Bug 88253 - Download thumbnails from the camera in reverse order
Summary: Download thumbnails from the camera in reverse order
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Sort (show other bugs)
Version: 0.7.0
Platform: unspecified Linux
: NOR wishlist with 10 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-27 19:46 UTC by Rivo Laks
Modified: 2022-01-27 16:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rivo Laks 2004-08-27 19:46:55 UTC
Version:           0.7.0-cvs (using KDE 3.3.0, compiled sources)
Compiler:          gcc version 3.4.1
OS:                Linux (i686) release 2.4.26

It would be great if in the camera dialog (the one which shows all the images in the camera), thumbnails of pictures could be downloaded starting from the last (i.e. most recent) one. This way, if I have lots of pictures in camera, I could quickly see which ones I haven't downloaded into computer yet, without waiting for all the thumbnails to be downloaded.
You could make it a configuration option.

Rivo
Comment 1 Dennis Gnad 2005-02-07 20:34:57 UTC
This would be a really good idea !
I also have other ideas:
My camera always continues numbering, so even if there is no picture at all on the camera, the next picture taken will have the number from the picture that was taken before +1, so i always get new filenames...
I have exact ideas (it should be possible to set it for every camera independent):

Have an option to set a thumbnail-cache. Have three options:
1. off
2. continued numbering
3. non-continued numbering (maybe another name here...)

1) the cache is off ..
2) if you access the camera:
 a) first, checking which images are already cached and exclude them, then the thumbnails will be downloaded in reverse order to the cache
 b) thumbnails which are in the cache will be displayed
 c) thumbnails which are in the cache but not on the camera will be deleted
3) more simple, and not as effective
 a) thumbnails from cache will be displayed in reverse order
 b) thumbnails will be downloaded in reverse order and added to the cache

it would be GREAT if this would be added, this would really make digikam much more effective, much users would profit from it, especially if they have a digital camera with continued numbering, and that's not something rare !
Comment 2 caulier.gilles 2006-08-22 12:01:54 UTC
Rivo,

About "continued numbering support" wish, please make a new file in B.K.O. Do not mix the wished in the same file because implementation can have different issues and it can be infernal to rule.

Thanks in advance

Gilles Caulier
Comment 3 caulier.gilles 2006-08-25 14:49:17 UTC
The original subject of this file to identify the last pictures taken by a camera is implemented in svn trunk following B.K.O #107316. 

About the "continued numbering support", we need a camera activity log. Denis, please report your wish in #107316. Thanks in advance

I close this file now.

Gilles Caulier

*** This bug has been marked as a duplicate of 107316 ***
Comment 4 Mikolaj Machowski 2006-08-28 12:11:39 UTC
>---- Status|NEW                         |RESOLVED
>          Resolution|                            |DUPLICATE


It is not simple duplicate. While scheme for identifying new images is
great sorting new images in the beginning would help further when
downloading photos.
Comment 5 caulier.gilles 2022-01-27 16:16:23 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=107316