Bug 86787 - Merge & Split PDF documents
Summary: Merge & Split PDF documents
Status: RESOLVED INTENTIONAL
Alias: None
Product: kpdf
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 190 votes (vote)
Target Milestone: ---
Assignee: Albert Astals Cid
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-08 12:58 UTC by Mark Purcell
Modified: 2009-08-26 23:09 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Purcell 2004-08-08 12:58:47 UTC
Version:           v0.3 (using KDE 3.2.3,  (testing/unstable))
Compiler:          gcc version 3.3.3 (Debian 20040422)
OS:                Linux (i686) release 2.6.7-1-686

Desirable functionality for KPDF would be the ability to merge and Split PDF documents, such as provided by the pdftk <http://www.accesspdf.com/pdftk>
Comment 1 André Marcelo Alvarenga 2005-02-27 19:09:43 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Albert Astals Cid 2005-02-28 20:43:14 UTC
I am about to mark that bug as invalid.
Do we really want KPDF to do that, IMHO KDPF is a PDF viewer, not a PDF editing tool.

What do you guys think?
Comment 3 Sebastian Frei 2005-02-28 21:07:13 UTC
KPDF is a viewer, you're right.
BUT it would nevertheless be very desirable to have this functionality.

I have often the situation, where I have multiple PDF files with odd page numbers and I want to print them all as a booklet (page number dividable with 4). To have a menu point "Load another pdf and append to the end" would be very helpful. The split functionality could be done with "Save pages <..> as extra file", but this is nearly similar with "Print as PDF".
Comment 4 rgpublic 2005-02-28 22:00:08 UTC
As someone who is working in an adv. agency and therefore having
to do with pdfs very often I want to stress the following points:
1) A fast, unbloated PDF viewer for KDE is certainly desireable
2) An app like Acrobat *PRO* is badly needed for the Linux desktop as well
3) Open Source programming resources are scarce so it would be
really bad if there would be the need to have two separate versions.
4) Firefox shows that a comprehensive, easily extensible architecture
doesnt necesarrily mean bloat. The solution: A plugin architecture
(Perhaps this can be achieved with KParts technology here as well?)
5) Adobe Acrobat also uses a plugin architecture. Unfortunately
many useless plugins are enabled in the default PDF viewer by default
and there is no easy way for the user to disable them. There is no
need to repeat that error.

Apart from all that I think that extracting pages from a PDF is not
a thing that I would consider "bloat", even in a viewer. I would
understand if other demands like a ruler or color picker (I was always
dreaming about these in a Linux PDF viewer) were denied here. Extracting
pages is everyday use. Imagine you have a large 200 pages manual and just
need a single page. There is no way whatsoever for the average user to
do this. This is very bad in Adobe Reader already IMHO. It would be great
if an Open Source PDF viewer really had an advantage (in terms of
features) in contrast to what's commercially available.

Thanks for listening (and already making KPDF a really great viewer).

Comment 5 Albert Astals Cid 2005-06-25 12:58:41 UTC
OK, guys, I'm probably implementing this in a weeks time, just need to know the use cases you want to do with that, exposing all pdftk functionality through a GUI is probably "impossible" so just tell me the exact things you would like to do using kpdf.
Comment 6 Gilles Schintgen 2005-06-25 22:42:52 UTC
OK, first for those who want to split PDFs. This is already possible. Just print to the virtual PDF printer and select the page range you want. But compared to pdftk this is only a workaround since AFAIK the "print method" involves conversion from pdf to ps and back to pdf which could lead to problems. Furthermore pdftk would be faster. That's why it'd be nice if a separate "Split PDF" menu entry could be provided. (I wouldn't need any advanced capabalities. Range specification as for printing would satisfy my needs.)

What I really need sometimes is the possibility to merge PDFs. Mostly this involves concatenating different PDFs, so the aforementioned "Append another PDF" functionality would be more than sufficient. Here's a use case: create some text document in LaTeX or OpenOffice.org and create a cover page in Scribus. Then join the two PDFs.

Moving pages around could be useful in very rare circumstances but I can't think of a realistic use case right now.

Thanks for working on this! KPDF is by far the most usable PDF viewer available.
Comment 7 rgpublic 2005-06-26 10:58:15 UTC
I agree to #6.
Moving pages around is not really necessary for me.
By far most import: A menu entry like in Adobe Pro: "Extract pages..."
Then you can select a page range. Preselected is the current page, i.e.:
From: <1> To: <1>
Printing to PDF is not a workaround for professional use. I dont want
to bet on all the problems occuring there when routing the stuff through
Ghostscript. On many system GS 7.x is still installed due to supposed
printing problems with recent version. These version destroy all spot
colors on printing for example.

Merging PDFs: I dont really need that, but I can imagine that an Append
pages... could be useful for many people.
Comment 8 Mark Purcell 2005-06-26 16:14:13 UTC
As per the original request the ability to extract a page range (SPLIT) and append (MERGE) a PDF document are the most important.

You also might want to take some code from the PDF tookkit service menu:

http://kde-apps.org/content/show.php?content=18545
Comment 9 Jonny McCullagh 2006-03-08 22:08:52 UTC
From a business perspective and as someone who trains people in Acrobat this functionality (and a few more) is essential. I regularly need to compile a single report as a PDF appending spreadsheets, documents etc.
I would therefore like to see menus like:
Modify -> Pages -> Insert Pages.. (i.e. Append)
Modify -> Pages -> Delete Pages.. 
Modify -> Pages -> Extract Pages..
Modify -> Pages -> Rotate Pages..

It would also be good if we could move/reorder the pages in the thumbnails panel by clicking and dragging.

I could also do with a few other options which are not as important as the above but would mean I could stop booting to Windows to use Acrobat:
Modify -> Pages -> Crop (as PDF files from commercial printers sometimes show the crop marks and margins)
Modify -> Document Properties (Meta data, security?)
I'd also like to see a few Forms features but I am probably the only one.
Also tools like highlighting and pen are much less important to me than the above.

I understand that KPDF is not aimed at being an editor but we need an alternative to Acrobat. Thanks for the hard work - I'd like to create some icons so I'll take a look at that but I think there are many icons from other apps which could be used.
Comment 10 Pascal d'Hermilly 2006-07-23 22:19:57 UTC
#5 I aggree with #9

I scan my important documents on an scanner with a feeder and it just sends the whole thing as a pdf file to me on an email. 
If it was implemented I could use it to take my 71 page pdf and divide it into the papers that it actually contain.

Offtopic: I simply LOVE kpdf. Thank you so much for making such a brilliant tool for my KDE desktop :D
Comment 11 Jonas Vejlin 2009-04-25 21:40:08 UTC
Is kpdf still maintain and if it is not should the wish be moved to okular?
Comment 12 m.wege 2009-04-26 09:05:46 UTC
You are right, this and all other wishes which are not already fullfilled in okular should be moved there. The rest of bugs and wishes on Kpdf should be closed.
Comment 13 Jonas Vejlin 2009-04-26 10:04:10 UTC
Are there an easy way of during that or should all non-fixed manual looked trough?
Comment 14 Jonas Vejlin 2009-04-27 09:26:38 UTC
#12: Are you during all the moving of bugs/wishes since I dont have permission to do so?
Comment 15 Albert Astals Cid 2009-08-26 23:09:16 UTC
Closing this wish.

kpdf is no longer under development and the okular team has stated is not interested in this feature.

Thanks a lot for sharing your opinion with us.

You might be interested in posting this wish into the brainstorm forums at http://forum.kde.org/brainstorm.php as a separate application and someone might pick it up to implement it