Bug 83642 - quanta: Please allow konqueror proxy to be disabled in FTP upload
Summary: quanta: Please allow konqueror proxy to be disabled in FTP upload
Status: RESOLVED UNMAINTAINED
Alias: None
Product: quanta
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: András Manţia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-19 12:43 UTC by Ben Burton
Modified: 2015-10-10 08:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Burton 2004-06-19 12:43:48 UTC
Version:            (using KDE KDE 3.2.3)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Received through the Debian BTS (#205004).

I had a project which should be uploaded via ftp. So I entered the right
hostname, username, and password. Then I clicked "Upload", and a message
box appeared, asking me "$hostname seems to be unreachable. Continue
anyway?". I answered "yes", and the messagebox disappeared.

The caret continued blinking in the edit field, and whenever I pointed
the mouse onto a button, it was highlighted (as normal), but I could not
click on it nor could I press any key. The dialog was frozen.

The solution was to disable the ftp proxy settings in Konqueror.

I think quanta should provide a way to use ftp without proxy, even if it
were configured for Konqueror.

(end of debian bug report)

This was originally reported against 3.1.2, and things have changed a little.  I tried in on 3.2.3 where konqueror was configured with a proxy that I cannot access (i.e., the proxy should time out).

The first time I tried the upload, it gave an immediate "host inaccessible" error followed by a "could not create directory" error at which point it took me back to the upload dialog.  It all happened so fast, I can only assume it wasn't trying to connect to the proxy at all.

I hit Upload again however, and this time it gave the same "host inaccessible" error and then waited for a while and gave the expected "proxy timed out" error (and brought me back to the dialog).

At any rate, there still doesn't seem to be an option for disabling the konqueror proxy for a quanta project upload, and it seems like a fine thing to allow (since the usual FTP proxy might not allow write access).  So the symptoms have changed since the original debian bug was reported, but the basic request of "please allow FTP upload without proxy even if konqueror is configured to use one" still appears valid.

Thanks - Ben. :)
Comment 1 Olivier Vitrat 2007-06-11 19:27:05 UTC
2007/6/9, Roland Illig <roland.illig@gmx.de>:
> Olivier Vitrat wrote:
> > Hi,
> >
> > The Debian Qt/KDE team is trying to update the bug status of some old
> > bugs in the BTS, and I'm helping with this task.
> >
> > Some time ago, you've reported bug number 205004 "quanta: FTP upload
> > fails when a proxy is set in Konqueror->Proxy configuration" to
> > Debian's Bug Tracking System. You can read the bug report at:
> >
> >      http://bugs.debian.org/205004
>
> You can close the bug report, as I am no longer using Quanta, so I
> cannot reproduce it.
>
> Roland
>

Comment 2 Christoph Cullmann 2015-10-10 08:43:06 UTC
Dear users,

the Quanta application ceased to exist over 5 years ago. For some of the use cases of Quanta there are nowadays KDevPlatform plugins available (like PHP/Python/... language support plugins).

Therefore the old Quanta bugs will now be closed, the Quanta bugzilla product is already closed for new reports.

Greetings
Christoph