Bug 82979 - add possibility to change brightness & contrast & gamma
Summary: add possibility to change brightness & contrast & gamma
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: HI wishlist with 329 votes (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: usability
: 136512 322273 325701 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-06-07 11:24 UTC by Melchior Franz
Modified: 2022-11-15 20:55 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.12


Attachments
Brightness/Contrast/Gamma item eating image space (416.28 KB, image/webp)
2022-11-05 10:43 UTC, PK
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Melchior Franz 2004-06-07 11:24:36 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

Very often pictures are too dark to see enough detail. I would like to have keystrokes available to make pictures brighter/darker (like b/B in kuickshow), and maybe also to change contrast. One needs to use kuickshow as an "external tool" to achieve this now, which hasn't even a key bound. Until this is implemented, gwenview is only a "bright image viewer" for me.  :-(
Comment 1 Hackeron 2004-06-17 22:06:05 UTC
Dont forget gamma as well. I would really like this kind of functionality as well. Similar to the way kuickshow handles it.

If only kuickshow worked outside of KDE :(... Fortunately gwenview does work, and developers are very helpful with feature requests :)
Comment 2 Melchior Franz 2004-12-01 12:00:46 UTC
Woohoo ... many thanks to Lubos & Aurelien for the fulfillment of this wish!  :-)
Comment 3 Melchior Franz 2008-01-16 20:15:53 UTC
Regression in KDE4.0 -- feature not yet (re)implemented or just dropped?
Comment 4 Aurelien Gateau 2008-01-16 21:35:57 UTC
Not yet reimplemented (among others...).

Aurélien
Comment 5 Melchior Franz 2008-01-16 22:05:12 UTC
Ahh, thanks! That's good news. I was a bit worried that this could have become one of the features that are considered too special and for this reason became victim of an UI un-cluttering effort (a.k.a. gnomification ;-)

In the last gwenview there was a dialog for brightness/contrast/gamma -- which I never used: I very much preferred to use the g/G (gamma), b/B (brightness) and c/C (contrast) keys. This allows for convenient browsing in fullscreen mode and quick adjusting.

In some cases it's just not an option to adjust images in another application and to store them to the disk (thus removing the need for this feature in gwenview):

- images on non-writable medium
- images shared with others (e.g. in a CVS/SVN/git checkout) with different monitor settings and/or environments
- temporary lighting problems (sun in your back)
- necessity to temporarily see details in dark parts
Comment 6 bgn66922 2008-08-29 04:21:51 UTC
I really missed this feature.
And I don't want to install digiKam, just for such simple use.

Will it be back before KDE 4.2?

Regards.
Comment 7 bgn66922 2009-01-22 02:27:22 UTC
Still no news?
Do I have to use "the GIMP" only to fix a too dark photo? :-)
Comment 8 Aurelien Gateau 2009-01-22 10:43:02 UTC
So many feature requests... so little free time... maybe in 4.3?
Comment 9 alexpremie 2009-08-19 21:55:45 UTC
Alas... not in kde 4.3....
Export to fessebouc or apod is so important....

maybe in kde 5.17 ??
Comment 10 Christoph Feck 2013-10-06 14:02:37 UTC
*** Bug 325701 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2013-10-06 14:03:07 UTC
*** Bug 322273 has been marked as a duplicate of this bug. ***
Comment 12 lorenzo 2017-09-09 02:07:43 UTC
This feature is still missing in version 17.08.0.
Comment 13 Nate Graham 2017-09-11 15:21:30 UTC
*** Bug 136512 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Feck 2018-04-03 10:56:55 UTC
How to best address this?

We have tickets that want a dialog with default settings, maybe because the monitor is not correctly calibrated. We have tickets that want temporary view settings using keyboard shortcuts. And it is not clear if they expect the changes also affect saved images, and if they should be applied before or after ICC color correction.

While technically the adjustments are relatively easy, I wonder what's the best way forward regarding the UI and UX. Are the 'bBcCgG' keys free for usage? How about other keys that change temperature or saturation; my viewer uses 'tT' and 'kK' for these.
Comment 15 Yatman 2018-04-03 13:52:38 UTC
It would be really great if you can implement this feature.
As for me I need the possibility to save changes. I think changing brightness/contrast/gamma without saving or without any message could be a little confusing for someone.
Comment 16 null 2018-04-03 15:34:01 UTC
In Gwenview 1.4 it worked this way:
- "View → Colours" menu
- Increase/Decrease Gamma/Brightness/Contrast actions
- Ctrl-(Shift)-B/C/G shortcuts
- "Adjust B/C/G" dialog with a live on-canvas preview and a "Defaults" button (setting all values back to 0)
- All changes only temporarily affected the current image.

I guess we could reimplement this, and:
- Add temperature and saturation
- Drop "Ctrl" in the shortcuts, i.e. (Shift)-B/(C)/G/T/S (the only conflict is with Shift-C for Crop, so we'd need to either change Crop or use a different letter for Contrast – I'd prefer the latter)
- Add an entry to the "Operations" panel
- Consider changing the (external) dialog to the inline style as used for Crop
- (later) Add the ability to save the changes back to the image

> the monitor is not correctly calibrated
That should be solved at the system level, i.e. either in the Gamma KCM or by improving colour profile support in general. 

For adjusting multiple images, it might be worth bringing back the KIPI plugins for batch editing. However, probably the adjustments would have to be done for each image individually anyway, as they mostly depend on the image itself.

IOW, to make this manageable there needs be a clear separation:
- Monitor issues are none of Gwenview's business.
- Image/Camera imperfections are good candidates for correction in Gwenview.

> applied before or after ICC color correction
I might be wrong, but currently I'd imagine it could work this way:
Image on disk → Apply transformations (Crop, Rotate, Gamma etc.) → Display (obeying zoom level, ICC profile etc.)

> my viewer
If the viewer had a name, I could test it out, perhaps leading to some inspiration… ;)
Comment 17 Christoph Feck 2018-04-03 18:49:58 UTC
I never released it. I call it 'kv': http://imagezero.maxiom.de/files/kv.tar.xz
(not all keys in README work)

There is no GUI, it only has a Quit item in RMB menu because I once got stuck on a keyboardless tablet ;)
Comment 18 null 2018-04-10 22:21:00 UTC
> I call it 'kv'
Nice ;) You can even toggle each RGB channel separately (although extra actions for that in Gwenview would probably clutter up the UI too much, and 1/2/3 are already taken for the ratings…). Now we only need someone implementing the colour features in Gwenview.
Comment 19 John 2021-07-05 14:51:28 UTC
(17 years?! Wow!!! Really?! This is old!!!)

Anyway, i would like to say this is desirable for me to.
Currently i have to load Krita just to adjust contrast. it's somthing that takes a couple of seconds - far less than loading Krita...

So... it's kind of an upvote for this mummy-age issue ;)
Comment 20 PK 2021-10-04 06:12:38 UTC
One used to be able to change brightness and contrast in Krita. But they removed this option because there already was a way (far more difficult) to do this.
Now I have to install Gimp to do this.
This would be a great addition to Gwenview!
ps.
Would it be difficult to borrow some code of Krita?
Comment 21 Bug Janitor Service 2022-09-30 13:20:13 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/gwenview/-/merge_requests/160
Comment 22 Nate Graham 2022-10-29 16:22:48 UTC
Git commit cc1ae77a9e9f1cd4ce319c50f76076df032a740d by Nate Graham, on behalf of Ilya Pominov.
Committed on 29/10/2022 at 16:18.
Pushed by ngraham into branch 'master'.

Add possibility to change brightness & contrast & gamma

M  +2    -1    app/gwenviewui.rc
M  +28   -1    app/imageopscontextmanageritem.cpp
M  +1    -0    app/imageopscontextmanageritem.h
M  +4    -0    lib/CMakeLists.txt
A  +108  -0    lib/bcg/bcgimageoperation.cpp     [License: GPL]
A  +59   -0    lib/bcg/bcgimageoperation.h     [License: GPL]
A  +121  -0    lib/bcg/bcgtool.cpp     [License: GPL]
C  +21   -24   lib/bcg/bcgtool.h [from: app/imageopscontextmanageritem.h - 051% similarity]
A  +144  -0    lib/bcg/bcgwidget.cpp     [License: GPL]
A  +58   -0    lib/bcg/bcgwidget.h     [License: GPL]
A  +129  -0    lib/bcg/imageutils.cpp  *
A  +39   -0    lib/bcg/imageutils.h  *

The files marked with a * at the end have a non valid license. Please read: https://community.kde.org/Policies/Licensing_Policy and use the headers which are listed at that page.


https://invent.kde.org/graphics/gwenview/commit/cc1ae77a9e9f1cd4ce319c50f76076df032a740d
Comment 23 Christian Hartmann 2022-11-05 06:18:17 UTC
Great! I've been missing this feature for ages :)
Comment 24 PK 2022-11-05 10:43:18 UTC
Created attachment 153489 [details]
Brightness/Contrast/Gamma item eating image space

Great that this feature now hit Gwenview. But look how much the line: "Adjust Brightness/Contrast/Gamma" cost from the image-space. And I'm sure it will be the same, if not worse, in e.g. my own language (Dutch).
Perhaps shorten the terms?
Comment 25 John 2022-11-07 15:35:53 UTC
(In reply to PK from comment #24)
> Created attachment 153489 [details]
> Brightness/Contrast/Gamma item eating image space
> 
> Great that this feature now hit Gwenview. But look how much the line:
> "Adjust Brightness/Contrast/Gamma" cost from the image-space. And I'm sure
> it will be the same, if not worse, in e.g. my own language (Dutch).
> Perhaps shorten the terms?

I noticed that too. And i don't like it either!

Maybe something like "Image Adjustments" or "Color Adjustments"...
Comment 26 Ilya Pominov 2022-11-15 20:55:40 UTC
(In reply to John from comment #25)
> (In reply to PK from comment #24)
> > Created attachment 153489 [details]
> > Brightness/Contrast/Gamma item eating image space
> > 
> > Great that this feature now hit Gwenview. But look how much the line:
> > "Adjust Brightness/Contrast/Gamma" cost from the image-space. And I'm sure
> > it will be the same, if not worse, in e.g. my own language (Dutch).
> > Perhaps shorten the terms?
> 
> I noticed that too. And i don't like it either!
> 
> Maybe something like "Image Adjustments" or "Color Adjustments"...

Agree. I send MR https://invent.kde.org/graphics/gwenview/-/merge_requests/169