Bug 82399 - HTML templates (with input widgets) for composing Emails
Summary: HTML templates (with input widgets) for composing Emails
Status: RESOLVED DUPLICATE of bug 1015
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.6.2
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-28 17:42 UTC by Juergen Gerner
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Gerner 2004-05-28 17:42:37 UTC
Version:           1.6.2 (using KDE 3.2.2, Gentoo)
Compiler:          gcc version 3.3.3 20040217 (Gentoo Linux 3.3.3, propolice-3.3-7)
OS:                Linux (i686) release 2.6.4-gentoo-r1

I've got an idea for a feature that I didn't see anywhere yet. I thought about the needs of companies at Email writing. For snail mails, most companies have a stationary (a letter template), where they just print the current date, the text and so on. They do this for the following reasons:
1. It saves time and money
2. The letters have the same design at all ("Corporate Design")

So it would be nice to get these advantages to Emails. I imagine a template system for KMail: The templates are in HTML format, and have placeholders in it. At composing, the placeholders will be replaced with LineEdits, TextEdits and ComboBoxes, where the writer can input text or select pre-defined values. Before sending, the values of the fields will be inserted as normal text at the specific place.
Additionally, some placeholders can be used to automatically fill in system values, e.g. the current date or the username.

Here's a small example how such a template could look like:
=========================================================
<body bgcolor="#FFFFFF" text="#000000">
<font face="CorporateDesignFont" size="10pt">
<table border="0" cellpadding="5">
<tr><td>###COMBOBOX###Mr.###Ms.###</td></tr>  <!-- title -->
<tr><td>###LINEEDIT###</td></tr>              <!-- correspondent's name -->
<tr><td><b>###LINEEDIT###</b></td></tr>       <!-- company's name -->
<tr><td><br><br></td></tr>
<tr><td><i>Our city, ###DATE###<br>           <!-- current date -->
Our ref.: ###USER###</i></td></tr>            <!-- login name -->
<tr><td><br><br></td></tr>
<tr><td>###TEXTEDIT###</td></tr>              <!-- the message -->
<tr><td><hr></td></tr>
<tr><td>Our company<br>                       <!-- some indications -->
Our street<br>
Our city<br>
...</td></tr>
</table></font></body>
=========================================================

This template allows to select a title for the receiver, to fill in the name of the receiver and his/her company, and, of course, to write the message. It fills in automatically the current date and the username. And the template has informations about our company at the end, and because these infos are stored statically in the template, no Email writer can change them.

Maybe these templates can be selected manually, or combined with the identity management...

Tell me your thoughts about it.
Regards,
Juergen
Comment 1 Ismail Donmez 2004-07-20 21:02:07 UTC

*** This bug has been marked as a duplicate of 1015 ***