Bug 81757 - Impossible to log in as root
Summary: Impossible to log in as root
Status: RESOLVED DUPLICATE of bug 78948
Alias: None
Product: kdesu
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdesu bugs tracker
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-17 20:17 UTC by Casteyde.Christian
Modified: 2008-06-18 23:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Casteyde.Christian 2004-05-17 20:17:28 UTC
Version:            (using KDE KDE 3.2.2)
Installed from:    Compiled From Sources
Compiler:          gcc 3.3.3 
OS:                Linux

As of KDE 3.2.2, kdesu does not want to log in as root.
It says "Invalid password", even if the password is the
right one.

It finds and start su, but it simply does not work.
If I start it from konsole (for instance,
"kdesu kcmshell k3bsetup2"), I get :

kdesu (kdelibs): [process.cpp:263] Running `/bin/su'
kdesu (kdelibs): [su.cpp:180] Read line <Password: >
kdesu (kdelibs): [process.cpp:263] Running `/bin/su'
kdesu (kdelibs): [su.cpp:180] Read line <Password: >
kdesu (kdelibs): [process.cpp:350] Child pid 19006
kdesu (kdelibs): [su.cpp:180] Read line <>
kdesu (kdelibs): [su.cpp:180] Read line <-c: -c: No such file or directory>

(please note the double "-c:", quite strange).

It therefore appears the environment for su is not set up
correctly (especially the PATH). My /etc/profile did adds
/opt/kde/bin to the PATH envar. My /etc/logins.def also does.
It doesn't work even for konsole / bash 
(kdesu /opt/kde/bin/konsole for instance)
Didn't manage to get it work, anyway, the error message is wrong
(the password is right). Maybe the command line used to start
su is wrong also.

CC
Comment 1 Waldo Bastian 2004-05-17 21:49:58 UTC

*** This bug has been marked as a duplicate of 78948 ***
Comment 2 Ingo Wagener 2004-12-18 10:07:38 UTC
I have just installed Suse9.2 and all of a sudden I experienced the above problem. Has it not been incorporated into the general update yet?