Bug 81436 - does not work if artsd has crashed
Summary: does not work if artsd has crashed
Status: RESOLVED INTENTIONAL
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 30 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-12 16:43 UTC by Trevor Feeney
Modified: 2006-06-11 12:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Trevor Feeney 2004-05-12 16:43:48 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

if a program has caused artsd to crash and Amarok is still running, it will not play any songs unless it is restarted
Comment 1 Stephan Binner 2004-05-15 10:33:30 UTC
Not surprising, or? :-)
Comment 2 Wouter Deconinck 2004-05-26 18:56:11 UTC
Can amaroK pick up again when artsd is restarted after a crash?  I don't know anything about the communication with artsd, but the 'd' makes me think of polling artsd until it is started (once a sec or so)...
Comment 3 Nicholas Pilon 2004-07-18 19:41:51 UTC
Expected behavior is that it should restart artsd quietly in the background. This is what other things (KDE notifications, JuK) seem to do if they do not find an artsd running.
Comment 4 deepak 2004-09-09 14:59:07 UTC
I have seen the same behaviour. Earlier, I thought it was a Mandrake specific bug - but I am now seeing the same thing in SuSE. I frequently kill artsd because it doesn't work well with mplayer for me (too much latency). After watching a movie on mplayer - it's very irritating to find amarok no longer works. Have to restart the app. Please fix this! 

Comment 5 Mark Kretschmann 2004-09-10 12:18:37 UTC
Using aRts engine is not recommended. Use xine or gstreamer instead.
Comment 6 Max Howell 2004-09-18 01:08:35 UTC
This does seem a little like complaining that your operating system freezes if you kill the kernel.
Comment 7 Damir Perisa 2004-09-26 20:28:58 UTC
some other situation that is very much related to this bug:


1) sound-device is occupied by other app (mplayer)

2) artsd starts against /dev/null, if i run a kde app (e.g. kmail), so that notifications work (this is handeled in kdeinit, i think)

3) mplayer finishes and gives sound-device free

4) artsd is still running on /dev/null

5) starting amarok with arts engine, amarok seems happy and uses the existing artsd that runs against /dev/null --- but unfortunately, no music can be heard (no wonder, my speakers are not connected to /dev/null ;-) )

expected 5) amarok detects that arts is running on /dev/null and tries to restart it - if unsuccessfull, amarok gives feedback echo "Sorry, arts is running on /dev/null or crashed and i cannot restart it, please restart it by hand or use other playback-engine"

Comment 8 Christian Muehlhaeuser 2005-01-04 06:59:13 UTC
sorry, i dont think it's amarok's responsibility to handle these situations. and as mentioned: prepare to name arts along with the words dinosaurs and vhs ;-)

regards,
muesli