Bug 81068 - Disregards "Generate accessors methods" setting in CPP generation
Summary: Disregards "Generate accessors methods" setting in CPP generation
Status: RESOLVED DUPLICATE of bug 84739
Alias: None
Product: umbrello
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Umbrello Development Group
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-07 00:20 UTC by Gregory Shpitalnik
Modified: 2004-07-08 21:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gregory Shpitalnik 2004-05-07 00:20:12 UTC
Version:            (using KDE KDE 3.2.0)
Installed from:    I Don't Know
OS:          Linux

Umbrello C++ generator always generates accessors for
class attributes even when  "Generate accessors methods" setting is not marked.

It would be also nice to take into account class attributes prefix
like "m_" when generating accessors methods.
For instance if you have class attribute "m_name" then
generate accessors get_name()/set_name() rather than
get_m_name()/set_m_name().
It might be helpfull to add "Class attributes prefix" setting to the
C++ Code generation settings and generate accessors with regard to this setting.
Comment 1 Oliver Kellogg 2004-07-08 21:45:01 UTC
I tried solving this one (81068) but I'm afraid I'll have to pass up.
Marking this as duplicate of 84739 instead of vice versa
because the explanations at 84739 are more helpful.


*** This bug has been marked as a duplicate of 84739 ***