Bug 80988 - kmail corrupts index entries of old mails (from older kmail versions?)
Summary: kmail corrupts index entries of old mails (from older kmail versions?)
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: index (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR major with 80 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 85749 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-05-05 21:20 UTC by Ulrich Möhrke
Modified: 2010-02-14 13:51 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The empty messages which get created by reindexing (97 bytes, text/plain)
2004-09-09 22:43 UTC, F Fracassi
Details
Sorry, was not the right file, ignore (8.55 KB, text/plain)
2005-02-14 21:40 UTC, Ulrich Möhrke
Details
Mail with described problem (3.04 KB, text/plain)
2005-02-14 21:50 UTC, Ulrich Möhrke
Details
Mail with problem (5.79 KB, text/plain)
2005-02-14 21:54 UTC, Ulrich Möhrke
Details
Mail with problem (1.74 KB, text/plain)
2005-02-14 21:59 UTC, Ulrich Möhrke
Details
Mail with problem (2.35 KB, text/plain)
2005-02-14 22:08 UTC, Ulrich Möhrke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Möhrke 2004-05-05 21:20:26 UTC
Version:            (using KDE KDE 3.2.2)
Installed from:    Debian testing/unstable Packages
OS:          Linux

I have my mails in local folders (downloaded from pop3).
Kmail destroyes mails when I'm setting the cursor at a line of a mail in the list of mails in one folder.

At the moment I can see that Kmail destroys mails older than november 2003.
Maybe it is because these are mails from an older version of kmail.
The header of a mail, which I want to try now containes the line:
User-Agent: KMail/1.5.3
The file is ~/Mail/sent-mail/cur/1063547443.1446.HiJY:2,S
After my test I have the same result as before. kmail tells me no "from" no "to", no address. Now I found, that the file itself seems not to be destroyed.

Now I tried one with the line
User-Agent: KMail/1.5.4
and this one is not destroyed. It is from november 1 2003.

I'm using kmail with german translation.

I don't want to include the whole mails because these are privat ones. If you need more infomation, please sent me a mail.

Regards,
Ulli
Comment 1 min 2004-05-11 12:54:00 UTC
I can confirm this, and I think it's a rather grave bug as it makes the user think whether it's worth using kmail as a longer-term email client.
Comment 2 Maksim Orlovich 2004-05-11 16:09:35 UTC
dataloss -> grave
Comment 3 min 2004-05-11 22:43:06 UTC
(well, it doesn't actually destroy the files, as the reporter has already mentioned, but one cannot make any use of them)
Comment 4 Till Adam 2004-05-29 21:09:06 UTC
Downgrading the severity to major, as it's not a real dataloss, just index corruption. Clarifying the description.
Comment 5 john turner 2004-06-03 18:58:32 UTC
RE: #4 ...as it's not a real dataloss, just index corruption.

I consider that a dataloss, as the kmail ( v 1.6.2 )
crashes at startup with old verson ( 1.5 ) mail folders
i.e. I want my mail back ( Please )
Comment 6 Ingo Klöcker 2004-07-17 23:23:43 UTC
I just tried to reproduce this by creating the index of the inbox folder (maildir format, 1000+ messages) with KMail 1.4.3. Then I started the current development version of KMail. KMail had no problems handling the inbox, i.e. it did neither crash nor forget messages.

So the only way to track down the problem is to provide me with the affected folders plus the corresponding index files. If that's not possible then there's not much we can do about this. Sorry.
Comment 7 john turner 2004-07-18 17:03:51 UTC
On 17 Jul 2004, Ingo KlXXcker wrote:

> ------- You are receiving this mail because: -------
> You are a voter for the bug, or are watching someone who is.
>
> http://bugs.kde.org/show_bug.cgi?id=80988
>
>
>
>
> ------- Additional Comments From kloecker kde org  2004-07-17 23:23 -------
> I just tried to reproduce this by creating the index of the inbox folder (maildir format, 1000+ messages) with KMail 1.4.3. Then I started the current development version of KMail. KMail had no problems handling the inbox, i.e. it did neither crash nor forget messages.
>
> So the only way to track down the problem is to provide me with the affected folders plus the corresponding index files. If that's not possible then there's not much we can do about this. Sorry.
>

1000 is only about 1/4 of the size of my message directory.
.
PLEASE TRY WITH a much larger sample than 1K

Because I can not read my older mail, I can not remove
mail that is not considered public. While 95% is
not sensitive material, I can not take the chance that
some of it is not for puplic reading.

Thanks for the efforts, there must be a big problem with
this area of Kmail, as it is repeatable on my two computers
with the  SuSE9.1 versions
Also, there are many other people writing about
that BUG

Regards, and good hunting.

John


Comment 8 Till Adam 2004-07-23 08:32:59 UTC
*** Bug 85749 has been marked as a duplicate of this bug. ***
Comment 9 Michael Cziebalski 2004-08-05 11:31:47 UTC
Yep, I got that problem, too

SuSE9.1

All fields (date, ...) were "unknown"

All mails I clicked on got that efeect and were lost...
Comment 10 F Fracassi 2004-09-09 22:18:00 UTC
Seems that I have the same bug, too. 
As the other posters, I can't send the dir.

The problem doesn't seem to be related to the number of mails in the specific folder. The affected folder (inbox) contains 1576 messages, but I have much larger ones (ca. 16000). 

I think (not 100% sure though because I also swiched to kde 3.3 around that time) that this appeared when I used "Compact all folders". 
 I can't spot any pattern as to which messages disappeared. All messages I recived after the bug appeared are intact. Then from the two years before this only around 30 have survived. The older ones ar also intact.

Regenerating the .inbox.* files doesn't help either
Comment 11 F Fracassi 2004-09-09 22:43:30 UTC
Created attachment 7473 [details]
The empty messages which get created by reindexing

Well the last statement is not 100% correct. After deleting .inbox.* and
restarting the messages reappear, but for each message an additional message us
created without contents. (see attachment.)
Comment 12 Till Adam 2004-12-28 14:42:46 UTC
Since we still don't have any data to reproduce the described behavior we are at a loss as to how to fix it. Calling all stations, anyone able to reproduce this and willing to help us debug it, please stand up and be counted.
Comment 13 Ulrich Möhrke 2005-02-03 00:31:30 UTC
Hallo,

I will attache some mails for which I have the problem. Maybe this helps. 
After removing .inbox.index, .inbox.index.ids, .inbox.index.sorted I can see 
the information about the mails within the inbox but after click on the line 
the information is lost again. 

Kmail Version 1.7.1
Kontact Version 1.0.1
KDE Version 3.3.1

Regards,
Ulrich


On Tuesday 28 December 2004 14:42, Till Adam wrote:
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>
> http://bugs.kde.org/show_bug.cgi?id=80988
>
>
>
>
> ------- Additional Comments From adam kde org  2004-12-28 14:42 -------
> Since we still don't have any data to reproduce the described behavior we
> are at a loss as to how to fix it. Calling all stations, anyone able to
> reproduce this and willing to help us debug it, please stand up and be
> counted.
http://diato.org/tablat.htm

Diskutieren Sie mit Experten aktuelle Fragen des modernen Managements
gesch
Comment 14 Ingo Klöcker 2005-02-13 00:12:22 UTC
Hi Ulrich, attaching the mails didn't work. Please attach them directly via the "Create a New Attachment" functionality of bugs.kde.org for this bug report, i.e. at http://bugs.kde.org/show_bug.cgi?id=80988.
Comment 15 Ulrich Möhrke 2005-02-14 21:40:39 UTC
Created attachment 9632 [details]
Sorry, was  not the right file, ignore

For this Mail I get the describeed problem.
Was it right to declaire the content type as plain text? Else send me a message
to upload again.
Comment 16 Ulrich Möhrke 2005-02-14 21:50:17 UTC
Created attachment 9633 [details]
Mail with described problem

Hopefully now I will send the right file.
Comment 17 Ulrich Möhrke 2005-02-14 21:54:40 UTC
Created attachment 9634 [details]
Mail with problem

please tell me if text/plain has not been the right choise
Comment 18 Ulrich Möhrke 2005-02-14 21:59:17 UTC
Created attachment 9635 [details]
Mail with problem
Comment 19 Ulrich Möhrke 2005-02-14 22:08:42 UTC
Created attachment 9636 [details]
Mail with problem

file name: 1065971490.1663.if1C:2,S
Comment 20 Ulrich Möhrke 2005-02-14 22:10:50 UTC
Comment on attachment 9633 [details]
Mail with described problem

file name: 1066320069.1065.920q:2,S
Comment 21 Till Adam 2005-02-16 21:59:05 UTC
The files you attached don't show any problem here, with KMail 1.8. I really don't know what to do with this bug...
Comment 22 Cornelius Claussen 2005-03-01 19:06:57 UTC
I had a (maybe?) similar problem and found KMail 1.7.1 to show this behaviour when it doesn't have write permissions to the file. (It does have read permissions of course). For me it shows the mail in the list after re-indexing, but whenever I click on the mail in the mail list, the subject changes to "No subject" and the sender to "unknown". Note that some older KMail versions worked fine with those files. You should check the ownership and permissions of the problematic files.
Comment 23 Ulrich Möhrke 2005-03-02 21:05:55 UTC
I had the same problem with permissions like Cornelius. I don't know, why I had different permissions (maybe old version of Kmail or restoring backups).
I don't know, why kmail needs write permission, but it should not be that no information is shown without write permission.
Comment 24 Cornelius Claussen 2005-03-04 12:20:00 UTC
as far as I remember this problem occured the first time when I upgraded from SuSE 8.2 to SuSE 9.0, so the change probably happend between KDE 3.1.1 and KDE 3.1.4.
Comment 25 Edwin de Jong 2006-01-25 17:03:18 UTC
I'm not sure if it is related, but when I open any new e-mail with mutt and later on try to open it with kmail I get the same behaviour as shown above.
Comment 26 Attila GOLONCSER 2008-02-11 06:59:02 UTC
I also have this problem desribed above, but with REAL data loss. My versions are.

$ kmail --version
Qt: 3.3.8
KDE: 3.5.8
KMail: 1.9.7

The number and the state of the messages are correct, but all the headers in the list are "unknown". All the corrupted mails have only these headers (but nothing else, my maildir folder is full with ~68 byte files):

Status: RO
X-Status: RC (or RAC, RT)
X-KMail-EncryptionState: N
X-KMail-SignatureState: N
X-KMail-MDN-Sent:

I came this problem when I filtered my messages (circa 270 in one task), and while the job kmail crashed. After restarting the same problem occured as in the main bug description, with the exception that I really lost my data from my folder.

Comment 27 Dominik Tritscher 2009-01-08 16:40:27 UTC
This bug still exists in KDE4. I used kmail 1.10.92 from Kubuntus KDE4.2beta2 packages.
Steps to reproduce:
- Change permissions of one or more mail-files of a local mail folder to read-only
- Look for the mail in kmails message list, you will notice the mail is listed correctly
- select the mail: the above described behaviour (empty header fields) occures
Comment 28 Dominik Tritscher 2010-02-14 13:51:01 UTC
I just tried with kmail 1.13.0 from Kubuntus KDE SC 4.4 PPA Packages.
The issue is not reproducible any more.