Bug 80055 - Kdesu report an error executing program with lower privileges
Summary: Kdesu report an error executing program with lower privileges
Status: RESOLVED DUPLICATE of bug 78948
Alias: None
Product: kdesu
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdesu bugs tracker
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-21 11:26 UTC by Marco Avidano
Modified: 2008-06-18 23:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Avidano 2004-04-21 11:26:52 UTC
Version:           Qt: 3.2.2 - KDE: 3.2.2 - KDE su: 1.0  (using KDE KDE 3.2.2)
Installed from:    Compiled From Sources
Compiler:          gcc-3.2.2 Configured with: ../gcc-3.2.2/configure --prefix=/usr --enable-shared --enable-threads=posix --enable-__cxa_atexit --disable-checking --with-gnu-ld --verbose --target=i386-slackware-linux --host=i386-slackware-linux Thread model: posix 
OS:          Linux

Running KDE as root, when I try to execute applications as different user with lower permissions, it return this error:

# kdesu -u user -c /opt/kde/bin/ksirc
kdesu (kdelibs): [process.cpp:263] Running `/bin/su'
kdesu (kdelibs): [su.cpp:180] Read line <-c: -c: Permission denied>

Alse a popup says "Su returned with an error". I never had this problem with KDE 3.2.1or previous version.
Comment 1 Stephan Binner 2004-04-21 11:31:28 UTC

*** This bug has been marked as a duplicate of 78948 ***