Bug 80018 - stronger distinction between file management and web browsing modes
Summary: stronger distinction between file management and web browsing modes
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-20 20:52 UTC by klee
Modified: 2009-09-16 21:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description klee 2004-04-20 20:52:34 UTC
Version:            (using KDE KDE 3.2.1)
Installed from:    Compiled From Sources

I am filing this bug to factor out discussion from Bug #8333 ("setting 'home page' is unintuitive"), where discussion of the merits of separating Konqueror into two separate applications is leading to much OT discussion.

The argument of the pro-separation crowd is roughly: Konqueror serves two cognitive purposes (file management and web browsing).  Forcing these two purposes into one application leads inevitably to a confusing GUI.  Therefore, Konqueror should be factored into two application modes, with greater differences between the GUI of these two modes.

I do not necessarily agree with the above.  As I said, I am posting this BR to move discussion out of BR #8333.
Comment 1 Aaron Peterson 2004-07-22 20:41:15 UTC
8333 depends on this bug actually.
and I must say it's a duisy.

It is so compoundingly frustraighting to not be able to open a web page, or a text document, from my computer, in it's own window, in text editing mode!

If I set it to open correctly for my own computer (trusted files), then the world wide web pages start doing funkey things...

A home file button is a great idea... but allowing only ONE?!!!!

I've been eagerly awaiting basic usability fixes since kde 3.1, (that I have observed in .. 2.x when I first saw kde)..  and this bug has 0 comments and 0 votes?  (maybe it's a new dupe)

anyway, This is the #1 problem going for kde.  it is not functional for basic tasks.  The internet isn't fast enough yet, for "network transparancy" to work yet... and I didn't even want it in the first place... because things that are on the network arn't under my control...

(/rant).... grrrrr...
Comment 2 James Richard Tyrer 2004-11-26 21:34:34 UTC
Re: Comment #2

Yes, this is a known bug, but you should check to see if there is a WishList item for it since it is not really on topic for this one.

The suggestion is that you should be able to select a seperate choice of File Association for HTTP than for local files.

What this actually comes down to should be that you could set a seperate File Association for "localhost.localdomain" or an alias for it.  To make this clear, if the URL has either ":/" or ":///" it is "localhost.localdomain" and if it has: "://" it is not.

--
JRT
Comment 3 Casper Planken 2004-11-27 13:00:54 UTC
I take this text from this bug description:
<i>where discussion of the merits of separating Konqueror into two separate applications is leading to much OT discussion</i>

To what extend is this really true (a pro-separation crowd)? I am not under the impression there are people who want 2 physical separate applications or there being a crowd? I think the whole basis for their argument is that there is not enough well designed usability around Konqueror's many universal abilities.

In my oppionion the user interface development is simply lagging behind Konqueror functionality, wish simply is the root of the whole problem.

Browsing modes (view profiles) are part of the solution. The problem is their current usability/implementation.
Comment 4 Dennis Gnad 2005-11-06 19:02:12 UTC
Another BIG problem are the bookmarks. I like to use bookmakrs for file managment, for different locations on my harddrive.

But I also want separate web bookmarks, so there aren't so much bookmarks in one menu point.

It's just the part with the "no-separation" that prevents me from using konqueror. I still use firefox, because konqueror is not ready to be a good browser, while preserving it as a good file manager.
Comment 5 michael papet 2006-03-01 03:04:42 UTC
Please note, that the many computer users actually fear using a file browser beyond "my documents" because they think they will break something.  They are far more likely to click on things that appear in a "browser" that looks like a web browser.

Putting time and effort making the file browsing mode look different won't make it easier to use.  I would argue the difference would make it as fearsome as a file browser in windows.  Sounds crazy.  But I do desktop support for a living and see it every day.

I prefer to think of Konqueror as the gui that unifies many browser types. (file/http/smb/etc.)  It's strength lie in that a folder at http://www.kde.org/folder looks and acts exactly like one at /home/user1.  The user doesn't care about modes, doesn't know one is FTP and the other is something else.  A good gui should follow that and not attempt to create distinctions.

Finally, you have other desktop environments with file browsers different than web browsers. They aren't generating as many adopters as KDE.  If there was more demand for this, I think you would see more file manager projects for KDE.
Comment 6 FiNeX 2009-09-16 21:49:08 UTC
A "stronger" distiction has been made in KDE 4 where dolphin is the default file manager.