Bug 79862 - Arabic-Indic digits (U+660 - U+669) are not recognizedas numeric data in kspread
Summary: Arabic-Indic digits (U+660 - U+669) are not recognizedas numeric data in kspread
Status: RESOLVED DUPLICATE of bug 178149
Alias: None
Product: calligrasheets
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Mandrake RPMs Linux
: NOR normal with 70 votes (vote)
Target Milestone: ---
Assignee: Laurent Montel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-18 05:26 UTC by Munzir Taha
Modified: 2009-05-04 22:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Munzir Taha 2004-04-18 05:26:18 UTC
Version:           Koffice 1.3 (using KDE KDE 3.2.0)
Installed from:    Mandrake RPMs
OS:          Linux

Arabic-Indic digits (U+660 - U+669) are not recognized as numeric data in kspread and hence we can't do any mathematical calcualtions based on them. We can't add, subtract, ... these numbers.

These numbers are widely used in Arabic countries and it's very essential to be supported.
Comment 1 Sebastian Sauer 2006-12-02 10:34:04 UTC
Related KDE-Thread "QLocale for float Arabic Numbers";
http://lists.kde.org/?t=114906958400001&r=1&w=2

Seems it would be needed to extend in http://websvn.kde.org/branches/koffice/1.6/koffice/kspread/valueparser.cc?view=markup e.g. readNumber to use QLocal::system().toDouble() ...
Comment 2 Stefan Nikolaus 2008-08-21 13:15:16 UTC
Check again with the upcoming 2.x series, please.
Comment 3 Chusslove Illich 2009-05-04 22:54:06 UTC

*** This bug has been marked as a duplicate of bug 178149 ***