Bug 79653 - Crash when invoking article spell checker when KNode configuration window open
Summary: Crash when invoking article spell checker when KNode configuration window open
Status: RESOLVED DUPLICATE of bug 75937
Alias: None
Product: knode
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-14 21:10 UTC by Tristan Miller
Modified: 2005-02-12 15:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2004-04-14 21:10:41 UTC
Version:            (using KDE KDE 3.2.1)
Installed from:    SuSE RPMs

Reproducibility
---------------
Always reproducible.  Use the following steps:

1) Settings->Configure KNode->Posting News->Spelling
2) Article->Post to Newsgroup
3) Type some text in the message body
4) Tools->Spelling
5) Select another language from the "Language" drop down box
6) A dialog pops up which says "You have to restart the dialog for changes to take effect".  Click OK.
7) All windows disappear and KNode dies a horrible death.

Step #3 appears to be necessary; otherwise no crash occurs.


Backtrace info:
---------------

This backtrace appears to be useless.
This is probably because your packages are built in a way which prevents creating of proper backtraces, or the stack frame was seriously corrupted in the crash.

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 16384 (LWP 7973)]
[New Thread 32769 (LWP 7974)]
[New Thread 16386 (LWP 7975)]
[New Thread 32771 (LWP 7976)]
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
0x415d7ab6 in waitpid () from /lib/i686/libpthread.so.0
#0  0x415d7ab6 in waitpid () from /lib/i686/libpthread.so.0
#1  0x40b038d3 in KCrash::defaultCrashHandler(int) ()
   from /opt/kde3/lib/libkdecore.so.4
#2  0x415d696c in __pthread_sighandler () from /lib/i686/libpthread.so.0
#3  <signal handler called>
#4  0x40f2b037 in QPtrVector<QConnectionList>::size() const ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#5  0x41273713 in QComboBox::activated(QString const&) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#6  0x40fc2322 in QComboBox::internalActivate(int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#7  0x41273905 in QComboBox::qt_invoke(int, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x40f29feb in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0x40f2a12a in QObject::activate_signal(int, int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0x4127baf1 in QListBox::selected(int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x40ffb803 in QListBox::mouseDoubleClickEvent(QMouseEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x40f61755 in QWidget::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0x40ec8c26 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0x40ec8788 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x40a832b4 in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kde3/lib/libkdecore.so.4
#16 0x40fc55d9 in QComboBox::eventFilter(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x089e3830 in ?? ()
#18 0xbfffe450 in ?? ()
#19 0x00000001 in ?? ()
#20 0x00000001 in ?? ()
Comment 1 Tristan Miller 2004-04-14 21:22:12 UTC
This may depend on or be related to Bug 79655 (wherein I suggested that the "You have to restart the dialog" message and its underlying machinations be removed entirely).
Comment 2 Tristan Miller 2004-04-14 21:34:55 UTC
Have done some more testing; seems the crash also occurs sometimes even when the preferences dialog is not open.  However, I'm unable to isolate exactly which circumstances cause it.
Comment 3 Tristan Miller 2004-07-14 16:08:27 UTC
Crash also occurs with KMail 3.2.91 (3.3 beta1) and KDE 3.2.91 (3.3 beta1).  Perhaps this is a problem with the composer or spelling checker in general.  Can someone please move this bug to the appropriate application?

Backtrace:
[New Thread 16384 (LWP 2124)]
[New Thread 32769 (LWP 1540)]
[KCrash handler]
#4  0x41a8a357 in QPtrVector<QConnectionList>::size() const ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#5  0x41dd36e3 in QComboBox::activated(QString const&) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#6  0x41b21a42 in QComboBox::internalActivate(int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#7  0x41dd38d5 in QComboBox::qt_invoke(int, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x41a8930b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0x41a8944a in QObject::activate_signal(int, int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0x41ddbac1 in QListBox::selected(int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x41b5af13 in QListBox::mouseDoubleClickEvent(QMouseEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x41ac0b20 in QWidget::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0x41a27b76 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0x41a276d8 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x415a4a0e in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kde3/lib/libkdecore.so.4
#16 0x41b24cf9 in QComboBox::eventFilter(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x088703d8 in ?? ()
#18 0xbfffe3d0 in ?? ()
#19 0x00000001 in ?? ()
#20 0x00000001 in ?? ()
#21 0x09a335f0 in ?? ()
#22 0x421567ce in __pthread_enable_asynccancel () from /lib/libpthread.so.0
#23 0xffffffe0 in ?? ()
#24 0x08117330 in ?? ()
Comment 4 Volker Krause 2005-02-12 15:20:05 UTC

*** This bug has been marked as a duplicate of 75937 ***