Bug 79635 - klipper error kills kicker
Summary: klipper error kills kicker
Status: RESOLVED DUPLICATE of bug 61412
Alias: None
Product: kicker
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash
Target Milestone: ---
Assignee: John Firebaugh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-14 15:01 UTC by bugs.kde.org
Modified: 2004-04-14 17:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugs.kde.org 2004-04-14 15:01:56 UTC
Version:            (using KDE KDE 3.2.1)
Installed from:    Unlisted Binary Package
Compiler:          gcc version 3.3.1 20030930 (Red Hat Linux 3.3.1-6) 
OS:          Linux

I get the following error:
     QClipboard: internal error, qt_xclb_wait_for_event recursed

At that point, the kicker panel and klipper both die. Restarting kicker manually (from a shell prompt) displays the klipper icon, with the history of previous copied text.
Comment 1 bugs.kde.org 2004-04-14 15:17:20 UTC
After posting the bug report, I got another kicker crash (the first one that has brought up a crash handler). Interestingly enough, after the "crash", now the panel remains visible, and klipper is functional.

Here's the backtrace:

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 16384 (LWP 2888)]
0x4120ff68 in waitpid ()
   from /lib/i686/libpthread.so.0
#0  0x4120ff68 in waitpid () from /lib/i686/libpthread.so.0
#1  0x40961ff8 in lt_dlfree () from /usr/lib/libkdecore.so.4
#2  0x4120ece6 in __pthread_sighandler () from /lib/i686/libpthread.so.0
#3  <signal handler called>
#4  0x40c0ab26 in QTextDrag::decode(QMimeSource const*, QString&, QCString&) ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#5  0xbfffe9c0 in ?? ()
#6  0x40c066bf in QClipboard::text(QCString&, QClipboard::Mode) const ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#7  0x40c0678c in QClipboard::text(QClipboard::Mode) const ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#8  0x416ea78f in KlipperWidget::clipboardContents(bool*) ()
   from /usr/lib/kde3/klipper_panelapplet.so
#9  0x416eae33 in KlipperWidget::newClipData() ()
   from /usr/lib/kde3/klipper_panelapplet.so
#10 0x416ebbf6 in KlipperWidget::qt_invoke(int, QUObject*) ()
   from /usr/lib/kde3/klipper_panelapplet.so
#11 0x416e5a4d in KlipperAppletWidget::qt_invoke(int, QUObject*) ()
   from /usr/lib/kde3/klipper_panelapplet.so
#12 0x40c5b42c in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#13 0x40c5b264 in QObject::activate_signal(int) ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x416f7dbb in ClipboardPoll::clipboardChanged() ()
   from /usr/lib/kde3/klipper_panelapplet.so
#15 0x416f7968 in ClipboardPoll::timeout() ()
   from /usr/lib/kde3/klipper_panelapplet.so
#16 0x416f7e28 in ClipboardPoll::qt_invoke(int, QUObject*) ()
   from /usr/lib/kde3/klipper_panelapplet.so
#17 0x40c5b42c in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x40c5b264 in QObject::activate_signal(int) ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x40f8e30b in QTimer::timeout() () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x40c7c732 in QTimer::event(QEvent*) ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x40bffeff in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x40bff50b in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x4080e2fd in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#24 0x40bef9c5 in QEventLoop::activateTimers() ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x40bab846 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#26 0x40c11f98 in QEventLoop::enterLoop() ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#27 0x40c11e48 in QEventLoop::exec() () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x40c00151 in QApplication::exec() ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#29 0x40085477 in kdemain () from /usr/lib/libkdeinit_kicker.so
#30 0x080485fb in kdemain ()
#31 0x412b3b5f in __libc_start_main () from /lib/i686/libc.so.6
Comment 2 Maksim Orlovich 2004-04-14 17:17:41 UTC

*** This bug has been marked as a duplicate of 61412 ***