Bug 78739 - Non-critical: Window lower border leaves margins in some cases
Summary: Non-critical: Window lower border leaves margins in some cases
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: decorations (show other bugs)
Version: unspecified
Platform: Slackware Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-30 14:59 UTC by sombragris
Modified: 2011-12-06 11:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of AlsaPlayer levelmeter using the Redmond windek (2.32 KB, image/png)
2004-03-30 15:01 UTC, sombragris
Details
Screenshot of the Alsaplayer levelmeter using the Quartz windec (2.13 KB, image/png)
2004-03-30 15:17 UTC, sombragris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sombragris 2004-03-30 14:59:53 UTC
Version:            (using KDE KDE 3.2.1)
Installed from:    Slackware Packages
OS:          Linux

Some of the window decorations provided with KDE 3.2.1 present an excessive lower margin with some apps. An example is the levelmeter of AlsaPlayer 0.99.x. This is not consistent, especially because there are other window decorations that use all the correct margins.

Here is the list of decorations that draw the windows correctly:
CDE
Glow
IceWM
KStep
Keramik
Laptop
Plastik
Quartz
System ++

Here is the list of decorations that draw the windows incorrectly:
BII
KDE 1
KDE 2
ModSystem
OpenLook
Redmond
Web

I have comparative screenshots and intend to attach them.

Please consider fixing this issue. Thanks for all your hard work.

Eduardo Sánchez
from Asunción, Paraguay, South America
member of the KDE-ES Spanish translation team
Comment 1 sombragris 2004-03-30 15:01:57 UTC
Created attachment 5466 [details]
screenshot of AlsaPlayer levelmeter using the Redmond windek

This is a screenshot of the levelmeter window of AlsaPlayer 0.99x showing the
increased lower margin in the Redmond window decoration.
Comment 2 sombragris 2004-03-30 15:17:34 UTC
Created attachment 5467 [details]
Screenshot of the Alsaplayer levelmeter using the Quartz windec

This is a screenshot of the AlsaPlayer 0.99x levelmeter using the Quartz window
decoration. This is the expected behavior.
Comment 3 Luciano Montanaro 2004-03-30 15:37:13 UTC
On Tuesday 30 March 2004 15:17, sombragris@sombragris.org wrote:
> ------- You are receiving this mail because: -------
> You are the assignee for the bug, or are watching the assignee.
>       
> http://bugs.kde.org/show_bug.cgi?id=78739      
> 
> 

Some styles can treat "Tool Windows" differently. Maybe the problem is related to 
that feature. I have never seen the problem though, since I don't have AlsaPlayer.
Can you try to increase the Window title font size to something large, like a 24pt,
and report the result? I am most familiar with the b2 code. Is the window resizable?

Luciano

Comment 4 sombragris 2004-03-30 15:57:00 UTC
Hi Luciano, thanks for commenting. I did what you requested. I changed the window title font to Tahoma 24 Bold and I can report that in BII and Redmond the lower border is still incorrect. There is no change.

Thanks,
Eduardo
Comment 5 sombragris 2004-03-30 15:59:31 UTC
I forgot to answer your second question. The window is not resizable. The window menu (Alt + F3 in the KDE default scheme) grays out the Resize command and the resize pointers do not appear on mouseover on the window borders.

Thanks,
Eduardo
Comment 6 sombragris 2004-03-30 20:04:30 UTC
pasting some email from Luciano and my answer:

On Tuesday 30 March 2004 11:12, Luciano wrote:
> 
> Thanks for the tests. What about the other styles? Is Quartz still 
> working correctly? And does B2 decorate the border with the 
> resizing handle (a small tab in the lower right corner) or without?
> If it doesn't, that would be a useful hint at where to look for 
> possible problems.
> 
> I'll try to check the decoration code this weekend.
> 
> Luciano
> 

Luciano, here are my results:

Behavior of window decorations in the Levelmeter AlsaPlayer window, 
using Tahoma 24 Bold as title font.

Windec          Works correctly?        Resize handle?
---------------------------------------------------------
BII             no                      no
CDE             no (1)                  no
Glow            yes                     no
IceWM           yes (2)                 no
KDE1            no (6)                  no
KDE2            no                      no
KStep           no (3)                  no
Keramik         no (3)                  no
Laptop          yes                     no
ModSystem       no                      yes (4)
Open Look       no                      yes (5)
Plastik         no (3)                  no
Quartz          yes                     no
Redmond         no                      no
System++        yes (2)                 yes (5)
Web             no                      no
---------------------------------------------------------

Hope this is useful.

Thanks,
Eduardo
Comment 7 sombragris 2004-03-30 20:09:29 UTC
more mail from Luciano, my answer is here:
> Thanks for the additional information.
> 
> Can you add these findings to the bug report, so that it is not lost, and 
> others can look at it? Since it does not affect one decoration only, 
> it could be a KWin problem, or an alsaplayer problem.
>   
> The problems marked (4) and (5) could be reported also as a different 
> bug (or wish).
> 
> (2) is a problem of the IceWM decoration;  
> 
> Ciao,
> Luciano
> 

I don't think it is an Alsaplayer problem because there was no such issue as far as I can remember in KDE versions 3.1x or lower. I remember clearly using alsaplayer with the KDE 1 and Redmond windecs (both of them affected by the bug) with no problem at all. Thus, it is highly likely that this is a KWin issue.

Thanks,

Eduardo
Comment 8 Lubos Lunak 2004-05-03 18:26:36 UTC
Those styles specify their minimum size larger than the window's size. At least for some of them the specified minimum size is unnecessarily large.
Comment 9 Thijs 2011-12-06 11:54:56 UTC
Styles are not what they were a 7 years ago ;)