Bug 78319 - Tiling window management support
Summary: Tiling window management support
Status: RESOLVED DUPLICATE of bug 59338
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-23 18:42 UTC by Helge Hoel
Modified: 2004-03-25 19:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Helge Hoel 2004-03-23 18:42:35 UTC
Version:            (using KDE KDE 3.2.1)
Installed from:    Gentoo Packages
OS:          Linux

Are there plans for this in KDE anytime soon? The idea of tiling is the idea to optionally break the window into rows/collumns to "sub-divide" the desktop into areas. When you maximize a window, it will only maximize within it's area. This is great for those of us running with high-resolution, cause we find ourself way to often in manually tiling applications like this. For example I want my webbrowser covering 80% of the screens width, but on the 20% which is left on the right side, I want kopete, some karamba-themes and whatnot, so that they're always visible no matter what I work on at the moment. If I could've just divided my screen into such frames, I wouldn't have to do this manually. I could just maximize konqueror, and it would maximize it's frame, but still staying off the last 20% (which then is another frame) where my kopete and karamba-themes stay. For a deaper introduction to tiling, I suggest you just read this article over at kuro5in. It explain the idea quite good, and show what window-managers that exist with tiling.

http://www.kuro5hin.org/story/2004/2/17/18567/0942
Comment 1 Lubos Lunak 2004-03-25 19:25:58 UTC

*** This bug has been marked as a duplicate of 59338 ***