Bug 78109 - "show desktop" breaks desktop switching
Summary: "show desktop" breaks desktop switching
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal with 3 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 85856 93391 95316 95607 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-03-20 23:09 UTC by Toomas
Modified: 2008-02-04 18:19 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toomas 2004-03-20 23:09:59 UTC
Version:            (using KDE KDE 3.2.1)
Installed from:    SuSE RPMs
OS:          Linux

Hello

Example1:
I'm on desktop 1. I press win+d (toggle showing desktop). Then i press ctrl-f2. All the windows rise up again and i'm still on desktop 1. I press AGAIN ctrl-f2 i get to desktop 2.

Example2:
I'm on desktop 2. I press win+d (toggel showing desktop). Then i press ctrl-f1. All the windows rise up and i'm still on desktop 2. I press ctrl-f1 AGAIN and i get to desktop 1.


/toomasr
Comment 1 Jorge Adriano 2004-06-20 11:40:26 UTC
Still present in KDE 3.2.3.
Using SuSE 8.2 rpms.
Comment 2 Anton 2004-06-29 12:53:46 UTC
Confirm it on 3.2.3 on gentoo

One thing: the bug shows only when some windows (or one window) are active on current desktop.
Comment 3 Anton 2004-06-29 12:57:40 UTC
Shortcut with "dcop kwin default setCurrentDesktop 2" is affected too. So it might be a problem in "setCurrentDesktop" function.
Comment 4 Anton 2004-07-05 10:26:48 UTC
Will someone fix it, huh? :(
Comment 5 Lubos Lunak 2004-07-24 13:20:31 UTC
*** Bug 85856 has been marked as a duplicate of this bug. ***
Comment 6 Lubos Lunak 2004-12-01 17:42:59 UTC
*** Bug 93391 has been marked as a duplicate of this bug. ***
Comment 7 Lubos Lunak 2005-01-03 14:49:33 UTC
*** Bug 95607 has been marked as a duplicate of this bug. ***
Comment 8 peppelorum 2005-03-19 22:26:54 UTC
Jut wanted to add that this still occurs in KDE 3.4, using debs from alioth.debian.org and Xinerama.
Comment 9 Lubos Lunak 2005-05-05 15:57:00 UTC
*** Bug 95316 has been marked as a duplicate of this bug. ***
Comment 10 Toomas 2005-05-06 22:59:12 UTC
KDE 3.4, debs from alioth.debian.org, _can't_ reproduce the problem.
Comment 11 peppelorum 2005-05-07 00:28:57 UTC
KDE 3.4, debs from alioth.debian.org. Gets this behaviour every time I change desktop, uses Xinerama if that matters.
Comment 12 Lubos Lunak 2005-05-13 10:57:33 UTC
SVN commit 413066 by lunakl:

Implement _NET_SHOWING_DESKTOP, giving control of the 'show desktop'
feature to KWin. There shouldn't hopefully be any visible user
difference other than fixed bugs.
BUG: 78109
BUG: 99524



 M  +23 -2     trunk/KDE/kdebase/kicker/core/showdesktop.cpp  
 M  +2 -0      trunk/KDE/kdebase/kicker/core/showdesktop.h  
 M  +4 -1      trunk/KDE/kdebase/kwin/client.cpp  
 M  +6 -1      trunk/KDE/kdebase/kwin/events.cpp  
 M  +3 -0      trunk/KDE/kdebase/kwin/manage.cpp  
 M  +74 -1     trunk/KDE/kdebase/kwin/workspace.cpp  
 M  +14 -1     trunk/KDE/kdebase/kwin/workspace.h  
 M  +43 -19    trunk/KDE/kdelibs/kdecore/kwinmodule.cpp  
 M  +12 -0     trunk/KDE/kdelibs/kdecore/kwinmodule.h  
 M  +99 -5     trunk/KDE/kdelibs/kdecore/netwm.cpp  
 M  +50 -0     trunk/KDE/kdelibs/kdecore/netwm.h  
 M  +2 -1      trunk/KDE/kdelibs/kdecore/netwm_def.h  
 M  +1 -0      trunk/KDE/kdelibs/kdecore/netwm_p.h  
Comment 13 peppelorum 2005-10-06 16:19:13 UTC
Using 3.4.2 from Debian/alioth/experimental on a newly installed system, still gets the same behaviour. Everything is new, including ~/.kde. Don't know what's missing. Using Xinerama as I said in my bug report, http://bugs.kde.org/show_bug.cgi?id=93391
Comment 14 Lubos Lunak 2005-10-07 13:28:37 UTC
You'll need KDE3.5.
Comment 15 peppelorum 2005-12-07 21:24:27 UTC
Now using 3.5.0 from http://pkg-kde.alioth.debian.org/kde-3.5.0/ and the error still occurs for me. Don't know what more information I should provide, if you'll tell me I will post it as soon as I can.
Comment 16 Lubos Lunak 2005-12-14 17:08:11 UTC
Both examples given in bug description work fine here, ctrl+fX immediately switches to the desired virtual desktop. I'm not sure what more information you could provide - perhaps step-by-step instructions how to reproduce the problem starting after creating a new user account.

Comment 17 Toomas 2006-01-09 22:16:23 UTC
Confirmed. Working like a charm. Thanks.
Comment 18 Jeff Mitchell 2007-01-10 22:46:36 UTC
Running KDE 3.5.5 on Gentoo here.  When I have some windows, then use my "Show Desktop" shortcut, and while the windows are all hidden attempt to switch virtual desktops, the desktop I'm already on is shown instead, and the windows are simply unhidden.

Since this has been marked as fixed, not sure if it's a regression or if it was never fixed right.
Comment 19 Lubos Lunak 2007-01-15 15:31:00 UTC
SVN commit 623798 by lunakl:

Ouch.
BUG: 78109



 M  +0 -1      showdesktop.cpp  


--- branches/KDE/3.5/kdebase/kicker/kicker/core/showdesktop.cpp #623797:623798
@@ -47,7 +47,6 @@
     // KDE is running with another WM without the feature.
     NETRootInfo i( qt_xdisplay(), NET::Supported );
     m_wmSupport = i.isSupported( NET::WM2ShowingDesktop );
-    m_wmSupport = false;
     if( m_wmSupport )
     {
         connect( Kicker::the()->kwinModule(), SIGNAL( showingDesktopChanged( bool )),
Comment 20 Jorge Adriano 2008-02-04 17:35:55 UTC
Is this really working fine now?
In KDE 3.5.8:

- click desktop access (show desktop)
(everything will minimise)

- change desktop 
(you can see in the pager that apps in previous desktop are restored!)

- go back to first desktop
(yeap they are restored)


Bug or feature?
...

You also get your applications restored by launching a new app after pressing "desktop access". What about this? bug or feature?

...

Comment 21 Lubos Lunak 2008-02-04 18:19:36 UTC
Feature. If 'Show Desktop' would be meant to minimize all windows, it would be named 'Minimize All Windows'.