Bug 76915 - Amarok is better than noatun, please remove noatun in kde 4!
Summary: Amarok is better than noatun, please remove noatun in kde 4!
Status: RESOLVED WORKSFORME
Alias: None
Product: kdemultimedia
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 268 votes (vote)
Target Milestone: ---
Assignee: Multimedia Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-07 03:43 UTC by Cédric Bellegarde
Modified: 2004-05-07 20:18 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cédric Bellegarde 2004-03-07 03:43:32 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:          Linux

noatun is very buggy for me.
Amarok is stable, beautiful, well designed, please make it part of kdemultimedia in kde 4 :)
Comment 1 jsvrp.gw 2004-03-23 15:25:56 UTC
Why? 

I think Noatun is a great app, same as AmaroK. They both have a different approach. I use from as v.0.9, Amarok, but have still sometimes use Noatun to hear some streams.

Keep Noatun and add AmaroK. Drop Kaboodle, because that one adds nothing to KDE. 

Cheers,

Jeroen  
Comment 2 Davide Ferrari 2004-03-23 15:32:53 UTC
No, I think that both noatun and kaboodle should be removed to leave only amaroK as official KDE stream player. It's powerful, eyecandy, feature-rich and whatever, while nor kaboodle neither noautun reach these standards
Comment 3 Nick Shaforostoff 2004-03-23 16:15:59 UTC
> No, I think that both noatun and kaboodle should be removed
Yes, i'm second!
They're very slow and unuseful (as well as ark and 'context menu'->Actions-><anything>).
amaroK is only at start, and  it will be more powerful than noautun when 1.0 will come.
Comment 4 Bart Verwilst 2004-03-23 19:56:26 UTC
I use kaboodle from time to time, to listen at individual music files now and then.. I use JuK as my main music player though.. Kaboodle starts up fast, which makes it ideal for a no-nonsense, quick listen app for single mp3's.. Noatun is buggy and bloated, and imho, could be safely replaced by amarok :)
Comment 5 Nick Shaforostoff 2004-03-23 20:20:36 UTC
> Kaboodle starts up fast, which makes it ideal for a no-nonsense, quick listen 
> app for single mp3's..
for this, there are should be kpart plugin, not stand-alone app.

> I use JuK as my main music player though..
My idea:
JuK could use kparts from amarok (for listening) and kaudiograbber (for music grabbing and encoding), and it should provide batch id3 processing by itself.

So my suggestion is to make multimedia apps integration (gathered in juk) like pim ones (gathered in kontact). (sorry, i didn't thought about technical side - so its your decision, developers)
Comment 6 Max Howell 2004-03-23 21:51:15 UTC
> for this, there are should be kpart plugin, not stand-alone app. 

Kaboodle is a KPart. It can exist as a standalone app thanks to the magic of KParts. Just like any KPart can.

Kaboodle should and most likely will stay because it is bug-free and useful as a KPart. I believe it is the kaboodle part that is the Konqi sidebar-mediaplayer, Apollon's media player page and probably it is used in many other places.

My other opinions related to this thread stay reserved ;-)
Comment 7 Cédric Bellegarde 2004-03-23 22:44:07 UTC
why?

Because noatun is buggy, very buggy.
Everytime i use this soft, it make a segfault in less than 10 minutes.
Comment 8 Leo Spalteholz 2004-03-25 06:16:39 UTC
I'd second this bug.  I've used KDE since 2.x and every time I tried noatun it either failed to start, crashed within 10 minutes, or had other serious bugs and lacked many features.  Even worse, it's development seems to be slowed or stopped.  The noatun site states "The primary reason nothing is happening here at noatun.kde.org is that we noatun developers consider noatun so close to completion it's not worth discussing.".  While the developers may think it is complete, the vast majority of users seem to have nothing but problems and complaints with it.
Comment 9 Stefan Gehn 2004-04-03 17:58:52 UTC
the main problem with noatun is that the actual sound backend (arts) is hardly maintained. most crashes are caused by broken arts installs. Noatun will get ported to another sound system, as soon as there's an agreement on a good one.
Comment 10 Marcin Kasperski 2004-04-06 14:30:44 UTC
To make more confusion let me add that for me the best KDE video player is kaffeine...
Comment 11 Bart Verwilst 2004-04-06 15:07:11 UTC
Ugh.. This is getting rediculous.. 
Comment 12 Casper Planken 2004-04-06 15:48:24 UTC
Does anyone expect that if Noatun becomes stable (or the sound backend) that all of a sudden Amarok and/or Juk and co. developers will jump on Noatun and leave their own project far behind? I don't think so. Noatun, in my oppionion, is dead, for whatever different reasons that may be.

Let's quote http://noatun.kde.org/ :
The primary reason nothing is happening here at noatun.kde.org is that we noatun developers consider noatun so close to completion it's not worth discussing.

OK, discussion closed ... (??)

However powerfull and flexible Noatun is, no one really gives a shit - arguably, sadly. Other players just seem to work (good enough) out of the box and that's what most obviously care about. Noatun is a project WAITING for plugins and as long as those usefull plugins lack, who cares? Unless some magic coders start backing Noatun with some seriously impressive stuff, the KDE desktop is basically stuck with Noatun. That's what it seems this bug report is all about.

As long as Noatun is perceived as 'broke' or inferior, this 'bug report' will stick around and 'those others' will only have gotten better.
Comment 13 Sashmit Bhaduri 2004-04-25 14:55:43 UTC
I think the situation we have is rediculious right now. Noatun is too strongly tied to arts, which makes noatun go down in flames quite often, and thus juk, amarok, kaffeine, kplayer, kmplayer were made (which could have been easily implemented as Noatun plugins, if Noatun wasn't so tied to arts)
Comment 14 shift 2004-04-26 13:53:47 UTC
playing MUSIC or VIDEOs i do not want to do much of plugin-mangling. 
i just want it to look nice, and perform well. 

noatun maybe a good framework, but right now it is a bunch of 
semi-implemented plugins. 

for example -- kaffeine and amarok are clean, neat, and SIMPLE! 


On Sunday 25 April 2004 16:55, Sashmit Bhaduri wrote:
> ------- You are receiving this mail because: -------
> You are a voter for the bug, or are watching someone who is.
>
> http://bugs.kde.org/show_bug.cgi?id=76915
>
>
>
>
> ------- Additional Comments From smt vfemail net  2004-04-25 14:55
> ------- I think the situation we have is rediculious right now. Noatun
> is too strongly tied to arts, which makes noatun go down in flames quite
> often, and thus juk, amarok, kaffeine, kplayer, kmplayer were made
> (which could have been easily implemented as Noatun plugins, if Noatun
> wasn't so tied to arts)

Comment 15 Whitehawk Stormchaser 2004-04-29 19:57:22 UTC
Just a question: Is this opened discussion, bug comit or a feature request?
Comment 16 Stanislav Karchebny 2004-04-29 20:01:23 UTC
Well, its a wish or a cry for help.. depends on pov
Comment 17 Stephan Binner 2004-04-29 20:01:46 UTC
It's simply off-topic in the bug system.
Comment 18 Casper Planken 2004-04-29 20:14:42 UTC
>It's simply off-topic in the bug system.

Allow me to increase the level of confusion;
there is a bug in this bug system.
Comment 19 rgpublic 2004-04-29 23:34:43 UTC
Sorry but I don't think this is off-topic.
The bug-system is also about feature requests (wishlist).
Nobody can deny that: There is even a link "most wanted
features" on the bugs.kde.org page linking to bug database
entries.
So IMHO this does not necessarily mean: "positive" feature requests,
but also "negative" feature requests. 
If you request that feature is included in KDE why is it THAT off-topic
or far-fetched to request the removal/modification of an existing feature?
The quality of KDE has a lot to do not only with the features of application
but also with the selection of its applications in general. 
The power of open source is that KDE can "soak up" new GPL'd apps whenever they are available and are better than existing ones. This feature request
is exactly about this.
Comment 20 Stephan Binner 2004-04-30 04:00:21 UTC
Requesting the replacement of one program by another is not a feature request of one application! This has to be discussed on the kde-multimedia mailing list (by the developers).
Comment 21 Cédric Bellegarde 2004-05-02 16:35:03 UTC
Sorry for my error, Stephan Binner is right, this has to be discuss on the kde-multimedia mailing list.
Comment 22 Nicolas Blanco 2004-05-07 20:18:06 UTC
I totally agree : amaroK is the best music player on KDE. If its development goes on, it should eventually become the only music player.
IMHO, I think there should only be ONE music player & ONE video player included in the official KDE distribution. The other music & video players could still be downloaded of course. I think that many video & music players could confuse the user.