Bug 75694 - drag-and-drop from ksnapshot crashes kview
Summary: drag-and-drop from ksnapshot crashes kview
Status: RESOLVED DUPLICATE of bug 61412
Alias: None
Product: kview
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash
Target Milestone: ---
Assignee: Matthias Kretz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-02-20 08:26 UTC by klee
Modified: 2004-02-23 17:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description klee 2004-02-20 08:26:38 UTC
Version:           3.0.90 (using KDE 3.2.90 (CVS >= 20040117), yes)
Compiler:          gcc version 3.2
OS:          Linux (i686) release 2.4.24-1up.1

1. Open KSnapshot.
2. Open KView.
3. Drag-and-drop the image from KSnapshot into KView.
4. Boom, crash.

For me, this crashes hard, without even KDE Crash Handler coming up.

Running kview from the command prompt yields the following stderr log:

kview_plugin: DropEvent in the image list: KImageCanvas
kviewviewer: DragEnter Event in the Canvas:
kviewviewer:  - image/png
kviewviewer:  - image/bmp
kviewviewer:  - image/eps
kviewviewer:  - image/jpeg
kviewviewer:  - image/krl
kviewviewer:  - image/pcx
kviewviewer:  - image/pgm
kviewviewer:  - image/ppm
kviewviewer:  - image/tga
kviewviewer:  - image/xbm
kviewviewer:  - image/xpm
kviewviewer:  - image/xv
kview_plugin: DropEvent in the image list: KImageCanvas
kview_plugin: DropEvent in the image list: KImageCanvas
QClipboard: internal error, qt_xclb_wait_for_event recursed
kutils (KSettings::Dispatcher): [virtual KSettings::Dispatcher::~Dispatcher             ()]
Comment 1 Frerich Raabe 2004-02-20 10:27:40 UTC
The only thing I notice is that dragging the image out of KSnapShot seems incredibly sluggish. Somewhen it seems the image (and the status of the mouse cursor) is changed only when you press some (I used Alt) key.
Comment 2 Lubos Lunak 2004-02-23 17:49:22 UTC

*** This bug has been marked as a duplicate of 61412 ***