Bug 73862 - crashed while loading pdf file.
Summary: crashed while loading pdf file.
Status: RESOLVED DUPLICATE of bug 61412
Alias: None
Product: kword
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-31 04:51 UTC by stacker
Modified: 2004-02-23 17:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stacker 2004-01-31 04:51:44 UTC
Version:           {W (using KDE 3.1.3)
Installed from:    compiled sources
Compiler:          gcc version 2.95.3 20010315 (release)
OS:          Linux (i686) release 2.4.24

[New Thread 16384 (LWP 480)]
0x411f3f88 in waitpid () from /lib/i686/libpthread.so.0
#0  0x411f3f88 in waitpid () from /lib/i686/libpthread.so.0
#1  0x4062bca0 in __DTOR_END__ () from /usr/local/kde/lib/libkdecore.so.4
#2  0x411f2ce6 in __pthread_sighandler () from /lib/i686/libpthread.so.0
#3  <signal handler called>
#4  0x41297be1 in kill () from /lib/i686/libc.so.6
#5  0x411f0211 in pthread_kill () from /lib/i686/libpthread.so.0
#6  0x411f051b in raise () from /lib/i686/libpthread.so.0
#7  0x412978b4 in raise () from /lib/i686/libc.so.6
#8  0x41298fd8 in abort () from /lib/i686/libc.so.6
#9  0x40de20eb in __default_terminate () at ./libgcc2.c:-1
#10 0x40de210c in __terminate () from /usr/local/qt/lib/libqt-mt.so.3
#11 0x40de2bde in __throw () from /usr/local/qt/lib/libqt-mt.so.3
#12 0x420fa5db in KoHyphenator::dict () from /usr/local/kde/lib/libkotext.so.2
#13 0x420f9f7b in KoHyphenator::hyphens ()
   from /usr/local/kde/lib/libkotext.so.2
#14 0x4204889e in KoTextFormatterCore::format ()
   from /usr/local/kde/lib/libkotext.so.2
#15 0x42047bb4 in KoTextFormatter::format ()
   from /usr/local/kde/lib/libkotext.so.2
#16 0x4201b797 in KoTextParag::format () from /usr/local/kde/lib/libkotext.so.2
#17 0x4205eae2 in KoTextObject::formatMore ()
   from /usr/local/kde/lib/libkotext.so.2
#18 0x41e44605 in KWTextFrameSet::updateViewArea ()
   from /usr/local/kde/lib/kde3/libkwordpart.so
#19 0x41dc670a in KWCanvas::slotContentsMoving ()
   from /usr/local/kde/lib/kde3/libkwordpart.so
#20 0x41dc6906 in KWCanvas::resizeEvent ()
   from /usr/local/kde/lib/kde3/libkwordpart.so
#21 0x40a4ac66 in QWidget::event () from /usr/local/qt/lib/libqt-mt.so.3
#22 0x409a9952 in QApplication::internalNotify ()
   from /usr/local/qt/lib/libqt-mt.so.3
#23 0x409a9504 in QApplication::notify () from /usr/local/qt/lib/libqt-mt.so.3
#24 0x4051a21b in KApplication::notify ()
   from /usr/local/kde/lib/libkdecore.so.4
#25 0x409aabfc in QApplication::sendPostedEvents ()
   from /usr/local/qt/lib/libqt-mt.so.3
#26 0x409aaa36 in QApplication::sendPostedEvents ()
   from /usr/local/qt/lib/libqt-mt.so.3
#27 0x409534c0 in QEventLoop::processEvents ()
   from /usr/local/qt/lib/libqt-mt.so.3
#28 0x40946636 in qt_xclb_wait_for_event ()
   from /usr/local/qt/lib/libqt-mt.so.3
#29 0x40949017 in QClipboardWatcher::getDataInFormat ()
   from /usr/local/qt/lib/libqt-mt.so.3
#30 0x40948594 in QClipboardWatcher::format ()
   from /usr/local/qt/lib/libqt-mt.so.3
#31 0x409b82f7 in QTextDrag::decode () from /usr/local/qt/lib/libqt-mt.so.3
#32 0x409b097d in QClipboard::text () from /usr/local/qt/lib/libqt-mt.so.3
#33 0x409b0a99 in QClipboard::text () from /usr/local/qt/lib/libqt-mt.so.3
#34 0x409b0b3d in QClipboard::text () from /usr/local/qt/lib/libqt-mt.so.3
#35 0x41e0a0e6 in KWView::clipboardDataChanged ()
   from /usr/local/kde/lib/kde3/libkwordpart.so
#36 0x41e1df1f in KWView::slotFrameSetEditChanged ()
   from /usr/local/kde/lib/kde3/libkwordpart.so
#37 0x41e0bfee in KWView::updateReadWrite ()
   from /usr/local/kde/lib/kde3/libkwordpart.so
#38 0x4175e2ac in KoDocument::addView ()
   from /usr/local/kde/lib/libkofficecore.so.2
#39 0x41deec12 in KWDocument::addView ()
   from /usr/local/kde/lib/kde3/libkwordpart.so
#40 0x4175ce10 in KoDocument::createView ()
   from /usr/local/kde/lib/libkofficecore.so.2
#41 0x41771a1c in KoMainWindow::setRootDocument ()
   from /usr/local/kde/lib/libkofficecore.so.2
#42 0x41779037 in KoApplication::start ()
   from /usr/local/kde/lib/libkofficecore.so.2
#43 0x40664581 in main () from /usr/local/kde/lib/kword.so
#44 0x0804d656 in launch ()
#45 0x0804e528 in handle_launcher_request ()
#46 0x0804ea45 in handle_requests ()
#47 0x0804f907 in main ()
#48 0x41284b5f in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 David Faure 2004-01-31 11:30:30 UTC
Subject: Re:  New: crashed while loading pdf file.

On Saturday 31 January 2004 04:51, stacker wrote:
> #9  0x40de20eb in __default_terminate () at ./libgcc2.c:-1
> #10 0x40de210c in __terminate () from /usr/local/qt/lib/libqt-mt.so.3
> #11 0x40de2bde in __throw () from /usr/local/qt/lib/libqt-mt.so.3
> #12 0x420fa5db in KoHyphenator::dict () from /usr/local/kde/lib/libkotext.so.2
Compilation problem, the exception isn't caught... This can't happen - unless kotext
was compiled without exceptions (I think).

Comment 2 stacker 2004-01-31 11:45:51 UTC
any solution?
Comment 3 David Faure 2004-01-31 11:50:50 UTC
Subject: Re:  crashed while loading pdf file.

On Saturday 31 January 2004 11:45, stacker wrote:
> any solution?
Try recompiling koffice/lib/kotext. Check that kotextformatter.cc gets compiled with -fexceptions
(if there's a -fno-exceptions *before* -fexceptions, that's fine, it's the latest that counts).

Or disable hyphenation.

Comment 4 Lubos Lunak 2004-02-23 17:51:15 UTC

*** This bug has been marked as a duplicate of 61412 ***