Bug 73226 - Ctrl-C kills konsole window, not processes running in shell
Summary: Ctrl-C kills konsole window, not processes running in shell
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-22 11:40 UTC by t_kleinen
Modified: 2004-02-21 01:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
kprocess.diff (1.09 KB, text/x-diff)
2004-01-23 22:44 UTC, Waldo Bastian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description t_kleinen 2004-01-22 11:40:40 UTC
Version:            (using KDE KDE 3.2.0)
Installed from:    Compiled From Sources
Compiler:          gcc 3.x (whatever is distributed with SuSE 9.0) 
OS:          Linux

If I have a konsole window with just one tab open and press Ctrl-C, it kills the konsole window, but not the process running in the shell. If I do a 'ps', I can still see the process running.
As soon as I open a second shell tab, this behavior diappears and everything is as expected.
This didn't happen in 3.1.94, it only happens in 3.1.95.
Comment 1 Kees van Wijk 2004-01-22 13:20:58 UTC
Yep I can confirm this behaviour at my gentoo linux kde-3.2_rc1 box!
I checked the configured shortcuts, but nothing stranged found.

 
Comment 2 Thiago Macieira 2004-01-22 17:37:21 UTC
I can't confirm with 3.2 20040121.
Comment 3 Waldo Bastian 2004-01-22 17:52:43 UTC
Subject: Re: [Konsole-devel]  Ctrl-C kills konsole window, not processes running in shell

Can't reproduce.

Comment 4 Stephan Kulow 2004-01-22 18:36:29 UTC
the problem appears if you run a root shell in konsole and then close the konsole window (hmm, how do you kill konsole with ^C? That sounds strange).
konsole will be closed, but due to missing permissions the root process can't
be killed. 

Can it be that problem?
Comment 5 t_kleinen 2004-01-23 19:14:24 UTC
No, it's not related to a root shell.

I did just what you usually do: Opened a konsole window and then started some command line application (transcode in fact). Then I wanted to kill transcode, so I clicked on the konsole window so that it gets the focus and then pressed Ctrl-C. But instead of stopping transcode this closed the konsole window and didn't kill transcode.

Right now I can't seem to reproduce it myself, so it may be that it only appears spuriously...
Comment 6 John Miller 2004-01-23 21:31:04 UTC
It happens here, but it seems it is only in a konsole that is opened via the tools menu in konqueror.
Comment 7 Waldo Bastian 2004-01-23 22:16:25 UTC
Subject: Re: [Konsole-devel]  Ctrl-C kills konsole window, not processes running in shell

> It happens here, but it seems it is only in a konsole that is opened via the
> tools menu in konqueror. 

Bingo! can reproduce it now.

Comment 8 Waldo Bastian 2004-01-23 22:44:02 UTC
Subject: [PATCH] [REGRESSION] KProcess messes up session groups / controlling terminals

The attached patch restores KProcess::start(DontCare) to the behavior of KDE 
3.1 and fixes BR73226

Cheers,
Waldo


Created an attachment (id=4325)
kprocess.diff
Comment 9 Oswald Buddenhagen 2004-01-24 01:29:19 UTC
fixed in 3_2_branch and head
Comment 10 t_kleinen 2004-01-25 17:56:17 UTC
That solved the problem. Works perfectly now. Thanks a lot for that rapid resolution.
Comment 11 t_kleinen 2004-02-06 17:30:17 UTC
Sorry, but is it possible that you didn't apply the patch to kde-3.2.0? 
Same problem appears again using release 3.2.0 ... 
Comment 12 Waldo Bastian 2004-02-06 17:38:34 UTC
It is in the KDE_3_2_BRANCH now but unfortunately too late for KDE 3.2.0
Someone didn't backport :-(
Comment 13 James Dow 2004-02-21 01:02:16 UTC
73226 is back in KDE 3.2. The konsole window closes but an application continues to run when a Ctrl-C is typed. BUT it only happens now when konsole is opened with Ctrl-T. When konsole is opened from the menu or the panel this does not happen.