Bug 73216 - Make spell checking test all installed dictionaries for as-you-type checking before you deactivate it
Summary: Make spell checking test all installed dictionaries for as-you-type checking ...
Status: RESOLVED DUPLICATE of bug 66516
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-22 10:12 UTC by Marcus Thiesen
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Thiesen 2004-01-22 10:12:50 UTC
Version:           1.6 (3.2 RC 1) (using KDE Devel)
Installed from:    Compiled sources

At the moment, the default behavior for the as-you-type spell checking feature is to deactivate it if the current configured dictionary leads to too much failures. 

I would prefer to first test the other dictionaries that are installed and if one is found that leads to less misspelled words this is activated instead, giving the information about language change in the status bar.

As I write often German and English email with the same account, this would make reconfiguring spell checking everytime when I switch languages far more easy.
Comment 1 Ingo Klöcker 2004-01-22 14:32:52 UTC
Note, that you can add a dictionary selection box to the composer (View->Dictionary). If you have a lot of dictionaries installed it might help if you create two identities where only the dictionary is different. Then you can easily switch between those two identities instead of having to look for the correct dictionary.
Comment 2 Marcus Thiesen 2004-03-16 12:43:00 UTC
I still would prefer an automated solution. 
If there are a lot of dictionaries present, one could make this "feature" either optional or just give a warning that this might lead to a lot of CPU consumption.
Comment 3 Daniel Naber 2004-05-10 20:59:17 UTC

*** This bug has been marked as a duplicate of 66516 ***