Bug 73074 - kmail composer tools spellcheck changing language causes crash
Summary: kmail composer tools spellcheck changing language causes crash
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: 1.6.50
Platform: unspecified Linux
: NOR crash with 60 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 73154 73629 82859 87187 92562 116234 117150 119857 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-01-20 22:32 UTC by Roger Larsson
Modified: 2008-09-09 21:42 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
bt (2.48 KB, text/plain)
2005-01-03 17:42 UTC, Tom Albers
Details
Mail with which I can reproduce (12.77 KB, text/plain)
2006-04-25 06:52 UTC, Philippe Cloutier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Larsson 2004-01-20 22:32:23 UTC
Version:           1.6.50 (using KDE 3.2.90 (CVS >= 20040117), compiled sources)
Compiler:          gcc version 3.3.1 (SuSE Linux)
OS:          Linux (i686) release 2.4.21-166-default

When changing language in kmail spell checker tool
I got a crash - to reproduce it you have to have a big
message. First time the dialogue immediately changes language but the popup telling you that you have to
restart the dialogue is not visible on top...
So you can not stop the dialogue.
Closing popup + dialogue and entering in the dialogue again, reselecting the initial language - crash.

[New Thread 16384 (LWP 28912)]
0x41c82a86 in waitpid () from /lib/i686/libpthread.so.0
#0  0x41c82a86 in waitpid () from /lib/i686/libpthread.so.0
#1  0x4110fb24 in KCrash::defaultCrashHandler(int) ()
   from /opt/kdecvs/lib/libkdecore.so.4
#2  0x41c8196c in __pthread_sighandler () from /lib/i686/libpthread.so.0
#3  <signal handler called>
#4  0x402164c3 in QGVector::size() const (this=0x8) at qgvector.h:66
#5  0x4152b872 in QSignalVec::at(unsigned) const (this=0x8, index=12)
    at qsignalslotimp.h:76
#6  0x41527c57 in QObject::receivers(int) const (this=0x870d528, signal=12)
    at kernel/qobject.cpp:1233
#7  0x4187f22e in QListBox::selected(QListBoxItem*) (this=0x870d528, 
    t0=0x872d730) at .moc/debug-shared-mt/moc_qlistbox.cpp:294
#8  0x41602fde in QListBox::mouseDoubleClickEvent(QMouseEvent*) (
    this=0x870d528, e=0xbfffeb04) at widgets/qlistbox.cpp:2202
#9  0x4156116d in QWidget::event(QEvent*) (this=0x870d528, e=0xbfffeb04)
    at kernel/qwidget.cpp:4432
#10 0x414c6be3 in QApplication::internalNotify(QObject*, QEvent*) (
    this=0xbffff440, receiver=0x870d528, e=0xbfffeb04)
    at kernel/qapplication.cpp:2582
#11 0x414c61ae in QApplication::notify(QObject*, QEvent*) (this=0xbffff440, 
    receiver=0x870d528, e=0xbfffeb04) at kernel/qapplication.cpp:2368
#12 0x41092eb8 in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kdecvs/lib/libkdecore.so.4
#13 0x4145d9a5 in QApplication::sendEvent(QObject*, QEvent*) (
    receiver=0x870d528, event=0xbfffeb04) at qapplication.h:492
#14 0x415c7cd1 in QComboBox::eventFilter(QObject*, QEvent*) (this=0x87039a8, 
    object=0x870d528, event=0xbfffece4) at widgets/qcombobox.cpp:1787
#15 0x41527668 in QObject::activate_filters(QEvent*) (this=0x870d528, 
    e=0xbfffece4) at kernel/qobject.cpp:902
#16 0x415274da in QObject::event(QEvent*) (this=0x870d528, e=0xbfffece4)
    at kernel/qobject.cpp:735
#17 0x41561055 in QWidget::event(QEvent*) (this=0x870d528, e=0xbfffece4)
    at kernel/qwidget.cpp:4408
#18 0x414c6be3 in QApplication::internalNotify(QObject*, QEvent*) (
    this=0xbffff440, receiver=0x870d528, e=0xbfffece4)
    at kernel/qapplication.cpp:2582
#19 0x414c61ae in QApplication::notify(QObject*, QEvent*) (this=0xbffff440, 
    receiver=0x871fa90, e=0xbfffef24) at kernel/qapplication.cpp:2368
#20 0x41092eb8 in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kdecvs/lib/libkdecore.so.4
#21 0x4145da11 in QApplication::sendSpontaneousEvent(QObject*, QEvent*) (
    receiver=0x871fa90, event=0xbfffef24) at qapplication.h:495
#22 0x41456a71 in QETWidget::translateMouseEvent(_XEvent const*) (
    this=0x871fa90, event=0xbffff234) at kernel/qapplication_x11.cpp:4282
#23 0x41454b17 in QApplication::x11ProcessEvent(_XEvent*) (this=0xbffff440, 
    event=0xbffff234) at kernel/qapplication_x11.cpp:3529
#24 0x4146ea78 in QEventLoop::processEvents(unsigned) (this=0x811df20, flags=4)
    at kernel/qeventloop_x11.cpp:192
#25 0x414dc786 in QEventLoop::enterLoop() (this=0x811df20)
    at kernel/qeventloop.cpp:198
#26 0x414dc6a2 in QEventLoop::exec() (this=0x811df20)
    at kernel/qeventloop.cpp:145
#27 0x414c6d63 in QApplication::exec() (this=0xbffff440)
    at kernel/qapplication.cpp:2705
#28 0x0804a574 in main (argc=7, argv=0xbffff5b4) at main.cpp:115
Comment 1 Roger Larsson 2004-01-20 22:38:46 UTC
Another slightly different looking crash.
Additional info: When the popup opens it will not close the dialog.
It sort of closes then opens again above the popup :-(
When working with short messages it does!

[New Thread 16384 (LWP 1165)]
0x41c82a86 in waitpid () from /lib/i686/libpthread.so.0
#0  0x41c82a86 in waitpid () from /lib/i686/libpthread.so.0
#1  0x4110fb24 in KCrash::defaultCrashHandler(int) ()
   from /opt/kdecvs/lib/libkdecore.so.4
#2  0x41c8196c in __pthread_sighandler () from /lib/i686/libpthread.so.0
#3  <signal handler called>
#4  0x402164c3 in QGVector::size() const (this=0x200067) at qgvector.h:66
#5  0x4152b872 in QSignalVec::at(unsigned) const (this=0x200067, index=4)
    at qsignalslotimp.h:76
#6  0x4152a158 in QObject::activate_signal(int, QString) (this=0x86f1658, 
    signal=4, param=
      {static null = {static null = <same as static member of an already seen type>, d = 0x806e7e0, static shared_null = 0x806e7e0}, d = 0x86dfeb8, static shared_null = 0x806e7e0}) at kernel/qobject.cpp:2428
#7  0x418759b7 in QComboBox::activated(QString const&) (this=0x86f1658, 
    t0=@0xbfffe304) at .moc/debug-shared-mt/moc_qcombobox.cpp:173
#8  0x415c4a11 in QComboBox::internalActivate(int) (this=0x86f1658, index=1)
    at widgets/qcombobox.cpp:1124
#9  0x41875b7a in QComboBox::qt_invoke(int, QUObject*) (this=0x86f1658, 
    _id=49, _o=0xbfffe414) at .moc/debug-shared-mt/moc_qcombobox.cpp:195
#10 0x41529a6d in QObject::activate_signal(QConnectionList*, QUObject*) (
    this=0x83e0350, clist=0x86fad40, o=0xbfffe414) at kernel/qobject.cpp:2333
#11 0x41529ddf in QObject::activate_signal(int, int) (this=0x83e0350, 
    signal=8, param=1) at kernel/qobject.cpp:2426
#12 0x4187f00c in QListBox::selected(int) (this=0x83e0350, t0=1)
    at .moc/debug-shared-mt/moc_qlistbox.cpp:258
#13 0x41602fcd in QListBox::mouseDoubleClickEvent(QMouseEvent*) (
    this=0x83e0350, e=0xbfffe7d4) at widgets/qlistbox.cpp:2201
#14 0x4156116d in QWidget::event(QEvent*) (this=0x83e0350, e=0xbfffe7d4)
    at kernel/qwidget.cpp:4432
#15 0x414c6be3 in QApplication::internalNotify(QObject*, QEvent*) (
    this=0xbffff110, receiver=0x83e0350, e=0xbfffe7d4)
    at kernel/qapplication.cpp:2582
#16 0x414c61ae in QApplication::notify(QObject*, QEvent*) (this=0xbffff110, 
    receiver=0x83e0350, e=0xbfffe7d4) at kernel/qapplication.cpp:2368
#17 0x41092eb8 in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kdecvs/lib/libkdecore.so.4
#18 0x4145d9a5 in QApplication::sendEvent(QObject*, QEvent*) (
    receiver=0x83e0350, event=0xbfffe7d4) at qapplication.h:492
#19 0x415c7cd1 in QComboBox::eventFilter(QObject*, QEvent*) (this=0x86f1658, 
    object=0x83e0350, event=0xbfffe9b4) at widgets/qcombobox.cpp:1787
#20 0x41527668 in QObject::activate_filters(QEvent*) (this=0x83e0350, 
    e=0xbfffe9b4) at kernel/qobject.cpp:902
#21 0x415274da in QObject::event(QEvent*) (this=0x83e0350, e=0xbfffe9b4)
    at kernel/qobject.cpp:735
#22 0x41561055 in QWidget::event(QEvent*) (this=0x83e0350, e=0xbfffe9b4)
    at kernel/qwidget.cpp:4408
#23 0x414c6be3 in QApplication::internalNotify(QObject*, QEvent*) (
    this=0xbffff110, receiver=0x83e0350, e=0xbfffe9b4)
    at kernel/qapplication.cpp:2582
#24 0x414c61ae in QApplication::notify(QObject*, QEvent*) (this=0xbffff110, 
    receiver=0x864fe10, e=0xbfffebf4) at kernel/qapplication.cpp:2368
#25 0x41092eb8 in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kdecvs/lib/libkdecore.so.4
#26 0x4145da11 in QApplication::sendSpontaneousEvent(QObject*, QEvent*) (
    receiver=0x864fe10, event=0xbfffebf4) at qapplication.h:495
#27 0x41456a71 in QETWidget::translateMouseEvent(_XEvent const*) (
    this=0x864fe10, event=0xbfffef04) at kernel/qapplication_x11.cpp:4282
#28 0x41454b17 in QApplication::x11ProcessEvent(_XEvent*) (this=0xbffff110, 
    event=0xbfffef04) at kernel/qapplication_x11.cpp:3529
#29 0x4146ea78 in QEventLoop::processEvents(unsigned) (this=0x811ddf0, flags=4)
    at kernel/qeventloop_x11.cpp:192
#30 0x414dc786 in QEventLoop::enterLoop() (this=0x811ddf0)
    at kernel/qeventloop.cpp:198
#31 0x414dc6a2 in QEventLoop::exec() (this=0x811ddf0)
    at kernel/qeventloop.cpp:145
#32 0x414c6d63 in QApplication::exec() (this=0xbffff110)
    at kernel/qapplication.cpp:2705
#33 0x0804a574 in main (argc=2, argv=0xbffff284) at main.cpp:115
Comment 2 Kai Lahmann 2004-01-21 18:02:37 UTC
*** Bug 73154 has been marked as a duplicate of this bug. ***
Comment 3 Roger Larsson 2004-05-10 22:49:55 UTC
This now works for me.
Comment 4 Roger Larsson 2004-06-09 22:53:10 UTC
Bug has resurfaced - was probably never fixed...
Note:
 Changing spell check language in new message works!
 Changing spell check language in message created with "Reply" crashes...

[New Thread 16384 (LWP 1948)]
[KCrash handler]
#4  0x402af496 in QGVector::size() const (this=0x24) at qgvector.h:66
#5  0x41bc1f8c in QPtrVector<QConnectionList>::size() const (this=0x24)
    at qptrvector.h:62
#6  0x41bc2580 in QSignalVec::at(unsigned) const (this=0x24, index=4)
    at qsignalslotimp.h:83
#7  0x41bc0e66 in QObject::activate_signal(int, QString) (this=0x8575a38, 
    signal=4, param=
      {static null = {static null = <same as static member of an already seen type>, d = 0x806fb58, static shared_null = 0x806fb58}, d = 0x8791fb0, static shared_null = 0x806fb58}) at kernel/qobject.cpp:2451
#8  0x41f1f643 in QComboBox::activated(QString const&) (this=0x8575a38, 
    t0=@0xbfffdd40) at .moc/debug-shared-mt/moc_qcombobox.cpp:173
#9  0x41c5cfc1 in QComboBox::internalActivate(int) (this=0x8575a38, index=8)
    at widgets/qcombobox.cpp:1124
#10 0x41f1f806 in QComboBox::qt_invoke(int, QUObject*) (this=0x8575a38, 
    _id=49, _o=0xbfffde50) at .moc/debug-shared-mt/moc_qcombobox.cpp:195
#11 0x41bc077b in QObject::activate_signal(QConnectionList*, QUObject*) (
    this=0x8575c80, clist=0x86109e0, o=0xbfffde50) at kernel/qobject.cpp:2356
#12 0x41bc0aed in QObject::activate_signal(int, int) (this=0x8575c80, 
    signal=8, param=8) at kernel/qobject.cpp:2449
#13 0x41f28c98 in QListBox::selected(int) (this=0x8575c80, t0=8)
    at .moc/debug-shared-mt/moc_qlistbox.cpp:258
#14 0x41c9b8a1 in QListBox::mouseDoubleClickEvent(QMouseEvent*) (
    this=0x8575c80, e=0xbfffe260) at widgets/qlistbox.cpp:2201
#15 0x41bf89a3 in QWidget::event(QEvent*) (this=0x8575c80, e=0xbfffe260)
    at kernel/qwidget.cpp:4674
#16 0x41b5dd47 in QApplication::internalNotify(QObject*, QEvent*) (
    this=0xbfffec50, receiver=0x8575c80, e=0xbfffe260)
    at kernel/qapplication.cpp:2618
#17 0x41b5d312 in QApplication::notify(QObject*, QEvent*) (this=0xbfffec50, 
    receiver=0x8575c80, e=0xbfffe260) at kernel/qapplication.cpp:2404
#18 0x4168e01e in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kdecvs/lib/libkdecore.so.4
#19 0x41af3d2d in QApplication::sendEvent(QObject*, QEvent*) (
    receiver=0x8575c80, event=0xbfffe260) at qapplication.h:491
#20 0x41c602a1 in QComboBox::eventFilter(QObject*, QEvent*) (this=0x8575a38, 
    object=0x8575c80, event=0xbfffe440) at widgets/qcombobox.cpp:1787
#21 0x41bbe1e4 in QObject::activate_filters(QEvent*) (this=0x8575c80, 
    e=0xbfffe440) at kernel/qobject.cpp:902
#22 0x41bbe056 in QObject::event(QEvent*) (this=0x8575c80, e=0xbfffe440)
    at kernel/qobject.cpp:735
#23 0x41bf888b in QWidget::event(QEvent*) (this=0x8575c80, e=0xbfffe440)
    at kernel/qwidget.cpp:4650
#24 0x41b5dd47 in QApplication::internalNotify(QObject*, QEvent*) (
    this=0xbfffec50, receiver=0x8575c80, e=0xbfffe440)
    at kernel/qapplication.cpp:2618
#25 0x41b5d312 in QApplication::notify(QObject*, QEvent*) (this=0xbfffec50, 
    receiver=0x85765f8, e=0xbfffe6d0) at kernel/qapplication.cpp:2404
#26 0x4168e01e in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kdecvs/lib/libkdecore.so.4
#27 0x41af3d99 in QApplication::sendSpontaneousEvent(QObject*, QEvent*) (
    receiver=0x85765f8, event=0xbfffe6d0) at qapplication.h:494
#28 0x41aec4e7 in QETWidget::translateMouseEvent(_XEvent const*) (
    this=0x85765f8, event=0xbfffea60) at kernel/qapplication_x11.cpp:4183
#29 0x41aea49d in QApplication::x11ProcessEvent(_XEvent*) (this=0xbfffec50, 
    event=0xbfffea60) at kernel/qapplication_x11.cpp:3403
#30 0x41b050d0 in QEventLoop::processEvents(unsigned) (this=0x81255b0, flags=4)
    at kernel/qeventloop_x11.cpp:192
#31 0x41b71fc6 in QEventLoop::enterLoop() (this=0x81255b0)
    at kernel/qeventloop.cpp:198
#32 0x41b71ee2 in QEventLoop::exec() (this=0x81255b0)
    at kernel/qeventloop.cpp:145
#33 0x41b5dec7 in QApplication::exec() (this=0xbfffec50)
    at kernel/qapplication.cpp:2741
#34 0x0804a98a in main (argc=36, argv=0x24) at main.cpp:108
Comment 5 Till Adam 2004-07-18 15:52:58 UTC
Roger, I can't reproduce what you describe. Are you still seeing this? If not, please consider closing this bug report.
Comment 6 Till Adam 2004-07-18 15:57:17 UTC
*** Bug 73629 has been marked as a duplicate of this bug. ***
Comment 7 Till Adam 2004-07-18 16:32:50 UTC
*** Bug 82859 has been marked as a duplicate of this bug. ***
Comment 8 Roger Larsson 2004-07-19 10:27:13 UTC
Note that it won't happen with a new message, only when changing
language when replying.

Use case: Default language for spell check English, replying to a
mail written in Swedish. Use Tools->Spellcheck, noticing wrong language,
changing => crash. [I am using ispell BTW]

I actually tried to change language on a reply to the message from
kde-bugs.

[New Thread 16384 (LWP 2314)]
[KCrash handler]
#4  0x402af006 in QGVector::size() const (this=0x19) at qgvector.h:66
#5  0x41cc324c in QPtrVector<QConnectionList>::size() const (this=0x19)
    at qptrvector.h:62
#6  0x41cc3840 in QSignalVec::at(unsigned) const (this=0x19, index=4)
    at qsignalslotimp.h:83
#7  0x41cc2126 in QObject::activate_signal(int, QString) (this=0x8b879d0, 
    signal=4, param=
      {static null = {static null = <same as static member of an already seen type>, d = 0x806fb28, static shared_null = 0x806fb28}, d = 0x8c00450, static shared_null = 0x806fb28}) at kernel/qobject.cpp:2451
#8  0x420211ab in QComboBox::activated(QString const&) (this=0x8b879d0, 
    t0=@0xbfffdd60) at .moc/debug-shared-mt/moc_qcombobox.cpp:173
#9  0x41d5e619 in QComboBox::internalActivate(int) (this=0x8b879d0, index=8)
    at widgets/qcombobox.cpp:1124
#10 0x4202136e in QComboBox::qt_invoke(int, QUObject*) (this=0x8b879d0, 
    _id=49, _o=0xbfffde70) at .moc/debug-shared-mt/moc_qcombobox.cpp:195
#11 0x41cc1a3b in QObject::activate_signal(QConnectionList*, QUObject*) (
    this=0x8b87c68, clist=0x8d768e0, o=0xbfffde70) at kernel/qobject.cpp:2356
#12 0x41cc1dad in QObject::activate_signal(int, int) (this=0x8b87c68, 
    signal=8, param=8) at kernel/qobject.cpp:2449
#13 0x4202a800 in QListBox::selected(int) (this=0x8b87c68, t0=8)
    at .moc/debug-shared-mt/moc_qlistbox.cpp:258
#14 0x41d9cef1 in QListBox::mouseDoubleClickEvent(QMouseEvent*) (
    this=0x8b87c68, e=0xbfffe270) at widgets/qlistbox.cpp:2201
#15 0x41cf9c8b in QWidget::event(QEvent*) (this=0x8b87c68, e=0xbfffe270)
    at kernel/qwidget.cpp:4677
#16 0x41c5ecff in QApplication::internalNotify(QObject*, QEvent*) (
    this=0xbfffec50, receiver=0x8b87c68, e=0xbfffe270)
    at kernel/qapplication.cpp:2620
#17 0x41c5e2ca in QApplication::notify(QObject*, QEvent*) (this=0xbfffec50, 
    receiver=0x8b87c68, e=0xbfffe270) at kernel/qapplication.cpp:2406
#18 0x4178c48e in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kdecvs/lib/libkdecore.so.4
#19 0x41bf4b13 in QApplication::sendEvent(QObject*, QEvent*) (
    receiver=0x8b87c68, event=0xbfffe270) at qapplication.h:491
#20 0x41d618f9 in QComboBox::eventFilter(QObject*, QEvent*) (this=0x8b879d0, 
    object=0x8b87c68, event=0xbfffe450) at widgets/qcombobox.cpp:1787
#21 0x41cbf4a4 in QObject::activate_filters(QEvent*) (this=0x8b87c68, 
    e=0xbfffe450) at kernel/qobject.cpp:902
#22 0x41cbf316 in QObject::event(QEvent*) (this=0x8b87c68, e=0xbfffe450)
    at kernel/qobject.cpp:735
#23 0x41cf9b73 in QWidget::event(QEvent*) (this=0x8b87c68, e=0xbfffe450)
    at kernel/qwidget.cpp:4653
#24 0x41c5ecff in QApplication::internalNotify(QObject*, QEvent*) (
    this=0xbfffec50, receiver=0x8b87c68, e=0xbfffe450)
    at kernel/qapplication.cpp:2620
#25 0x41c5e2ca in QApplication::notify(QObject*, QEvent*) (this=0xbfffec50, 
    receiver=0x8d757f0, e=0xbfffe6d0) at kernel/qapplication.cpp:2406
#26 0x4178c48e in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kdecvs/lib/libkdecore.so.4
#27 0x41bf4b7f in QApplication::sendSpontaneousEvent(QObject*, QEvent*) (
    receiver=0x8d757f0, event=0xbfffe6d0) at qapplication.h:494
#28 0x41bed2cd in QETWidget::translateMouseEvent(_XEvent const*) (
    this=0x8d757f0, event=0xbfffea60) at kernel/qapplication_x11.cpp:4188
#29 0x41beb283 in QApplication::x11ProcessEvent(_XEvent*) (this=0xbfffec50, 
    event=0xbfffea60) at kernel/qapplication_x11.cpp:3408
#30 0x41c05e4c in QEventLoop::processEvents(unsigned) (this=0x8125c58, flags=4)
    at kernel/qeventloop_x11.cpp:192
#31 0x41c72f8e in QEventLoop::enterLoop() (this=0x8125c58)
    at kernel/qeventloop.cpp:198
#32 0x41c72eaa in QEventLoop::exec() (this=0x8125c58)
    at kernel/qeventloop.cpp:145
#33 0x41c5ee7f in QApplication::exec() (this=0xbfffec50)
    at kernel/qapplication.cpp:2743
#34 0x0804a98a in main (argc=25, argv=0x19) at main.cpp:108
Comment 9 Don Sanders 2004-07-29 12:04:55 UTC
I have been able to reproduce this bug by following Roger's 
directions.

It's a kspell/kdelibs crash, and my kdelibs is a few months out of 
date so that might be why I can reproduce it (not sure).

Don.

Comment 10 Don Sanders 2004-08-16 10:01:02 UTC
*** Bug 87187 has been marked as a duplicate of this bug. ***
Comment 11 Tom Albers 2005-01-03 17:42:19 UTC
Created attachment 8902 [details]
bt

Reproducable with head kdelibs/base & pim. I first had trouble reproducing
until I activated the dictionary header in the composer. When activated it
resulted in the attached bt.
Comment 12 Tom Albers 2005-01-04 11:38:13 UTC
*** Bug 92562 has been marked as a duplicate of this bug. ***
Comment 13 Michiel de Bruijne 2005-01-23 19:52:51 UTC
Same over here, I'm running KDE 3.4-beta1
Comment 14 Øystein Olsen 2005-06-27 23:01:36 UTC
Reproducable with kde 3.4.1. It also happens with knode.
Comment 15 Kimmo 2005-09-05 11:53:48 UTC
Reproducable with SuSE 9.3 + KDE 3.4.2 + KMail 1.8.2, too. Each time I change the language for spell checking, a dialog appears (as described in the original bug posting) and after clicking OK KMail crashes.
Comment 16 Thiago Macieira 2005-11-13 15:04:39 UTC
*** Bug 116234 has been marked as a duplicate of this bug. ***
Comment 17 Winfried Dobbe 2005-12-09 20:24:48 UTC
Also reproducable with KDE 3.5 rpms for Suse 10. For me it also crashes on a new message, not just on a replied one. Thang God, KMail saved my (long) draft email.
Comment 18 Winfried Dobbe 2005-12-09 20:37:59 UTC
There are more dupllicates of this bug: 65864, 99186, 104588, 117150
Would be nice if someone could look into this.
Comment 19 marc.zero 2005-12-15 14:58:07 UTC
Changing the language in the composing window (with the toolbar obtained from menu "view/dictionnary") has no effect on the language appearing in the command "Tools->Spell check".  (kmail 1.8.2, using kde 3.4.2 level "b", Suse 10.0). Then, kmail crashes the same way as described in bug 73074.
Comment 20 Ber Kessels 2006-01-16 10:39:41 UTC
I can confirm with kde 3.5, kubuntu 5.10. 

The problem, I guess; lies in the fact that the popups aer not closed. Makes me wonder, why do we need the popups at all? The mesaage telling to "restart the dialog" is rather ugly, and very unuserfriendly. 
Comment 21 greatbunzinni 2006-02-12 17:09:17 UTC
Yet another manifestation of this ugly bug. Kmail just crashed, taking Kontact down along with it.
Comment 22 Philippe Cloutier 2006-04-25 06:52:20 UTC
Created attachment 15765 [details]
Mail with which I can reproduce
Comment 23 Philippe Cloutier 2006-04-25 07:10:58 UTC
1.9.1 (Etch).

About the reproducability, this does not happen with every mail, as mentioned before, but it should be trivial to find one which reproduces. I attached one for which it happens here.

This is also reported downstream as Debian #301966/#354658.
Comment 24 Ismail Onur Filiz 2006-04-25 07:29:50 UTC
*** Bug 117150 has been marked as a duplicate of this bug. ***
Comment 25 Ismail Onur Filiz 2006-04-25 07:30:18 UTC
*** Bug 119857 has been marked as a duplicate of this bug. ***
Comment 26 Jaime Torres 2008-09-09 17:56:08 UTC
In kmail 1.10.1 the spell checker language selection change is immediate and does not requires to start again and I've been unable to reproduce this crash.  
Comment 27 Ber Kessels 2008-09-09 19:51:53 UTC
Never experienced this bug with  1.9.10, kubuntu, where language switch is instantanious as well.
Comment 28 Roger Larsson 2008-09-09 21:42:19 UTC
Yea, it works! (tried in 1.10.0)