Bug 71594 - no way to set args to make command
Summary: no way to set args to make command
Alias: None
Product: kdevelop
Classification: Applications
Component: Build tools: Automake (show other bugs)
Version: git master
Platform: Compiled Sources Linux
: NOR wishlist
Target Milestone: ---
Assignee: kdevelop-bugs-null
Depends on:
Reported: 2004-01-01 16:52 UTC by Jon Smirl
Modified: 2008-06-29 17:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Jon Smirl 2004-01-01 16:52:05 UTC
Version:           CVS (using KDE Devel)
Installed from:    Compiled sources

On the project/build dialog for make.
There is a field for setting executable for the make tool
but there is no field for setting args to the tool.

In my case I need to run:
make -f Makefile.linux

I tried setting the executable to my command but it ignored the args.

Normally I just make a link to get around this but I can't this time.
Comment 1 Jeroen Wijnhout 2004-01-01 17:05:56 UTC
I think you can get around this, for the moment, by setting the make 
executable name to:
make -f Makefile.linux
This works for current CVS at least.

The wish is still valid imho.

Comment 2 Jon Smirl 2004-01-01 17:14:56 UTC
Doesn't work. I still get an error message about no Makefile in the directory.
Comment 3 Jeroen Wijnhout 2004-01-01 17:21:31 UTC
Sure you shouldn't do
gmake -f Makefile.linux
? On most linux systems make points to gmake, but on Solaris for example it doesn't. Too bad if this little workaround is no good for you.

Comment 4 Jon Smirl 2004-01-01 17:45:57 UTC
I just tried gmake and make.

I think the error is getting detected earlier then when it is processing the commands from the dialog.

I get a popup message saying "There is no Makefile in this directory". But I know there is no makefile there becuase I don't want one there. It might be if this popup was removed (or the check moved later), then my changed make command would run.
Comment 5 Kuba Ober 2004-01-02 14:33:04 UTC
This bug is invalid as the args to the make command *can* be set. The overeager "missing makefile" popup is reported under 71675. Please close.
Comment 6 Amilcar do Carmo Lucas 2004-01-06 18:35:45 UTC
Kuba can you tell me where you set the arguments to the make command ?
I can set the env variables, but not the arguments.
Comment 7 Ewald Arnold 2004-08-29 10:01:21 UTC
kdevelop already supports various make targets like "make install" or "make distclean". Unfortunately they are hardcoded and can't be modified or extended. 

As a workaround you can add options to the application name but this results in several problems. For example you can't compile a single source file because make then excecutes two targets.

What I would like to have is something like the settings for the configure process: a dialog page where I can set up my own targets or modify the defaults. For example I run doxygen in a different directory and modify the doxygen setup before processing. 

The existing hardcoded targets could then simply be preconfigured settings.
Comment 8 Lonnie VanZandt 2004-09-24 00:38:09 UTC
At least the hardcoded make targets should appear in the Build->Build Target submenu. If I could hack the project's XML file to add the targets, that would be a sufficient hack for now - but the XML tags therein don't clearly indicate support for this.
Comment 9 Alexander Dymo 2004-12-21 00:05:35 UTC
With recent KDevelop CVS HEAD you can define custom targets and make commands for the subproject context menu in automakt manager.
Comment 10 Andreas Pakulat 2007-01-14 22:57:38 UTC
This bug sounds more like a wishlist bug.
Comment 11 Andreas Pakulat 2008-06-29 17:12:15 UTC
*** Bug has been marked as fixed ***.