Bug 71438 - Composer ought to have checkbox for setting/appending Mail-Followup-To header
Summary: Composer ought to have checkbox for setting/appending Mail-Followup-To header
Status: RESOLVED WAITINGFORINFO
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 95 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-29 16:51 UTC by Casey Allen Shobe
Modified: 2012-08-19 00:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Casey Allen Shobe 2003-12-29 16:51:49 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

I can't count the number of times I've seen/used "I'm not on the mailing list, so please CC!".

How much better it would be for the composer to have a checkbox labelled "Request followups to be sent to my address" or something similar, which would enable setting (or appending to if preexisting i.e. in a reply) the Mail-Followup-To header.
Comment 1 Adrian von Bidder 2004-07-20 10:57:40 UTC
And, in connection with this, an option to automatically set M-F-T to the appropriate value in the default case, since I'm more annoyed with getting cc:s of countless emails on lists when I don't want them.
Comment 2 Daniel Faber 2005-09-09 22:05:43 UTC
It seems that you misunderstood how Mail-Followup-To works.  This header should be set if you _are_ subscribed to the mailing list in order to not get duplicates.  Maybe you are confused because kmail (at least v1.8.2) handles MFT wrong.  It uses MFT for ReplyList instead of ReplyAll.  Look here http://cr.yp.to/proto/replyto.html for information on how MFT should work.

Nevertheless I agree that kmail should have full MFT support which means that kmail should handle this header properly and be able to set it automatically.  But changes to the composer UI are not neccessary.  Instead there must be a way the user can tell kmail which mailing list he is subscribed to.
Comment 3 Jeremy Kitchen 2006-04-20 18:51:44 UTC
I think this is a duplicate of #59478, since if you add the functionality proposed in #59478, this functionality comes with it.  And if you add this, it's really only about 2 more steps to fully support #59478.

Either way, I'd love to see this incorporated :)
Comment 4 Myriam Schweingruber 2012-08-18 08:34:30 UTC
Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.
Comment 5 Luigi Toscano 2012-08-19 00:57:50 UTC
Instead of creating a new feature request, please confirm here if the wishlist is still valid for kmail2.