Bug 70516 - Konqueror toolbars cannot be easily configured to show different _base_ icon between different views
Summary: Konqueror toolbars cannot be easily configured to show different _base_ icon ...
Status: RESOLVED DUPLICATE of bug 56730
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-15 18:50 UTC by Carlos Woelz
Modified: 2004-09-07 19:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Woelz 2003-12-15 18:50:04 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 3.3.1 mdk
OS:          Linux

There are buttons that are frequently used for web-browsing, but very seldom used for file managing and vice versa.
Some of this problems are already solved by the merge toolbars in konqueror, but the main toolbar currently remains the same. this is a problem is you want to remove or add a button for only one view mode. One example of this is the up button. It only makes sense close to the right, left and refresh buttons, so putting it in the merge toolbars is silly. But it is very seldom used for web-browsing, and yet, it is essencial for file browsing.

The configuration of the merge toolbars are also a little confusing. It is not very clear that there are additional toolbars merged inside the main one (in the configure toolbars dialog). This is a concept shared by very few other apps, if other any app use this. And this also differs from almost all other toolbars inside KDE, because konqueror is the only app to implement view profiles. I think this merge technology should be reserved for context buttons, not view profile buttons.

Maybe, a simpler concept of different and more simple toolbars, one for each view would be nice. You would create one toolbar for each view, and name it after the view, like "web-browsing toolbar". Or any other solution you may think of.

This way you can make konqueror leaner, without loss of functionality.

Cheers!
Comment 1 Sashmit Bhaduri 2003-12-17 19:58:49 UTC
Perhaps all buttons should be moved to the responsibility of the part
Comment 2 Carlos Woelz 2003-12-17 21:25:31 UTC
I think some buttons really should be part dependent, as they are very specific. But if someone wants to navigate the web looking for some files to download, he must be free to open konqueror in file management mode, and he will have all the handy buttons he configured for file management view profile.
If all the buttons are part dependent, then this will not work.

In my opinion, each view profile should have its own toolbar. I hate when using windows explorer, all my buttons change to ie ones, just because I opened a web page. I think the current behavior of the merge toolbars is just perfect. Only the tools to configure it are a bit confusing.
Comment 3 Thiago Macieira 2003-12-18 16:09:36 UTC
As I said before, the toolbars are profile-dependant. You can have different toolbars for different profiles.
Comment 4 Carlos Woelz 2003-12-18 23:54:13 UTC
Thiago, are you sure? Look at this page and go to the konqueror section:

http://www.pycs.net/lateral/stories/12.html


Comment 5 Michael Jahn 2004-09-07 19:57:05 UTC

*** This bug has been marked as a duplicate of 56730 ***