Bug 69467 - segmentation fault during drag and drop trying to move files from a location to another
Summary: segmentation fault during drag and drop trying to move files from a location ...
Status: RESOLVED DUPLICATE of bug 61412
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: qt (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-01 20:29 UTC by giacomo
Modified: 2004-01-20 21:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description giacomo 2003-12-01 20:29:41 UTC
Version:           sconosciuto (using KDE 3.1.4)
Installed from:    compiled sources
Compiler:          gcc version 3.2.3
OS:          Linux (i686) release 2.4.2211-XI

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 16384 (LWP 946)]

0x40f555c9 in waitpid () from /lib/libpthread.so.0
#0  0x40f555c9 in waitpid () from /lib/libpthread.so.0
#1  0x4063f9ed in KCrash::defaultCrashHandler(int) ()
   from /opt/kde/lib/libkdecore.so.4
#2  0x40f53c45 in __pthread_sighandler () from /lib/libpthread.so.0
#3  <signal handler called>
#4  0x4092be10 in qt_xdnd_handle_selection_request(XSelectionRequestEvent const*) () from /usr/lib/qt/lib/libqt-mt.so.3
#5  0x4092c151 in QDropEvent::encodedData(char const*) const ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#6  0x4193c3cb in KonqIconViewWidget::contentsDragEnterEvent(QDragEnterEvent*)
    () from /opt/kde/lib/libkonq.so.4
#7  0x40ae915a in QScrollView::viewportDragEnterEvent(QDragEnterEvent*) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#8  0x40ae8879 in QScrollView::eventFilter(QObject*, QEvent*) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#9  0x40b9a2bf in QIconView::eventFilter(QObject*, QEvent*) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#10 0x409d996e in QObject::activate_filters(QEvent*) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#11 0x409d9891 in QObject::event(QEvent*) () from /usr/lib/qt/lib/libqt-mt.so.3
#12 0x40a1060c in QWidget::event(QEvent*) () from /usr/lib/qt/lib/libqt-mt.so.3
#13 0x40981035 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#14 0x409806eb in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#15 0x405c2c89 in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kde/lib/libkdecore.so.4
#16 0x40929c92 in qt_handle_xdnd_position(QWidget*, _XEvent const*, bool) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#17 0x40918342 in QApplication::x11ClientMessage(QWidget*, _XEvent*, bool) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#18 0x40919501 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#19 0x4092eed7 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#20 0x40994276 in QEventLoop::enterLoop() () from /usr/lib/qt/lib/libqt-mt.so.3
#21 0x40994118 in QEventLoop::exec() () from /usr/lib/qt/lib/libqt-mt.so.3
#22 0x40981281 in QApplication::exec() () from /usr/lib/qt/lib/libqt-mt.so.3
#23 0x419afa27 in main () from /opt/kde/lib/konqueror.so
#24 0x0804cbe1 in strcpy ()
#25 0x0804da09 in strcpy ()
#26 0x0804de8c in strcpy ()
#27 0x0804ec3a in strcpy ()
#28 0x410a3d06 in __libc_start_main () from /lib/libc.so.6
Comment 1 giacomo 2003-12-01 20:32:37 UTC
sometimes when dragging and dropping files with the intention to move them from a folder to another one i receive segmentation fault.
This just sometimes (i dare say one-two times out of ten)
If you resolve, can you tell me via e-mail?
Thanks a lot
jacum@libero.it

Udine-Italy

kde 3.1.4 on Linux Slackware 9.1 kernel 2.4.22
Comment 2 Lubos Lunak 2003-12-02 14:44:41 UTC
What's your Qt version? Do you have any debug output in ~/.xsession-errors?
Comment 3 Waldo Bastian 2004-01-20 21:53:20 UTC

*** This bug has been marked as a duplicate of 61412 ***