Bug 68959 - drag and drop of files from konqueror -> xmms / playlist crashes kdesktop
Summary: drag and drop of files from konqueror -> xmms / playlist crashes kdesktop
Status: CLOSED DUPLICATE of bug 61412
Alias: None
Product: kdesktop
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-24 20:20 UTC by Andreas Hartmann
Modified: 2009-01-02 20:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Hartmann 2003-11-24 20:20:30 UTC
Version:           Unbekannt (using KDE 3.1.93 (CVS >= 20031111), compiled sources)
Compiler:          gcc version 3.3.1
OS:          Linux (i686) release 2.4.23-pre7

1. Start a konqueror (KDE 3.1.4) on a remote machine via ssh. On the local machine run KDE HEAD from yesterday.

2. Click on a mp3-file e.g. at the remote konqueror. xmms starts (xmms should be primary application for mp3-files) on the remote machine and runs.

3. Open the playlist in xmms.

4. Mark a few mp3-files in konqueror (remote) and bring them via drag and drop in the playlist from xmms.

4. kdesktop crashes locally. In local ~/.xsession-errors you can find the following entry:
*** kdesktop (422) got signal 11

Unfortunately there is no krashmanager starting to get a backtrace.


Kind regards,
Andreas Hartmann
Comment 1 Ilya Konstantinov 2004-01-24 11:30:00 UTC
I'm seeing similar effect with KDE 2003-12-06, when drag-and-droping from an image file from a Konqueror window into The GIMP. kdesktop crashes, apparently somewhere in:
QPainter::begin(QPaintDevice const*, bool)
QIconView::drawDragShapes(QPoint const&)
[stack mangled]
(though, since this is a release build, backtraces can be more misleading than helpful)

It takes a few attempts. You don't need to actually drop the item over Gimp. Just drag it repeatedly, without dropping, from the Konqueror window to Gimp's window, and back, and forth, till kdesktop segfaults.

Also, it crashes only when "Show icons on desktop" option is enabled.
Comment 2 Waldo Bastian 2004-02-17 22:09:13 UTC

*** This bug has been marked as a duplicate of 61412 ***
Comment 3 FiNeX 2009-01-02 20:26:07 UTC
Bug closed. Kdesktop is no more mantained.