Bug 68508 - kicker ignores key and mouse events sometimes
Summary: kicker ignores key and mouse events sometimes
Status: RESOLVED DUPLICATE of bug 74487
Alias: None
Product: kicker
Classification: Plasma
Component: general (show other bugs)
Version: 1.1
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: John Firebaugh
: 68612 68656 70372 74392 74683 74891 75301 75705 (view as bug list)
Depends on:
Reported: 2003-11-18 16:30 UTC by geiseri
Modified: 2004-05-08 11:44 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description geiseri 2003-11-18 16:30:55 UTC
Version:           1.1 (using KDE 3.1.93 (CVS >= 20031111), yes)
Compiler:          gcc version 3.3 20030226 (prerelease) (SuSE Linux)
OS:          Linux (i686) release 2.4.20-4GB-athlon

when i try to click on the KMenu or any other Kicker applet item.  Randomly mouse clicks are ignored.  This applies to everything it seems but the System Tray.

Also the minicli applet will ignore every few key strokes.  This is new since the KWin migration.  

This makes KDE very hard to use because its inconsistent
Comment 1 John Firebaugh 2003-12-05 04:19:52 UTC
*** Bug 68656 has been marked as a duplicate of this bug. ***
Comment 2 John Firebaugh 2003-12-05 04:20:24 UTC
*** Bug 68612 has been marked as a duplicate of this bug. ***
Comment 3 John Firebaugh 2003-12-05 04:21:52 UTC
*** Bug 69411 has been marked as a duplicate of this bug. ***
Comment 4 John Firebaugh 2003-12-05 06:43:08 UTC
This may be caused by an interaction between MacOS-style menus and the code that passes mouse clicks on the panel borders to applets. I can reproduce it by turning on MacOS-style menus, opening the K-menu, and clicking the border of kicker just above an application menu item. Result: both K-menu and app menu open, kicker does not respond to mouse events. ESC clears things up.
Comment 5 geiseri 2003-12-05 06:45:12 UTC
i am not using MacOS menu... but i _do_ have my kicker at the top of the screen.  I wonder if that is the real issue?
Comment 6 András Manţia 2003-12-05 09:45:12 UTC
Subject: Re:  kicker ignores key and mouse events sometimes

I also don't use MacOS style menus, but the main kicker panel is on top and a 
child panel with the taskbar on the bottom.

Comment 7 Vincenzo Ciancia 2003-12-05 12:51:38 UTC
Bug 69411 has been marked as a duplicate of this one, even if I guess it has few in common so please when you close this bug also check for the other one: pressing left win key sometimes the system starts acting like you were fastly pressing and releasing this key, or as if you were keeping it pressed,and it does not suffice to repress the key to stop this behaviour. Also a wish, to be able to set the "win key opens k menu" off. Even changing the modifier map does not change the behaviour, this is *very* unpolite from what is supposed to be an X client.
Comment 8 Jonathan Story 2003-12-11 10:44:56 UTC
This still happens on 3.1.94 on Mandrake.

I have the panel at the bottom and a child panel on the bottom right hand side.

When this behaviour occurs during menu selection (i.e. I succeeded in clicking on the "Start" button, but mouse movement/clicking has no effect on the revealed menu) I have found that I can still use the cursor keys to move the menu selection and press "Enter" to select.

Curiously, it seems that the clicks that I made (but were ignored), are queued up and sent to the window underneath when I finally press "Enter".

Comment 9 John Firebaugh 2003-12-26 21:50:09 UTC
*** Bug 70372 has been marked as a duplicate of this bug. ***
Comment 10 Vincenzo Ciancia 2004-02-06 05:16:26 UTC
The bug I reported is not yet solved: sometimes, using the left win key causes random lock of the same key. To unlock, either press the k menu and pray, or ctrl+alt+backspace :)

I can't undestand how this happens, sorry
Comment 11 John Firebaugh 2004-02-09 08:55:24 UTC
*** Bug 74683 has been marked as a duplicate of this bug. ***
Comment 12 Thomas Klaemmt 2004-02-11 18:39:00 UTC
It's the same with KDE 3.2 on FC 1. I found that killing and restarting kicker helps for some minutes before the problem starts again. Additionally it seems that the problem does only appear after a certain uptime.

Regarding comment #5: I don't use Mac OS menus too but my kicker is at the bottom of the screen.
Comment 13 Warwick Bruce Chapman 2004-02-14 11:06:14 UTC
See "Bug 68477: klipper freezes on selecting an action in the popup 
(normal)" for similar problems with klipper -  I am experiencing them in 3.2.0 final still
Comment 14 Tommi Tervo 2004-02-15 19:57:07 UTC
*** Bug 75301 has been marked as a duplicate of this bug. ***
Comment 15 Roland Wolters 2004-02-16 23:31:51 UTC
I am Using FC2 Test 1, KDE 3.2RC1 is inside - I do have the main panel at the bottom, a child panel at the top.
I can see problems with kicker through looking at knewsticker: randomly it starts to stutter and can only be corrected by restarting kicker.
It often comes up when I use mozilla - their seems to be a correlation on my system between using mozilla and the total freezing of the kde-kikcer functions (than knewsticker freeezes too).

Can someone affirm this correlation with mozilla?
Comment 16 Ranju Mathew 2004-02-17 00:28:32 UTC
Multiple instances of Mozilla/Firefox and Konsole definately causes this bug to be reproducable on my system(Intel P4 w/ Fedora Core1 and KDE 3.2).
Comment 17 mail4xxxx 2004-02-17 19:38:42 UTC
I have a menu freeze situation. Sometimes (I thought there was a correlation between the menu freeze and mozilla as well) I click on the kmenu, it pops up, slide to secondary menu, it flys out, then freeze. I use a Ctrl-Esc combination to unfreeze, and then anything I've clicked while it was frozen launches.
Comment 18 Roland Wolters 2004-02-18 03:49:38 UTC
Sometimes, when the klicked button in the kicker bar freezes, it helps to klick the right mouse button on the icon, then klick the left button and the kicker "came back".
I am not sure how to reproduce te bug in any case, sometimes its there, sometimes its not.
Its on KDE 3.2 on Fedora Core 1, too.
Comment 19 Vincenzo Ciancia 2004-02-18 10:17:05 UTC
The best workaround I have found to these problems is to completely disable that "winkey" feature. I am not sure if this is your problem too, however the only way I found to disable win key is to start kde with a .xsession like this:


xmodmap -e "keycode 115 = Hyper_L"
startkde &
sleep 15
xmodmap -e "keycode 115 = Super_L"

This sucks but somewhat works.

Comment 20 Ranju Mathew 2004-02-18 20:56:26 UTC
Setting the group similar tasks to <never> allows the pager to be more usable.  The applications buttons and "KDE Start" button are still not very responsive.
Comment 21 John Firebaugh 2004-02-22 02:11:40 UTC
*** Bug 75705 has been marked as a duplicate of this bug. ***
Comment 22 John Firebaugh 2004-02-22 02:13:09 UTC
*** Bug 74891 has been marked as a duplicate of this bug. ***
Comment 23 John Firebaugh 2004-02-22 02:14:51 UTC
*** Bug 74392 has been marked as a duplicate of this bug. ***
Comment 24 Edward Muller 2004-02-22 09:42:20 UTC
My problems from bug #74891 how nothing to do with the windows key. My two problems are as follows:

1) Alt+Tab sometimes locks up. THe longer KDE is running the more often it happens. I need to ssh in, kill kiwn and then restart it on a text console and I can continue working.

2) I've applied the Mandrake focus patch to qt 3.2.3 (I am running Fedora Core 1) and I'm still having the taskbar issues. The issue is when I right click on a task I can't use the mouse buttons/pointed to activate or select an option. I think there is also a problem in that the taskbar sometimes doesn't work on the first click. I end up having to click twice.
Comment 25 Lubos Lunak 2004-02-24 11:23:14 UTC
Can somebody reproduce the problem without running Klipper as an applet?
Comment 26 lawrence goodman 2004-02-24 13:45:52 UTC
Just wanted to say that I fixed the problem by doing exactly that: I got rid of the Klipper applet.

Comment 27 Robin Green 2004-02-24 23:41:33 UTC
Ah, that $&%^*(%ing Klipper. Nice idea, but it's been buggy as hell since ... like, forever.

Maybe this embarrassment will finally spur some much needed attention to fixing Klipper bugs.
Comment 28 Mudong 2004-02-26 04:54:08 UTC
yeah, that's right, it's the Klipper, I removed it, now it's working fine. But I really like Klipper, would be good if somebody could fix this bug soon, I hope I had time to do this.
Comment 29 lawrence goodman 2004-02-26 15:11:17 UTC
Small note: the klipper runs fine if it's in the systray, just not as an applet. 
Comment 30 Lubos Lunak 2004-02-26 16:54:30 UTC
One more question: Does the problem exist also with numlock turned on (and with klipper as applet, of course)?
Comment 31 András Manţia 2004-02-26 16:56:06 UTC
I always have numlock turned on...

Comment 32 Lubos Lunak 2004-03-01 19:23:33 UTC

*** This bug has been marked as a duplicate of 74487 ***
Comment 33 Michael Shuler 2004-03-09 13:50:45 UTC
could somone tell me how to get rid of the klipper applet? I am not stupid just new. To used to windows to totally know my way around.
Comment 34 Jonas Petersson 2004-05-05 09:53:01 UTC
I can confirm that this problem seems to still be around in Debian Testing KDE 3.2 from about yesterday. Turning off the klipper applet ( from it's own menu, "remove >" ...) appears to solve the problem. In fact, now that I'm aware of it, klipper seems to be the cause of several oddities I've experienced.
Comment 35 András Manţia 2004-05-08 11:44:45 UTC
I should say that upgrading my Qt copy to the latest from the kde-cvs (I 
think it's the same as the official Qt 3.3.2), solved many problems 
that seemed to be caused by the klipper applet. Perviously I had problem 
with the K Menu and 
just noticed problems with the RMB menu in some Quanta treeviews (mouse 
events are ignored, keyboard works fine), the new Paste functionality 
(selecting an item from the clipboard history) was not working.
Now I can't see any problem in Quanta, KMenu and with the Paste button.
Everybody seeing such problems should try to upgrade the Qt. 
(BTW, I have kdelibs from CVS HEAD).