Bug 67956 - opening a postscript file in a background tab causes konqueror to become confused
Summary: opening a postscript file in a background tab causes konqueror to become conf...
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: tabbing (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 66272 67826 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-11-12 02:51 UTC by Richard Smith
Modified: 2003-11-15 07:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Smith 2003-11-12 02:51:12 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

When I right-click a link to a .ps file and hit 'Open in Background Tab', it opens in a background tab, but Konqueror seems to think it's in the foreground; its toolbars are activated, and the navigation buttons (Back, Forward, Up) act on the background tab not on the displayed tab.

Further, if one then closes the background tab, many actions on the foreground tab cause konqueror to crash, due to the KonqView it's trying to access being NULL. Interesting part of backtrace:

#4  <signal handler called>
#5  0x41b46c80 in KonqView::isToggleView() const (this=0x0) at konq_view.h:243
#6  0x41b7083d in KonqMainWindow::slotPopupMenu(KXMLGUIClient*, QPoint const&, QPtrList<KFileItem> const&, KParts::URLArgs const&, unsigned, bool) (
    this=0x80f08e0, client=0x868c2a8, _global=@0xbfffe818, _items=@0xbfffe5d0, 
    _args=@0xbfffe820, itemFlags=12, showProperties=false)
    at konq_mainwindow.cc:3952
#7  0x41b702af in KonqMainWindow::slotPopupMenu(KXMLGUIClient*, QPoint const&, KURL const&, KParts::URLArgs const&, unsigned, unsigned) (this=0x80f08e0, 
    client=0x868c2a8, _global=@0xbfffe818, url=@0xbfffe8d0, _args=@0xbfffe820, 
    f=12, _mode=32768) at konq_mainwindow.cc:3860
Comment 1 Richard Smith 2003-11-12 02:52:00 UTC
Happens for .tar.gz files too (opening in Ark). It seems likely this happens for all embedded viewers (other than KHTML).
Comment 2 Stephan Kulow 2003-11-12 13:06:16 UTC
*** Bug 67826 has been marked as a duplicate of this bug. ***
Comment 3 Stephan Kulow 2003-11-12 13:07:25 UTC
*** Bug 66272 has been marked as a duplicate of this bug. ***
Comment 4 Nick Steeves 2003-11-12 13:16:36 UTC
Bug 66272 involves KHTML.
Comment 5 Stephan Kulow 2003-11-12 13:25:51 UTC
look closer: he said he clicked a link -> HTML too
Comment 6 Stephan Binner 2003-11-15 07:50:23 UTC
*** Bug has been marked as fixed ***.