Bug 66177 - screen saver background kstars
Summary: screen saver background kstars
Status: RESOLVED INTENTIONAL
Alias: None
Product: kstars
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Mandrake RPMs Linux
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: Jasem Mutlaq
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-10-18 00:37 UTC by ivo welch
Modified: 2011-02-20 22:44 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ivo welch 2003-10-18 00:37:57 UTC
Version:           0.9.1 (using KDE 3.1.3)
Installed from:    Mandrake Linux Cooker i586 - Cooker
Compiler:          gcc version 3.3.1 (Mandrake Linux 9.2 3.3.1-2mdk)
OS:          Linux (i686) release 2.4.22-10mdk

a suggestion, not a bug:  it would be nice if we could easily make an application like kstars the screen background or screen saver.  this should be in the tool menu.

I would also love to be able to just type "Location: New Haven, CT.  Time: Now.  Show sky above."

What a great little app!

/iaw
Comment 1 kstars 2003-10-18 01:04:30 UTC
I can't believe this is the first screensaver wish! :)  It's something we've talked about a lot on the mailing list, and has been on the "TODO (someday)" list for a while now.  Having it present in bugzilla will be a good thing, so thanks.

As for a background mode, that will be possible in KDE 3.2.  We created a command-line mode that generates an image, and you can tell the KConfig module for backgrounds to use this to generate an image for your desktop every N minutes.  See here for an example from my desktop: http://www.30doradus.org/desktop.png

>  I would also love to be able to just type "Location: New Haven, CT. Time: Now. Show sky above."

Type it where?  Right now, you can just type Ctrl+G, "New Haven", click Ok, Ctrl+E, "Z" for your example.  Do you mean you want something like a mini-console embedded in the program?  Kind of interesting.  There are many DCOP functions available for controlling KStars from the command line, shell scripts, other apps, etc.
In 3.2 we also provide a "Script Builder" tool that provides a simple GUI for making shell scripts based on the DCOP commands.

I'll leave this open until the screensaver is implemented.  If DCOP functions aren't what you had in mind for the other thing, you can submit another wish for that.
Comment 2 ivo welch 2003-10-18 03:27:06 UTC
Subject: Re:  screen saver background kstars

hi:  I had never seen kstars before today, so it is actually nice that 
you get a fresh view.  looking forward to kde 3.2.

as to typing in location, this was not apparent to me.  I think the new 
user experience would be better if there would be a field next to where 
you can type your location, and next to it a button that says "show me 
my sky" or something.

I am running into a slight other problem right now, so I cannot try out 
^G.  for some odd reason, kstars now makes X absorb 95% of the CPU on a 
512MB system.  will try later.

thanks, and what a great program this is!

regards,

/iaw



kstars@30doradus.org wrote:

>------- You are receiving this mail because: -------
>You reported the bug, or are watching the reporter.
>     
>http://bugs.kde.org/show_bug.cgi?id=66177     
>kstars@30doradus.org changed:
>
>           What    |Removed                     |Added
>----------------------------------------------------------------------------
>           Severity|normal                      |wishlist
>             Status|UNCONFIRMED                 |ASSIGNED
>      everconfirmed|0                           |1
>
>
>
>------- Additional Comments From kstars@30doradus.org  2003-10-18 01:04 -------
>I can't believe this is the first screensaver wish! :)  It's something we've talked about a lot on the mailing list, and has been on the "TODO (someday)" list for a while now.  Having it present in bugzilla will be a good thing, so thanks.
>
>As for a background mode, that will be possible in KDE 3.2.  We created a command-line mode that generates an image, and you can tell the KConfig module for backgrounds to use this to generate an image for your desktop every N minutes.  See here for an example from my desktop: http://www.30doradus.org/desktop.png
>
>  
>
>> I would also love to be able to just type "Location: New Haven, CT. Time: Now. Show sky above."
>>    
>>
>
>Type it where?  Right now, you can just type Ctrl+G, "New Haven", click Ok, Ctrl+E, "Z" for your example.  Do you mean you want something like a mini-console embedded in the program?  Kind of interesting.  There are many DCOP functions available for controlling KStars from the command line, shell scripts, other apps, etc.
>In 3.2 we also provide a "Script Builder" tool that provides a simple GUI for making shell scripts based on the DCOP commands.
>
>I'll leave this open until the screensaver is implemented.  If DCOP functions aren't what you had in mind for the other thing, you can submit another wish for that.
>  
>



Comment 3 mchugh19@yahoo.com 2005-06-13 08:08:33 UTC
I would just like to voice my vote for this as well. It would be really nice to be able to set your location and desired view (normal or night vision) and have it activate a screen saver. Thanks
Comment 4 mchugh19@yahoo.com 2007-11-24 17:42:32 UTC
For KDE 4 it would also be neat to extend wish into making a plasmoid. Then kstars could also be the desktop background.
Comment 5 Alexey Khudiakov 2011-02-20 18:19:46 UTC
Such functionality is out of scope for kstars so I'm closing it as wontfix,
Comment 6 kavol 2011-02-20 19:36:27 UTC
(In reply to comment #5)
> Such functionality is out of scope for kstars so I'm closing it as wontfix,

are you serious?

reading comment #1 ...

> I can't believe this is the first screensaver wish! :)  It's something we've
> talked about a lot on the mailing list, and has been on the "TODO (someday)"
> list for a while now.  Having it present in bugzilla will be a good thing, so
> thanks.
...
> I'll leave this open until the screensaver is implemented.

one developer says this bug is good and another says this is WONTFIX?

well ... okay, where we can ask for this feature then?
Comment 7 Alexey Khudiakov 2011-02-20 22:44:56 UTC
Well it was more than six years ago. A lot of thing have changed. Now kstars tries to becom astronomer's tool suitable for both amateurs and professional. Screensaver isn't useful feature for them. 

Also it's bad idea to use kstars as screensaver because of long startup time and quite liberal use of system resources.