Bug 66050 - Please add extended forecast
Summary: Please add extended forecast
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kweather-kde3
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist with 145 votes (vote)
Target Milestone: ---
Assignee: geiseri
URL:
Keywords:
: 132880 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-10-15 03:29 UTC by Ben Burton
Modified: 2010-04-17 16:02 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Burton 2003-10-15 03:29:06 UTC
Version:            (using KDE KDE 3.1.4)
Installed from:    Debian testing/unstable Packages

Received through the debian BTS (#185034).

It would be handy if kweather could display an extended forecast.

Thanks :)
Comment 1 Thiago Macieira 2003-10-15 03:58:52 UTC
Retrieved from where? www.weather.com has a nice long forecast (even in multiple languages), but their city codes are completely different.
Comment 2 Ben Burton 2003-10-15 04:13:36 UTC
Subject: Re:  Please add extended forecast

> Retrieved from where? www.weather.com has a nice long forecast (even
> in multiple languages), but their city codes are completely different.

I have no idea. :)  This was a request from a debian user.  I personally
don't know all that much about what weather services are publicly
available.

Ben. :)

Comment 3 Jedd 2003-10-16 04:11:43 UTC
You can probably close this against my bug (59415) -- which requests the ability to open one (or more) nominated URL's via a right-click into kweather.  IANAP, but it seems like a fairly easy way to implement the same kind of thing your Debian user was asking for.
Comment 4 Ben Burton 2003-10-16 11:04:04 UTC
Subject: Re:  Please add extended forecast

> You can probably close this against my bug (59415) -- which requests
> the ability to open one (or more) nominated URL's via a right-click
> into kweather.  IANAP, but it seems like a fairly easy way to
> implement the same kind of thing your Debian user was asking for.

Though I suspect the user was actually wanting a forecast for the
selected city/location - in this case the URL isn't nominated, but
rather automagically determined.  Though as has already pointed out,
automagically determining this URL could be rather difficult.

Ben. :)

Comment 5 Rob Blomquist 2004-06-06 08:55:27 UTC
I would love to see a forecast added to Kweather, but I would say it should be from NOAA, just like the conditions report. There should be some way to pass the information easily. And if the config UI is going to grow, great, more functionality would rock!!!
Comment 6 mic006fr 2004-11-05 13:38:46 UTC
I don't know much about meteo either, but I found this: http://weather.noaa.gov/pub/data/forecasts/taf/stations/ and http://weather.noaa.gov/pub/data/forecasts/shorttaf/stations/ where you can find forecasts (I think ;)) the same way you get current conditions (by adding ID of station + ".TXT"). I don't know if these forecasts are very interesting, but I think it is much more interesting to have forecasts in kweather than the current weather (well, look through the window and you can see what the weather is like ;)). I don't know how to decode this TAF code (Terminal Aerodrome Forecasts), but it shoud be very like METAR code.
It should be pretty easy (that is easier to say, yes) to use these forecasts : stations are the same, and code must be quite the same also.
I hope it could be useful ! Go along with the great work !

Michel, french user
Comment 7 Alberto Cavalin 2005-06-19 20:14:49 UTC
Hi all, I wish to have the kweather applet do a forecast like the xfce4-weather-plugin. I don't know how you can do it, but for any clue take a look at their source code.
Many thanks.
Comment 8 Andrius Kazimieras Kasparavičius 2005-08-02 02:53:09 UTC
any plans? cheers :)
Comment 9 richlv 2005-10-03 15:50:04 UTC
this might be connected to bug 70527 (unless it is possible to resolve this by pure noaa information).
Comment 10 Ben Smith 2006-02-15 01:39:46 UTC
That NOAA TAF information isn't very interesting.  It mostly only gives wind, visibility, and cloud cover -- useful for aviation but not much else.  7 day forecasts seem to be for the US only, by state and city: http://weather.noaa.gov/pub/data/forecasts/state/.
Comment 11 Scott 2006-06-08 02:49:40 UTC
I'd suggest using the same sources that the weather applet in GNOME uses. I  believe it is also data from weather.com  Right now the GNOME weather applet provides current conditions, 2-3 day forecast and a satellite map.
Comment 12 Martin Koller 2006-12-26 00:25:57 UTC
*** Bug 132880 has been marked as a duplicate of this bug. ***
Comment 13 Stefan Böhmann 2010-04-17 16:02:29 UTC
kweather isn't maintained anymore. A replacement could be the weather plasmoid. 

If this bug is still valid for the weather plasmoid please open a bug against it (Product: plasma, Component: widget-weather).