Bug 65705 - kdesktop crashes with signal 11 in a remote X
Summary: kdesktop crashes with signal 11 in a remote X
Status: CLOSED DUPLICATE of bug 61412
Alias: None
Product: kdesktop
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-10-08 17:56 UTC by Daniel Bramkamp
Modified: 2009-01-02 20:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
.xsession-errors (71.37 KB, application/octet-stream)
2003-10-08 21:53 UTC, Daniel Bramkamp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Bramkamp 2003-10-08 17:56:33 UTC
Version:            (using KDE KDE 3.1.4)
Installed from:    Compiled From Sources
Compiler:          GCC 3.2.3 
OS:          Linux

kdestop crashes with signal 11 when being used in a remote X session via LTSP 3.0.9 or Cygwin's most recent X server. It does that when I drag icons from the kicker panel to the desktop fast. If i do that operation slowly it works, but the desktop gets a bit messy after that (left over rectangles from the icon, etc.). Sometimes the screen flickers and kdesktop starts up again, other times it leaves me with an empty and inaccessible desktop. The information I get in .xsession-errors looks like this :

kdesktop: slotCompleted() m_hasExistingPos: 1
libkonq: doDrop: dest : file:/root/Desktop/[
0: /opt/kde/lib/libkdecore.so.4(_Z11kdBacktracei+0x46) [0x406e16a6]
1: /opt/kde/lib/libkonq.so.4(_ZN14KonqOperations6doDropEPK9KFileItemRK4KURLP10QDropEventP7QWidget+0x83) [0x400d3823]
2: /opt/kde/lib/libkonq.so.4(_ZN18KonqIconViewWidget11slotDroppedEP10QDropEventRK10QValueListI13QIconDragItemE+0x2c)
 [0x400c695c]
3: /opt/kde/lib/libkonq.so.4(_ZN18KonqIconViewWidget9qt_invokeEiP8QUObject+0xb3) [0x400cc9a3]
4: /opt/kde/lib/kdesktop.so(_ZN10KDIconView9qt_invokeEiP8QUObject+0x1fc)  [0x4004f86c]
]
libkonq:
kdesktop: KonqOperations::doDrop metaData: 0 entries.
libkonq: URL : file:/opt/kde/share/applnk/System/konsole.desktop
DCOP: unregister 'kdesktop'
*** kdesktop (14971) got signal 11

Everything works fine when I use that KDE installation locally, or query the X server on the same machine.
Comment 1 Daniel Bramkamp 2003-10-08 21:53:07 UTC
Created attachment 2712 [details]
.xsession-errors

More errors about the described problem that I get and which are logged in
.xsession-errors.
Comment 2 Daniel Bramkamp 2003-10-09 17:51:15 UTC
I've done more research on this and it seems to happen only with QT 3.2.x, QT 
3.1.2 works fine.

Is it supposed to work with QT 3.2.x ? If not, I guess this bug can be closed.
Comment 3 George Staikos 2003-10-10 03:44:37 UTC
Is there any way you can attach gdb when this happens to get a full backtrace?  Or 
at least get one from drkonqi? 
Comment 4 Daniel Bramkamp 2003-10-10 08:46:29 UTC
Unfortunately I've never seen drkonqi pop up when this happens. Since I am not 
a programmer my knowledge of tools like gdb is very limited at best. However, 
if you can tell me how to use gdb to get the backtrace I can probably do that.
Comment 5 Lubos Lunak 2003-10-10 14:09:35 UTC
That "QClipboard: internal error, qt_xclb_wait_for_event recursed" in the log is a duplicate of 
#61412. I'm not aware of QClipboard causing crash with sig11 though. 
 
Comment 6 Waldo Bastian 2004-02-11 15:55:36 UTC
Duplicate of BR61412

*** This bug has been marked as a duplicate of 61412 ***
Comment 7 FiNeX 2009-01-02 20:25:27 UTC
Bug closed. Kdesktop is no more mantained.