Bug 63559 - Kmail hangs when applying filters and fetching gpg signatures.
Summary: Kmail hangs when applying filters and fetching gpg signatures.
Status: RESOLVED DUPLICATE of bug 41514
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.5.3
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-09-01 09:15 UTC by ralphdewitt
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ralphdewitt 2003-09-01 09:15:59 UTC
Version:           1.5.3 (using KDE 3.1.3)
Installed from:    Gentoo
Compiler:          gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r1, propolice)
OS:          Linux (i686) release 2.4.22_pre2-gss

When mail is being downloaded and filters are being applied Kmail will hang, no manual operations are possible until all mail is downloaded and all filters are applied. This behaviour is very annoying. Also while reading mail Kmail with Agyptian (sp) support inabled and gpg instructed to fetch keys not in key ring, will also hang/freeze/lockup. If the key does not fetch properly such as in the case of someone who did not post to a key server, then Kmail remains hung with the only option to kill the process. There has to be a better way to impliment filters and key fetching. KDE System Guard is my used tool. Used to Kill Kmail. This is very frustrating. Please fix the implimintation of filters and key fetching.
Comment 1 Ingo Klöcker 2003-09-01 17:08:18 UTC
duplicate of #41514 (filtering) and #30269 (gpg) 

*** This bug has been marked as a duplicate of 41514 ***