Bug 63097 - Left click inside an active window (but in the background) doesn't raise it anymore.
Summary: Left click inside an active window (but in the background) doesn't raise it a...
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-21 23:30 UTC by Casteyde.Christian
Modified: 2007-03-16 11:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Casteyde.Christian 2003-08-21 23:30:03 UTC
Version:            (using KDE KDE 3.1.3)
Installed from:    Compiled From Sources
Compiler:          gcc 3.3.1 -O2 -march=athlon
OS:          Linux

The kwin configuration says that the window should be activated, raised and the click should be passed for left button clicks inside an ->inactive<- window. If the window is not active, all this occurs and the window ends up to be the foremost. But if the window is already active (but not in the foreground, for instance because of a previous middle click configured to activate but not raise the clicked window), the configuration doesn't apply (not an inactive window), and window is not raised.

I suggest to add configuration options for click inside an "active" windows too (but in such a case, the whole conf form should be rearranged).

This seems to be a KDE 3.1.3 regression from 3.1.2: it used to raise the window event if it wasn't active. Maybe the active state wasn't tested before, nevertheless I cannot raise windows with invisible titlebar anymore.
Comment 1 Lubos Lunak 2003-08-26 12:28:42 UTC
*** Bug has been marked as fixed ***.
Comment 2 Aaron Williams 2005-04-27 07:33:31 UTC
This bug is back in KDE 3.4.0.  It is intermittent, but once it stops working, it never recovers.  Clicking inside an active window does not cause it to rise, even though I have Inactive Inner Window set to Active, Raise & Pass Click.  There is no option for clicking on an active window since I also have Focus Follows Mouse enabled.

Changing the focus policy to the default, click to focus, does not help.  The only thing I can think of is I also have keyboard shortcuts set for raising and lowering windows since I use a Sun keyboard plugged into my PC.

I see this same behavior on my Solaris box at work, where I also run KDE 3.4.0
Comment 3 Lubos Lunak 2005-04-27 12:37:05 UTC
And you do have click raise turned on?
Comment 4 Aaron Williams 2005-04-27 18:25:34 UTC
Doh.  [just kidding].  Yes, it is set.

-Aaron
Comment 5 S. Bryant 2007-03-15 22:56:30 UTC
Hi!  Please re-open this bug.  I've been experiencing this behaviour since my update from KDE 3.5.5 to 3.5.6.

When I click inside a non-active window, the window is not activated or raised.  I can click on and use menus and other widgets in the non-active window, so the mouse clicks are being passed through.  This also affects non-KDE apps (eg: XEmacs) in exactly the same way, so it seems to be a KWin problem.

Clicking on the root window used to deactivate the active window without activating a new one, but this no longer works (nothing happens).

Possibly related: using ALT + left-click (in inner window) to move a window no longer works.  The ALT key on its own still activates the menu as normal.

Mouse actions in the window frame or title bar work correctly, including those with the modifier.  It's the actions inside the window which are not working.

I rechecked my settings, tried alternative ones and the tried setting them back, but to no avail.  I'm using click to focus with "click raise active window" activated.  My left button for the inactive inner window is set to "Activate, Raise & Pass Click", but only the "Pass Click" part happens.

I'm using OpenSUSE 10.2 (32bit), with the RPMs from their repository; I'm using the NVidia drivers and TwinView with 2 monitors.  This problem affects other users on the same machine in exactly the same way.

-- Steve
Comment 6 Lubos Lunak 2007-03-16 11:15:12 UTC
Please fill a new bugreport.