Bug 62872 - kde themes crash repeatedly
Summary: kde themes crash repeatedly
Status: RESOLVED DUPLICATE of bug 62656
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-18 12:26 UTC by Tim
Modified: 2003-09-18 08:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim 2003-08-18 12:26:19 UTC
Version:            (using KDE KDE 3.1)
Installed from:    SuSE RPMs
Compiler:          gcc (GCC) 3.3 20030226 
OS:          Linux

After applying a theme in KDE3.1, KDE starts to apply the theme, but then begins running extreamly slow. The panel also refuses to work afterwards. Even using another desktop manager, all KDE-based programs (like kEdit, kSysGuard, Kcalc, etc) crash at startup.

The following is output from trying to run KDevelop in Gnome (same problems with all of the KDE based apps, in all managers, including kde itself):
#0  0x4147fcf7 in waitpid () from /lib/libpthread.so.0
#1  0x40ac0c89 in KCrash::defaultCrashHandler(int) ()
   from /opt/kde3/lib/libkdecore.so.4
#2  0x4147e895 in __pthread_sighandler () from /lib/libpthread.so.0
#3  <signal handler called>
#4  0x40ee2f01 in QImage::create(int, int, int, int, QImage::Endian) ()
   from /usr/lib/libqt-mt.so.3
#5  0x40ee2fd2 in QImage::create(QSize const&, int, int, QImage::Endian) ()
   from /usr/lib/libqt-mt.so.3
#6  0x40ee1d06 in QImage::QImage(QSize const&, int, int, QImage::Endian) ()
   from /usr/lib/libqt-mt.so.3
#7  0x40ee744b in QImage::smoothScale(QSize const&, QImage::ScaleMode) const ()
   from /usr/lib/libqt-mt.so.3
#8  0x40ee72c3 in QImage::smoothScale(int, int, QImage::ScaleMode) const ()
   from /usr/lib/libqt-mt.so.3
#9  0x40aa3f5b in KIconLoader::loadIcon(QString const&, KIcon::Group, int, int, QString*, bool) const () from /opt/kde3/lib/libkdecore.so.4
#10 0x40aa65ae in SmallIcon(QString const&, int, int, KInstance*) ()
   from /opt/kde3/lib/libkdecore.so.4
#11 0x40a52232 in KApplication::miniIcon() const ()
   from /opt/kde3/lib/libkdecore.so.4
#12 0x40a59707 in KApplication::setTopWidget(QWidget*) ()
   from /opt/kde3/lib/libkdecore.so.4
#13 0x408d2459 in KMainWindow::initKMainWindow(char const*) ()
   from /opt/kde3/lib/libkdeui.so.4
#14 0x408d2321 in KMainWindow::KMainWindow(QWidget*, char const*, unsigned) ()
   from /opt/kde3/lib/libkdeui.so.4
#15 0x4094f4de in KDockMainWindow::KDockMainWindow(QWidget*, char const*, unsigned) () from /opt/kde3/lib/libkdeui.so.4
#16 0x4048d39e in KParts::DockMainWindow::DockMainWindow(QWidget*, char const*, unsigned) () from /opt/kde3/lib/libkparts.so.2
#17 0x40142981 in QextMdiMainFrm::QextMdiMainFrm(QWidget*, char const*, unsigned) () from /opt/kde3/lib/libkdevelopqextmdi.so.2
#18 0x0810322e in CKDevelop::CKDevelop() ()
#19 0x0811460c in main ()
#20 0x414fa8ae in __libc_start_main () from /lib/libc.so.6


I would have to assume that the theme invalidates the settings somehow..
Every theme did this (I tried setting the 'default' theme as root, and
bugged out also).
Comment 1 András Manţia 2003-09-13 20:03:35 UTC
Subject: quanta/quanta

CVS commit by amantia: 

Don't show too many error dialogs if saving failed (when using KDE CVS). 
Don't reload the file if saving failed (fixes 63872). 
Reload the file after save only if the highlighting mode is 0 (original patch by bj at altern.org, improves the fix/workaround for 62625).

CCMAIL: 62872-done@bugs.kde.org
 


  M +16 -5     quantadoc.cpp   1.113


--- quanta/quanta/quantadoc.cpp  #1.112:1.113
@@ -211,13 +211,24 @@ bool QuantaDoc::saveDocument(const KURL&
   {
     fileWatcher->removeFile(oldURL.path());
-    if (!w->doc()->saveAs( url ))
+    KTextEditor::Document *wdoc = w->doc();
+    if (!wdoc->saveAs( url ))
     {
+#if KDE_VERSION < KDE_MAKE_VERSION(3,1,90)
       KMessageBox::error(quantaApp, i18n("Saving of the document\n%1\nfailed.\nMaybe you should try to save in another directory.").arg(url.prettyURL()));
+#endif
       result = false;
-    }
+    } else
+    {
     w->closeTempFile();
-    w->doc()->openURL(url);
+      if (dynamic_cast<KTextEditor::HighlightingInterface*>(wdoc)->hlMode()==0)
+       {
+         uint line,col;
+         w->viewCursorIf->cursorPositionReal(&line, &col);
+        wdoc->openURL(url);
+         w->viewCursorIf->setCursorPosition(line, col);
+     }
     w->createTempFile();
     w->setDirtyStatus(false);
+    }
     if (w->url().isLocalFile())
     {


Comment 2 András Manţia 2003-09-13 20:14:51 UTC
Sorry, fixed by mistaked (typo in CVS commit). Please close it if it was closed before. 
 
Andras 
Comment 3 George Staikos 2003-09-18 08:10:00 UTC

*** This bug has been marked as a duplicate of 62656 ***