Bug 61184 - kdesktop and kcontrol crash when using certain backgrounds
Summary: kdesktop and kcontrol crash when using certain backgrounds
Status: RESOLVED NOT A BUG
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kimgio (show other bugs)
Version: unspecified
Platform: RedHat Enterprise Linux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-07-13 16:55 UTC by Timothy Covell
Modified: 2003-11-24 14:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Covell 2003-07-13 16:55:26 UTC
Version:           kcontrol 3.1.0 and kdesktop 3.1.0 (using KDE KDE 3.1)
Installed from:    RedHat RPMs
Compiler:          gcc (GCC) 3.2.2 20030222 (Red Hat Linux 3.2.2-5)  
OS:          Linux

When using multiple backgrounds mode, kdesktop will crash when loading certain background images (using tiffs, jpegs, and gifs(?)).   This is _very_ bad because it defeats the screensaver etc. and it cannot be fixed w/o editting by hand the configuration files in ~/.kde; kcontrol will crash when selecting the backgrounds applet.    Also, on reboot/relogin, the kdesktop program will continue to try to spawn new processes to work, but it will hog the CPU; the solution is to do a "killall kdesktop".   By the way, I'm sending this bug report via Opera because Konqueror refused to accept cookies even when I said that it should accept  all cookies.  Unfortunately, I cannot tell you which image it was that crashed because there doesn't appear to be a current image setting/log anywhere, it's just one (or more) of dozens of images which do display in ImageMagick...I just found one (corrupted Tiff) which crashes Konqueror's Image Viewer but not Kuikshow, this backtrace is appended after the kcontrol backtrace (I could e-mail the image upon request).

Here's the kcontrol crash dump:
[New Thread 1093753760 (LWP 1169)]
0xffffe002 in ?? ()
#0  0xffffe002 in ?? ()
#1  0x40621e81 in KCrash::defaultCrashHandler(int) ()
   from /usr/local/lib/libkdecore.so.4
#2  <signal handler called>
#3  0x41876d13 in TIFFInitSGILog () from /usr/lib/libtiff.so.3
#4  0x4187860f in TIFFInitPackBits () from /usr/lib/libtiff.so.3
#5  0x4187a1ea in TIFFReadEncodedStrip () from /usr/lib/libtiff.so.3
#6  0x4186c22c in TIFFReadRGBAImage () from /usr/lib/libtiff.so.3
#7  0x4186ba7d in TIFFRGBAImageGet () from /usr/lib/libtiff.so.3
#8  0x4186bade in TIFFReadRGBAImage () from /usr/lib/libtiff.so.3
#9  0x406f4cc7 in kimgio_tiff_read () from /usr/local/lib/kde3/kimg_tiff.so
#10 0x4020b7c3 in KImageIOFormat::callLibFunc(bool, QImageIO*) ()
   from /usr/local/lib/libkio.so.4
#11 0x4020d1f2 in KImageIOFactory::readImage(QImageIO*) ()
   from /usr/local/lib/libkio.so.4
#12 0x40974444 in QImageIO::read() () from /usr/local/qt/lib/libqt-mt.so.3
#13 0x40972458 in QImage::load(QString const&, char const*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#14 0x4184dacb in KBackgroundRenderer::doWallpaper(bool) ()
   from /usr/local/lib/kde3/kcm_background.so
#15 0x4184e8cb in KBackgroundRenderer::render() ()
   from /usr/local/lib/kde3/kcm_background.so
#16 0x4184f025 in KBackgroundRenderer::qt_invoke(int, QUObject*) ()
   from /usr/local/lib/kde3/kcm_background.so
#17 0x4099dcd9 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#18 0x4099db5f in QObject::activate_signal(int) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#19 0x40c9d678 in QTimer::timeout() () from /usr/local/qt/lib/libqt-mt.so.3
#20 0x409be16b in QTimer::event(QEvent*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#21 0x40943872 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#22 0x4094344d in QApplication::notify(QObject*, QEvent*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#23 0x405a1ed0 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/local/lib/libkdecore.so.4
#24 0x4091bc4f in QEventLoop::activateTimers() ()
   from /usr/local/qt/lib/libqt-mt.so.3
#25 0x408fc910 in QEventLoop::processEvents(unsigned) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#26 0x409559d3 in QEventLoop::enterLoop() ()
   from /usr/local/qt/lib/libqt-mt.so.3
#27 0x40955890 in QEventLoop::exec() () from /usr/local/qt/lib/libqt-mt.so.3
#28 0x40943aa8 in QApplication::exec() () from /usr/local/qt/lib/libqt-mt.so.3
#29 0x413b8486 in main () from /usr/local/lib/kcontrol.so
#30 0x0804c9d5 in launch(int, char const*, char const*, char const*, int, char const*, bool, char const*, bool, char const*) ()
#31 0x0804d608 in handle_launcher_request(int) ()
#32 0x0804da9a in handle_requests(int) ()
#33 0x0804e72d in main ()
#34 0x42015574 in __libc_start_main () from /lib/tls/libc.so.6

Konqueror image viewer crash:
[New Thread 1093753760 (LWP 1253)]
0xffffe002 in ?? ()
#0  0xffffe002 in ?? ()
#1  0x40621e81 in KCrash::defaultCrashHandler(int) ()
   from /usr/local/lib/libkdecore.so.4
#2  <signal handler called>
#3  0x41f1fd13 in TIFFInitSGILog () from /usr/lib/libtiff.so.3
#4  0x41f2160f in TIFFInitPackBits () from /usr/lib/libtiff.so.3
#5  0x41f231ea in TIFFReadEncodedStrip () from /usr/lib/libtiff.so.3
#6  0x41f1522c in TIFFReadRGBAImage () from /usr/lib/libtiff.so.3
#7  0x41f14a7d in TIFFRGBAImageGet () from /usr/lib/libtiff.so.3
#8  0x41f14ade in TIFFReadRGBAImage () from /usr/lib/libtiff.so.3
#9  0x41c19cc7 in kimgio_tiff_read () from /usr/local/lib/kde3/kimg_tiff.so
#10 0x4020b7c3 in KImageIOFormat::callLibFunc(bool, QImageIO*) ()
   from /usr/local/lib/libkio.so.4
#11 0x4020d1f2 in KImageIOFactory::readImage(QImageIO*) ()
   from /usr/local/lib/libkio.so.4
#12 0x40974444 in QImageIO::read() () from /usr/local/qt/lib/libqt-mt.so.3
#13 0x40972458 in QImage::load(QString const&, char const*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#14 0x4096bcc0 in QImage::QImage(QString const&, char const*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#15 0x41f5ce7b in KViewViewer::openFile() ()
   from /usr/local/lib/kde3/libkviewviewer.so
#16 0x41f5b064 in KViewViewer::openURL(KURL const&) ()
   from /usr/local/lib/kde3/libkviewviewer.so
#17 0x41405519 in KonqView::openURL(KURL const&, QString const&, QString const&) () from /usr/local/lib/konqueror.so
#18 0x413da519 in KonqMainWindow::openView(QString, KURL const&, KonqView*, KonqOpenURLRequest) () from /usr/local/lib/konqueror.so
#19 0x413d8a6d in KonqMainWindow::openURL(KonqView*, KURL const&, QString const&, KonqOpenURLRequest const&, bool) () from /usr/local/lib/konqueror.so
#20 0x413dbbf4 in KonqMainWindow::openURL(KonqView*, KURL const&, KParts::URLArgs const&) () from /usr/local/lib/konqueror.so
#21 0x413db6f0 in KonqMainWindow::slotOpenURLRequest(KURL const&, KParts::URLArgs const&) () from /usr/local/lib/konqueror.so
#22 0x413f6983 in KonqMainWindow::qt_invoke(int, QUObject*) ()
   from /usr/local/lib/konqueror.so
#23 0x4099dcd9 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#24 0x40043e0b in KParts::BrowserExtension::openURLRequestDelayed(KURL const&, KParts::URLArgs const&) () from /usr/local/lib/libkparts.so.2
#25 0x40042d59 in KParts::BrowserExtension::slotEmitOpenURLRequestDelayed() ()
   from /usr/local/lib/libkparts.so.2
#26 0x40044857 in KParts::BrowserExtension::qt_invoke(int, QUObject*) ()
   from /usr/local/lib/libkparts.so.2
#27 0x41ee8b2b in IconViewBrowserExtension::qt_invoke(int, QUObject*) ()
   from /usr/local/lib/kde3/konq_iconview.so
#28 0x4099dcd9 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#29 0x40c9bd46 in QSignal::signal(QVariant const&) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#30 0x409b6e3d in QSignal::activate() () from /usr/local/qt/lib/libqt-mt.so.3
#31 0x409be2e7 in QSingleShotTimer::event(QEvent*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#32 0x40943872 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#33 0x4094344d in QApplication::notify(QObject*, QEvent*) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#34 0x405a1ed0 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/local/lib/libkdecore.so.4
#35 0x4091bc4f in QEventLoop::activateTimers() ()
   from /usr/local/qt/lib/libqt-mt.so.3
#36 0x408fc910 in QEventLoop::processEvents(unsigned) ()
   from /usr/local/qt/lib/libqt-mt.so.3
#37 0x409559d3 in QEventLoop::enterLoop() ()
   from /usr/local/qt/lib/libqt-mt.so.3
#38 0x40955890 in QEventLoop::exec() () from /usr/local/qt/lib/libqt-mt.so.3
#39 0x40943aa8 in QApplication::exec() () from /usr/local/qt/lib/libqt-mt.so.3
#40 0x413d1693 in main () from /usr/local/lib/konqueror.so
#41 0x0804c9d5 in launch(int, char const*, char const*, char const*, int, char const*, bool, char const*, bool, char const*) ()
#42 0x0804d608 in handle_launcher_request(int) ()
#43 0x0804daf4 in handle_requests(int) ()
#44 0x0804e72d in main ()
#45 0x42015574 in __libc_start_main () from /lib/tls/libc.so.6
Comment 1 Daniel Molkentin 2003-07-16 21:14:56 UTC
This is a problem in the underlying TIFF library (libtiff). Reassigning to kdelibs. 
Comment 2 Waldo Bastian 2003-10-14 18:15:31 UTC
Can you provide a problematic image as attachment to this bugreport, or can you 
provide a link to such image? 
 
If you don't want to publish the image you may also send it in private mail to 
bastian@kde.org 
Comment 3 Waldo Bastian 2003-11-24 14:13:57 UTC
Reporter doesn't respond.

In case you read this and still happen to have the offending image, please report to http://www.libtiff.org/bugs.html

Closing report, not a bug in KDE code.
Comment 4 Timothy Covell 2003-11-24 23:26:31 UTC
Subject: Re:  kdesktop and kcontrol crash when using certain backgrounds

I replied to you a long time ago but your Qmailer cannot 
handle the Tiff file because it is too big for your system.
So, you tell me how to get it to you.

tim


On Mon November 24 2003 08:13, you wrote:
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>
> http://bugs.kde.org/show_bug.cgi?id=61184
> bastian@kde.org changed:
>
>            What    |Removed                     |Added
> ---------------------------------------------------------------------------
>- Status|NEW                         |RESOLVED
>          Resolution|                            |INVALID
>
>
>
> ------- Additional Comments From bastian@kde.org  2003-11-24 14:13 -------
> Reporter doesn't respond.
>
> In case you read this and still happen to have the offending image, please
> report to http://www.libtiff.org/bugs.html
>
> Closing report, not a bug in KDE code.

Comment 5 Waldo Bastian 2003-11-25 11:58:42 UTC
Subject: Re:  kdesktop and kcontrol crash when using certain backgrounds

On Mon November 24 2003 23:26, Timothy Covell wrote:
> I replied to you a long time ago but your Qmailer cannot
> handle the Tiff file because it is too big for your system.
> So, you tell me how to get it to you.

Ah, nice to hear from you. Better report directly to 
	http://www.libtiff.org/bugs.html
since that's where it will need to be fixed anyway, and maybe they have 
already fixed it in their development version. I did notice that they fixed 
something in the area where the crash occurred.

Alternatively you can gzip it and send it to bastian@svn.net and see if that 
mailer is less picky.

Cheers,
Waldo