Bug 60105 - KDE has incorrect font names.
Summary: KDE has incorrect font names.
Status: RESOLVED NOT A BUG
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: qt (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: HI major (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-06-20 03:40 UTC by James Richard Tyrer
Modified: 2007-11-07 18:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test file to illustrate the bug (4.69 KB, application/kword)
2003-06-20 03:42 UTC, James Richard Tyrer
Details
test code for ps generation (802 bytes, text/plain)
2003-06-23 20:21 UTC, David Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Richard Tyrer 2003-06-20 03:40:37 UTC
Version:           1.3 Beta 2 (using KDE KDE 3.1.2)
Installed from:    Compiled From Sources
Compiler:          GCC-3.3 
OS:          Linux

I created the attached KWord file to test other printing issues, but couldn't because the PostScript font names are incorrect and/or incorrect case.

The names in the PS file are:

TimesNewRomanPs 
ComicSansMs 
Swis721Bt 
Swis721Bt-Bold 
BrushscriptBt

The correct names are:

TimesNewRomanPSMT 
ComicSansMS 
Swiss721BT 
Swiss721BT-Bold 
BrushScriptBT

Note that editing the PS file with a text editor fixed the problem.

There is another issue that also occurs with other wordprocessors -- it is the Times vs. Times-Roman issue.

The actual names for: 

Swiss721BT
BrushScriptBT

are:

Swiss721BT-Roman
BrushScriptBT-Regular

This makes it necessary to add an alias to the Fontmap file just as is necessary for Times.  I don't know if this is the normal way to do it or which name should appear in the PS file, but I would think that should be the actual PS font name as reported by the font file.

--
JRT
Comment 1 James Richard Tyrer 2003-06-20 03:42:11 UTC
Created attachment 1850 [details]
Test file to illustrate the bug
Comment 2 James Richard Tyrer 2003-06-20 03:44:45 UTC
NOTE: if you would like my two PS files, I will be happy to forward them to you 
but I thought that they were a bit too long to post here. 
 
-- 
JRT 
Comment 3 David Faure 2003-06-20 12:02:29 UTC
Subject: Re:  New: PS files generated by printing have incorrect font names.

I forwarded your report to Trolltech - all the PS generation happens in Qt... 

Comment 4 David Faure 2003-06-23 20:21:30 UTC
Created attachment 1872 [details]
test code for ps generation
Comment 5 David Faure 2003-06-23 20:22:21 UTC
Hmm, TT answered back that it works for them, with a plain Qt program.  
  
"Could you perhaps try to reproduce this with just Qt?  
I've tried using the attached program, but the resulting .ps  
file seemed to contain the correct font names."  
  
I attached the testcase. I have no time for further debugging on this right now, sorry.  
Comment 6 James Richard Tyrer 2003-06-23 21:09:30 UTC
The bug appears to be more general.

If you check, you will see that the same incorrect font names appear in the font
selector widget.  E.G. Control Center: Appearance & Themes => Fonts: Choose.

So, this is probably a general KDE bug.

--
JRT
Comment 7 James Richard Tyrer 2003-06-23 21:13:16 UTC
Changed Product and Summary to better represent the actual problem.

Please move this to the correct place if I have it wrong.

--
JRT
Comment 8 Stephan Kulow 2003-06-24 09:18:25 UTC
the question was: can you reproduce it with a pure Qt application?! 
Comment 9 James Richard Tyrer 2003-08-03 10:42:44 UTC
Having looked into this further, I find that there are two different but related
problems.  The family name: "Swis721 BT" is correct and the incorrect case in
the KFontDialog shouldn't cause any problems.  However, KWord is not using the
correct PostScript font names but rather it is using the same names as in the
KFontDialog in the PostScript files that it generates.  I don't know if this is
caused by KOffice code or KDELibs code.

I will open a new bug for KOffice.

--
JRT
Comment 10 James Richard Tyrer 2003-08-04 23:15:20 UTC
I have determined that the problem is in Qt.

So, I am closing the bug.

--
JRT