Bug 59576 - JJ: zoom buttons are missing in kmail
Summary: JJ: zoom buttons are missing in kmail
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: GUI (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 48 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: junior-jobs
: 90622 123219 131449 150011 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-06-09 22:56 UTC by Anders Lund
Modified: 2011-08-21 08:46 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Lund 2003-06-09 22:56:51 UTC
Version:           1.5.9 (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 3.2.2 
OS:          Linux

When reading HTML mails, I miss a zoom button, since many clients use fonts that are too small to read comfortably on the screen. Either promote KHTMLs zoom buttons, or provide your own, please ;)
Comment 1 Helge Hielscher 2004-04-27 15:12:38 UTC
see also bug 50983
Comment 2 Ismail Onur Filiz 2006-03-07 19:42:20 UTC
---Forwarded from bug 123219---
           Summary: Zoom Messages with Ctrl++ and Ctrl+-
           Product: kmail
           Version: 1.9.1
          Platform: SuSE RPMs
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: wishlist
          Priority: NOR
         Component: general
        AssignedTo: kmail-devel kde org
        ReportedBy: rayH eng-int co uk
Version:           1.9.1 (using KDE KDE 3.5.1)
Installed from:    SuSE RPMs
OS:                Linux

My eyesight is failing and changes from hour to hour. 

I would like kmail to use the ctrl++/ctrl+- keystrokes to zoom in and out in the same manner as Konqueror. I am not sure whether this should apply to the whole KMail window or only the message(active) pane.

I think that this might subsume longstanding "Bug 59576:  zoom buttons are missing in kmail" and "Bug 50983: HTML mail does not honor minimum font sizes".
--EO Forward--
Comment 3 Ismail Onur Filiz 2006-03-07 19:44:27 UTC
*** Bug 123219 has been marked as a duplicate of this bug. ***
Comment 4 Thomas McGuire 2007-05-20 13:53:59 UTC
*** Bug 131449 has been marked as a duplicate of this bug. ***
Comment 5 Thomas McGuire 2007-05-20 13:54:57 UTC
*** Bug 90622 has been marked as a duplicate of this bug. ***
Comment 6 Dotan Cohen 2007-05-23 18:30:26 UTC
From bug #90622:
CTRL-Scrollwheel does increase and decrease text size in the message pane, but for HTML mail and non-HTML. However, this is useless for those who don't have a mouse (or those with no scrolwheel). Toolbar "Zoom" buttons that provide the same functionality will solve the problem as they can be mapped to keyboard shortcuts. This should be rather easy to implement.
Comment 7 Dotan Cohen 2007-05-23 18:31:58 UTC
*** Bug 90622 has been marked as a duplicate of this bug. ***
Comment 8 Thomas McGuire 2007-09-20 19:20:10 UTC
*** Bug 150011 has been marked as a duplicate of this bug. ***
Comment 9 Francois Cartegnie 2008-03-09 14:25:21 UTC
Changing font size "on the fly" is useful when you temporary need to read some asian or complex fonts.
Comment 10 Dotan Cohen 2008-12-04 22:56:49 UTC
> Changing font size "on the fly" is useful when you temporary need
> to read some asian or complex fonts.

Or for laptop user s who often find themselves using the machine under varying ambient conditions.
Comment 11 Martin Hignett 2009-12-28 22:40:19 UTC
Submitted a patch here http://reviewboard.kde.org/r/2456/. Waiting for review.
Comment 12 Laurent Montel 2011-08-21 08:46:53 UTC
Adapted patch to kmail-akonadi. (kmail-master/4.8)