Bug 59303 - cant use Ctrl-Shift- shorcuts at all
Summary: cant use Ctrl-Shift- shorcuts at all
Status: RESOLVED UPSTREAM
Alias: None
Product: kdelibs
Classification: Unclassified
Component: shortcuts (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Ellis Whitehead
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-06-03 23:41 UTC by shift
Modified: 2020-12-19 23:12 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shift 2003-06-03 23:41:11 UTC
Version:            (using KDE KDE 3.1.2)
Installed from:    SuSE RPMs
Compiler:          gcc 3.2 
OS:          Linux

if i use Ctrl-Shift as a keyboard layout switch 
in xkb, then i cant use any of Ctrl-Shift- shortcuts 
in KDE. 

as soon as press down both Ctrl- and Shift-, the layout 
is switched, and there is no way to make it work with any other 
third key as shortcut. 

however, i use the same combination
for layout switch in Windows, and it 
gets switched only when i RELEASE both keys, 
and if i hold down Ctrl- Shift- and press 
any other key -- it will work as a usual 
shortcut and the layout will not get switched. 

i dont want to stop using Ctrl-Shift as a layout switch, 
because it isvery comfirtable to me, and at the same 
time i am used to combinations like
Ctrl-Shift- leftarrow, and i know that this is not 
a KDE's problem, but despite numerous users' posts 
in various mail-lists -- this problem still remains. 

Is there any chance to solve it from this side?
Comment 1 Stephan Kulow 2003-06-04 11:06:32 UTC
perhaps Ellis knows 
Comment 2 Ellis Whitehead 2003-06-07 11:20:39 UTC
I've gotten other requests for this too, and hope to have it implemented for KDE 3.2.  
In any case, it's on my "active" todo list.  However, I need to know exactly how the 
shortcut works.  Does Shift+Ctrl work too?  Ctrl_Left+Shift_Right? 
Comment 3 Vitaly Shishakov 2003-06-08 14:17:44 UTC
Subject: Re:  cant use Ctrl-Shift- shorcuts at all

On Saturday 07 June 2003 13:20, you wrote:
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>
> http://bugs.kde.org/show_bug.cgi?id=59303
> ellis@kde.org changed:
>
>            What    |Removed                     |Added
> -------------------------------------------------------------------------
>--- Status|UNCONFIRMED                 |ASSIGNED
>       everconfirmed|0                           |1
>
>
>
> ------- Additional Comments From ellis@kde.org  2003-06-07 11:20 -------
> I've gotten other requests for this too, and hope to have it implemented
> for KDE 3.2. In any case, it's on my "active" todo list.  However, I need
> to know exactly how the shortcut works.  Does Shift+Ctrl work too? 
> Ctrl_Left+Shift_Right?

i have SuSE 8.2, and XFree 8.3
here is my XF86Config:

Section "InputDevice"
  Driver       "Keyboard"
  Identifier   "Keyboard[0]"
  Option       "AutoRepeat" "250 30"
  Option       "MapName" "Generic Windows Keyboard [ pc105 ]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "us,ru"
  Option       "XkbModel" "pc105"
  Option       "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" ",winkeys"
EndSection

(in previous versions configuration was similar) 

When used in such manner, i can use any of the Ctrl-Shift 
combinations available (right or left or right-left) 

as U see -- i use Scroll led to indicate group switch, 
and it is lid as soon as both keys are DOWN, 

in MS Windows the group is changed only 
when both keys are released, and no other key 
was pressed. 

Comment 4 shift 2003-07-19 01:41:54 UTC
unfortunately, this relatesd not only to KDE applications,  
recently i am using Netbeans -- a cool java IDE, and there as well Ctrl-Shift 
shortcuts do not work under described conditions.  
Comment 5 Christoph Cullmann 2003-11-28 21:05:12 UTC
hmm, just side note for this shift-ctrl bug: in katepart for example I can't get the SHIFT-CTRL-I accel working for the unindent action, related problem ? I have no special xkb config, just normal de layout, no other options
it's really bad to have the shortcut visible in the menu but doesn't work :/
Comment 6 shift 2004-07-14 12:05:38 UTC
luckily, there is X.org now, which, as i denote, will soon become THE x-server for everything, and, unlike XF86 -- they have public BUGZILLA! 

i posted this bug there:  http://freedesktop.org/bugzilla/show_bug.cgi?id=865

this thing is really annoying, and i hope it gets fixed soon. 
Comment 7 George Goldberg 2008-02-19 03:31:40 UTC
Did this ever get fixed? or is it still a problem in recent KDE 3 or KDE 4?
Comment 8 shift 2008-02-21 17:34:00 UTC
The problem is still there
is it so hard to add a flag to fire "Change Layout" event on _RELEASE_ of 
the combination, but not on _PRESS_ ? 

On 19 февраля 2008, George Goldberg wrote:
[bugs.kde.org quoted mail]
Comment 9 Anatoly 2010-03-21 12:31:33 UTC
I confirm that recent version of KDE (4.4.1) is still affected.
Comment 10 Nicolás Alvarez 2011-04-07 21:34:30 UTC
This is an X.org server issue, see bug https://bugs.freedesktop.org/show_bug.cgi?id=865. KDE developers cannot do anything about it.
Comment 11 k0fe 2017-10-13 21:41:23 UTC
After the next update of the package "xserver-xorg-input-evdev-hwe-16.04" (with dependencies) from the version "1: 2.10.2-1ubuntu1 ~ 16.04.1" to the version "1: 2.10.5-1ubuntu1 ~ 16.04.1 ", in the KDE shell, the language switch does not happen when the keys are released, but when pressed.

Distributions on which this problem was repeated:
neon-useredition-20171012-1018-amd64
kubuntu-16.04.3-desktop-amd64
kubuntu-17.04-desktop-amd64

Distributions in which there is no such problem:
ubuntu-16.04.3-desktop-amd64
ubuntu-17.04-desktop-amd64 (but there is no such package)

When setting the switch to Ctrl-Shift, you can not quickly select text with the "Ctrl-Shift-Arrows" keys. However, you do not want to have outdated xorg packages. Extremely uncomfortable, help!