Bug 59195 - Selecting 'Reply-All' in KMAIL results in a new message with no recipients
Summary: Selecting 'Reply-All' in KMAIL results in a new message with no recipients
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 51112 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-06-01 01:51 UTC by Eric Rosenberg
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch that seems to fix the problem (913 bytes, patch)
2003-06-01 23:19 UTC, Eric Rosenberg
Details
Revised Patch (937 bytes, patch)
2003-06-02 02:24 UTC, Eric Rosenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Rosenberg 2003-06-01 01:51:15 UTC
Version:           1.5.2 (using KDE 3.1.2)
Installed from:    Gentoo
Compiler:          gcc version 3.2.2
OS:          Linux (i686) release 2.4.20-gentoo-r5

When I select a message in my Inbox then select 'Reply to All' the compose window that opens up does not have any recipients. This has happened for every message I've tried.

I installed KMail and KDE by doing an 'emerge kde' on my newly setup gentoo system.
Comment 1 Ingo Klöcker 2003-06-01 15:21:33 UTC
Subject: Re:  New: Selecting 'Reply-All' in KMAIL results in a new message with no recipients

I'm not able to reproduce this bug. Therefore the only way for you to 
find out why it doesn't work for you is to add some debug messages to 
KMMessage::createReply in kmmessage.cpp.

Furthermore it would be helpful if you could try the latest stable 
version of KMail from cvs. On kmail.ingo-kloecker.de you can find a 
short description of how to do that.

Last but not least, please attach a message (the headers of the message 
from View->View Source will suffice) for which is doesn't work to this 
bug report.

Comment 2 Eric Rosenberg 2003-06-01 20:26:49 UTC
I went through the emails in my inbox some more and found the following pattern. 
Reply-All does seem to work for messages where my default identity is explicitly in the 
recipient list of the message I'm replying to. It never seems to work for messages 
where my default identity is not in the recipients list.  
 
Take the following message for example, if I set my default identity to be either 
eric@ekrosenberg.com or leaderdev@computerwizards.com then Reply-All works fine. 
However, if I set my default identity to be eric@computerwizards.com then Reply-All 
does not work. The default identity from the settings is the thing that seems to 
determine if it will work or not, just selecting a different identity in the compose window, 
picking sticky, and then hitting Reply-All again doesn't affect the behavior. It still works 
or fails based on the presence of the Default identity in the source message. (Perhaps 
the fact that it filters the recipients of the reply based on the default identity is a 
seperate bug?) 
 
**** 
Received: by flag.computerwizards.com (mbox eric) 
 (with Cubic Circle's cucipop (v1.31 1998/05/13) Sun Jun  1 18:14:56 2003) 
X-From_: eric@ekrosenberg.com  Sun Jun  1 14:14:50 2003 
Return-Path: <eric@ekrosenberg.com> 
Received: from calvin (outgoingsmtpserver [216.22.223.4]) 
	by flag.computerwizards.com (8.12.9/8.12.9) with ESMTP id h51IEmOm032428; 
	Sun, 1 Jun 2003 14:14:48 -0400 
From: Eric Rosenberg <eric@ekrosenberg.com> 
To: leaderdev@computerwizards.com 
Subject: Test 
Date: Sun, 1 Jun 2003 14:11:32 -0400 
User-Agent: KMail/1.5.2 
Cc: eric@ekrosenberg.com 
MIME-Version: 1.0 
Content-Disposition: inline 
Content-Type: text/plain; 
  charset="iso-8859-1" 
Content-Transfer-Encoding: 7bit 
Message-Id: <200306011411.32994.eric@ekrosenberg.com> 
Status: R  
X-Status: N 
X-KMail-EncryptionState:   
X-KMail-SignatureState:   
 
Test 
*** 
Comment 3 Eric Rosenberg 2003-06-01 21:00:06 UTC
I wonder if this might be related to bug 5112. 
 
I noticed that if I set my identity to be ric@ekrosenberg.com and select the sample 
message from comment #2 that reply-all gives me a message addressed to 
leaderdev@computerwizards.com but eric@ekrosenberg.com is not included. 
 
 
Comment 4 Eric Rosenberg 2003-06-01 23:19:19 UTC
Created attachment 1699 [details]
Patch that seems to fix the problem

I'm uploading a VERY simple patch. I think it fixes this bug as well as bug
51112
Comment 5 Ingo Klöcker 2003-06-02 01:40:30 UTC
Subject: Re:  Selecting 'Reply-All' in KMAIL results in a new message with no recipients

Sorry, but this patch is too simple. For example it doesn't work if you 
reply to all to a message with the header
To: Eric Rosenberg <eric@computerwizards.com>
because "Eric Rosenberg <eric@computerwizards.com>" obviously doesn't 
start with "eric@computerwizards.com". Nevertheless "Eric Rosenberg 
<eric@computerwizards.com>" should be omitted if you reply to all. I'm 
working on a patch which is a little bit more complex and also cleans 
up a few other things.

The correct fix for bug 51112 (and probably also your bug) should be:
-     QString myAddr = getEmailAddr(msg->from());
+     QCString myAddr = getEmailAddr(msg->from()).lower();
     for (QStringList::Iterator it = recipients.begin();
          it != recipients.end(); ) {
-      if ((*it).find(myAddr,0,false) != -1) {
+      if( myAddr == getEmailAddr( *it ).lower() ) {

Please test it.

Comment 6 Eric Rosenberg 2003-06-02 02:24:47 UTC
Created attachment 1703 [details]
Revised Patch

Patch that works even if a name is present before the email address that should
be removed.
Comment 7 Till Adam 2003-06-05 17:14:14 UTC
*** Bug 51112 has been marked as a duplicate of this bug. ***
Comment 8 Ingo Klöcker 2003-06-07 21:31:22 UTC
Subject: Re:  New: Selecting 'Reply-All' in KMAIL results in a new message with no recipients

Thanks a lot for your collaboration, Eric. The bug will be fixed in 
KMail 1.5.3.