Bug 58823 - non scalable fonts (eg 100dpi) are unavailable
Summary: non scalable fonts (eg 100dpi) are unavailable
Status: RESOLVED DUPLICATE of bug 55617
Alias: None
Product: kcontrol
Classification: Unclassified
Component: kcmfonts (show other bugs)
Version: unspecified
Platform: Mandrake RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: rik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-23 01:07 UTC by Richard Neill
Modified: 2003-06-02 05:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Neill 2003-05-23 01:07:00 UTC
Version:            (using KDE KDE 3.1)
Installed from:    Mandrake RPMs
OS:          Linux

After installing some truetype fonts, KDE no longer has the 100dpi/75dpi fonts available to it. xfontsel still shows them, but KDE control panel does not. 

This is a problem because I find antialiased fonts are blurry/out of focus/cause eye-strain, and would prefer non-antialiased. But all the truetype fonts are designed for antialiasing, and look dreadful without it. However, the 100dpi fonts are intended for use without antialiasing, and look quite good that way.

It's possible that this is a feature; if so, I think it's a bad one. Some people don't like antialiasing!

There's more on what I did at http://www.richard.neill.hemscott.net/a22p-mdk9-1.html#fonts
In my view:

1) Best: Antialiasing OFF, using 100dpi fonts => quite smooth, very crisp
But impossible in KDE 3.1 unless all truetype fonts are removed from the system!

2)Tolerable: Antialiasing ON, set up optimally, using truetype fonts. 

3)Worst: Antialiasing OFF, using truetype fonts.
Comment 1 James Richard Tyrer 2003-06-01 03:12:59 UTC
Are you using FontConfig? 
 
If so, please run: 
 
fc-cache -v |grep 100dpi 
 
-- 
JRT 
Comment 2 Richard Neill 2003-06-02 02:04:36 UTC
You asked about Fontconfig - no, I'm not explicity using it (as in running
fontconfig-config from the command-line). I just started with a default KDE
installation, and used the KDE control centre font tool to add some more
MS-Windows TTF fonts.

The output of fc-cache -v | grep 100dpi is null, whether I run it as root or
not. Here's what I get from fc-cache -v run as root:

# fc-cache -v
fc-cache: "/usr/share/AbiSuite/fonts/": caching, 39 fonts, 0 dirs
fc-cache: "/usr/share/fonts/type1/greek/": skipping, 14 fonts, 0 dirs
fc-cache: "/usr/share/fonts/ttf/western/": skipping, 9 fonts, 0 dirs
fc-cache: "/usr/share/fonts/ttf/decoratives/": skipping, 30 fonts, 0 dirs
fc-cache: "/usr/share/fonts/default/Type1/": skipping, 35 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/TTF/": caching, 158 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/Type1/": skipping, 85 fonts, 0 dirs
fc-cache: succeeded

Please let me know if there's anything else you'd like me to try.

Regards

Richard
Comment 3 James Richard Tyrer 2003-06-02 05:56:35 UTC
KDE 3.1.2 
 
This has the same cause which is the improper editing of the: 
 
/etc/fonts/fonts.conf 
 
file by KFontInst. 
 
-- 
JRT 

*** This bug has been marked as a duplicate of 55617 ***