Bug 58615 - kmail crash on 4 MG text file
Summary: kmail crash on 4 MG text file
Status: RESOLVED DUPLICATE of bug 59069
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.5.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-17 20:07 UTC by michael
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michael 2003-05-17 20:07:18 UTC
Version:           1.5.1 (using KDE 3.1.1)
Compiler:          gcc version 2.95.4 20011002 (Debian prerelease)
OS:          Linux (i686) release 2.2.20

Haven't had a kmail crash in 6 months, but because of the unusual behavior trying to perform the backtrace, it might be related to resource consumption.  Had a 4 MG text file sent to me, and as it tried to render in the preview window, I noticed a long hang, and then a crash.  When trying to perform the backtrace, DrKonqi showed up in the task bar after 5minutes, but never got a backtrace, and the backtrace app seemed to crash too. (At least it dissappeared) A lot of swapping occurred, and finally after 10 minutes or so, the machine started to respond again.
Comment 1 michael 2003-05-17 20:08:53 UTC
PS.  We still have that bug that when Kmail crashes, you end up with all your recent 
sent messages appearing in the outbox folder on the next restart.  They do not have 
any body, just the subject line appears in the outbox folder, and until you manually 
delete them, you can't send mail. 
Comment 2 Stephan Kulow 2003-05-18 21:10:58 UTC
can you provide the text file somehow? Then I could try to get a stack trace. 
To me the bug is simply: you're running out of memory. And with out of memory 
it's a) hard to run a debugger and b) write any config data 
 
If the app is killed though, then it's killed most likely by the kernel, because you're 
running out of swap space too. 
Comment 3 michael 2003-05-19 17:33:43 UTC
Sorry, I was in a hurry to get some work down, and I deleted the text file so I could 
get on with reading my mail.  Not much help am I .. :) 
Nothing showed in the logs tho, pertaining to a OOM condition. 
I will see what I can do about replicating it..  Basically it was just a file listing of a 
backup, (picture the output of `find /`) 
 
Comment 4 Stephan Kulow 2003-09-20 15:17:05 UTC
the same underlying problem: suboptimal handling of out of memory situations. 

*** This bug has been marked as a duplicate of 59069 ***