Bug 57564 - CSS Blink property is ignored
Summary: CSS Blink property is ignored
Status: RESOLVED NOT A BUG
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Mandrake RPMs Linux
: NOR wishlist with 5 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-22 20:32 UTC by Albert Astals Cid
Modified: 2013-08-01 22:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Astals Cid 2003-04-22 20:32:44 UTC
Version:            (using KDE KDE 3.1)
Installed from:    Mandrake RPMs
OS:          Linux

Konqueror ignores 
text-decoration	: blink;
in CSS (http://www.w3.org/TR/REC-CSS2/text.html#lining-striking-props)

You can see it going to http://klt.sf.net with both Konqueror(Atention doesn't blinks) and Mozilla(Atention does blink)
Comment 1 Datschge 2003-04-22 21:13:24 UTC
To quote the W3 suggestion you linked yourself: "blink: (...) Conforming user agents 
are *not* required to support this value." I prefer it not being supported by khtml ever 
since I can't think of a more effective way to annoy users. 
Comment 2 Albert Astals Cid 2003-04-22 21:22:38 UTC
Ok, i now it is not required. This is because i marked it as a wish and not as a bug. 
 
Animated gifs can also be used to annoy the users (and more effectively in my opinion) 
and konqueror shows them, so i suppose you want them to be disabled in Konqueror. 
Comment 3 Datschge 2003-04-22 22:27:00 UTC
And I do have gif animations disabled. =) 
(an option like "animate gifs only on mouse hover" would be useful sometimes though) 
Comment 4 S Leiber 2003-06-08 15:14:10 UTC
If we integrate the funktion text-decoration: blink I think we can make a configuration to 
set the blink on (implement it and have a blinking text)/off(have the same situation like 
it is). I think many other browser interprate it and so I think khtml must it, too.   ;) 
I think it was a good way to make it configuratable because many user don't whant 
blinking text but some whant it!!   :) 
 
Sven 
 
Comment 5 Kai Lahmann 2003-06-15 01:13:34 UTC
pleaaaaaaaaaaaaase wontfix! It's so anoying....... 
Comment 6 Leo Savernik 2005-02-18 22:27:01 UTC
Oh no, now that we support marquee, we must support blink also.

However, *I* won't implement it.

Patches are welcome.
Comment 7 Hugo Rodrigues 2006-03-29 08:34:20 UTC
I would love to see it implemented either.
Comment 8 Hugo Rodrigues 2006-03-29 08:37:47 UTC
BTW in Konqueror 3.5.1 it is still not supported.
Comment 9 Michael Nottebrock 2007-03-24 20:21:16 UTC
There are probably a million more important things to implement in Konqueror, but OTOH, for http://fingr.us/ , it would make the joke just that little bit better.
Comment 10 Albert Astals Cid 2013-08-01 22:37:34 UTC
Since neither firefox nor chrome do support blink anymore i've decided to withdraw my wish. If someone else from the voters still want it, please create a new bug and explain why.