Bug 57527 - additional image information not maintained when rotating
Summary: additional image information not maintained when rotating
Status: RESOLVED DUPLICATE of bug 55777
Alias: None
Product: kuickshow
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Carsten Pfeiffer
URL:
Keywords:
: 59672 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-04-21 23:31 UTC by A T Somers
Modified: 2003-10-28 17:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A T Somers 2003-04-21 23:31:35 UTC
Version:           0.8.5 (using KDE 3.1.0)
Installed from:    SuSE
Compiler:          gcc version 2.95.3 20010315 (SuSE)
OS:          Linux (i686) release 2.4.18-4GB

A lot of digital camera's include additional information with a JPEG, containing things like date&time, shutter-timing, etc. When rotating a picture made with such a camera, this info is lost. I think that should not happen. I would expect maybe an additional field that says "Rotated by Kuickview", but not the loss of info.
Comment 1 Carsten Pfeiffer 2003-04-22 13:17:23 UTC
Subject: Re:  New: additional image information not maintained when rotating

On Monday 21 April 2003 23:31, you wrote:

> A lot of digital camera's include additional information with a JPEG,
> containing things like date&time, shutter-timing, etc. When rotating a
> picture made with such a camera, this info is lost. I think that should not
> happen. I would expect maybe an additional field that says "Rotated by
> Kuickview", but not the loss of info.

Hmm, indeed, that's very bad :-/ I'll try to implement lossless image rotation 
for jpegs, that would also preserve the other jpeg information.

The problem is that the image saving code is in Imlib, a separate library, 
which apparently doesn't handle those things. Maybe I should start 
maintaining imlib...

Best wishes
Carsten Pfeiffer
-----BEGIN PGP SIGNATURE-----

iQEVAwUBPqUkTaWgYMJuwmZtAQEM9ggApt2QrzKR7SuSJMN2AJAE9pNwVVjvf+u3
NHI/Mx3wDpkospSGBak1ESNhwxx3QT++2rHupJ56M1Uc4F9dPRADa4YqY4yY5ksL
SF2VrzbEi6PlpEFLBNoZ9Eh6WFu+gFOrXyKBGNy1r2iGlwbJtzRbO0ALpgeHHd18
9iYN2ITx5f5hFoTGphyl1BMvB7ad31BeewwDpLNRtLGpDi42UECbzeUW/TN7zyRi
SetQjQpIIFmzyZL573AVFn1h4rwRxki+asRGraHxoi8du1sNHnHrltj6EohtytfQ
Kz3MRUxGdBflsZcD3IXlmlidF6TPlHnXNsd5mwuS7AJ8zazvwXuNJg==
=BDDc
-----END PGP SIGNATURE-----

Comment 2 Aaron J. Seigo 2003-07-08 12:51:54 UTC
*** Bug 59672 has been marked as a duplicate of this bug. ***
Comment 3 Dominik Stadler 2003-10-23 09:03:29 UTC
I think Bug 55777 is a duplicate of this, one of them should be marked duplicate.
Comment 4 Datschge 2003-10-28 17:26:54 UTC
Indeed, thanks for the note. Please move CC and votes over to bug 55777 (which is older and has more votes already).

*** This bug has been marked as a duplicate of 55777 ***