Bug 57415 - First File Select Dialog should be able to turn off
Summary: First File Select Dialog should be able to turn off
Status: RESOLVED WORKSFORME
Alias: None
Product: koffice
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KOffice List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-18 11:11 UTC by Ismail Donmez
Modified: 2003-06-02 09:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ismail Donmez 2003-04-18 11:11:14 UTC
Version:            (using KDE Devel)
Compiler:          gcc 3.2.2 
OS:          Linux

Everytime I open kword it asks me to select a file to start it or creating a new document from a template but %90 of times I want to just fire up kword and start to write. So I shouldnt be need to see first dialog.

Most of software having these kind of dialogs just puts a checkbox on this dialog like "Dont show this dialog again." . So I think kword ( in general all koffice applications ) need a this kind of a checkbox to disable first file dialog.
Comment 1 tnagy 2003-04-18 22:39:47 UTC
It is like the bug/wish 56756, isn't it ?

The best solution would be to imitate the cute startup dialog box of Qt designer
(with that famous checkbox "do not show this dialog again").

I don't know if someone modified the dialog box, I tried to modify it -
unsuccessfully yet.
Comment 2 Holger Schröder 2003-04-19 13:21:22 UTC
Subject: Re:  First File Select Dialog should be able to turn off

Hi, 

i have also been looking into it, the dialogbox itself is the smallest 
problem. the real problem is, that exactly that dialogbox is used in all 
koffice programs, and not only in the case of initially starting the program, 
but also when you select file -> new... in the program and when you select 
insert -> object frame -> any application.

so the problem is i couldn
Comment 3 Ismail Donmez 2003-06-02 09:35:16 UTC
Implemented on CVS. Thnx!