Bug 57033 - "up" button/operation should parse current location for bulliten board-type urls
Summary: "up" button/operation should parse current location for bulliten board-type urls
Status: RESOLVED DUPLICATE of bug 93192
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-09 09:10 UTC by Brendan Orr
Modified: 2009-09-13 19:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brendan Orr 2003-04-09 09:10:51 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

When clicking the "up" button.  Konqueror shouldn't only just go up a directory.  For instance if one was reading through a forum and wished to go back to the list of forums (or topics), clicking up should go there.  Making the url go from
http://www.somewhere.org/forums/ultimatebb.php?ubb=get_topic;f=5;t=004317
to
http://www.somewhere.org/forums/ultimatebb.php  
which usually returns to the list of topics/forums.  Really easy to impliment by parsing the url for "?" and removing the characters afterword as well as the "?" itself.
Comment 1 Stephan Kulow 2003-04-09 10:39:42 UTC
this may make sense for your forum, but I'm not sure for how many scripts it would 
simply break. E.g. bugs.kde.org/show_bug.cgi?id=57033 makes sense, while 
show_bug.cgi doesn't really make sense. It will prompt for a bug number, so I don't 
close your bug report right away - it would be interersting to see what breaks :) 
Comment 2 Siegbert Baude 2004-11-13 01:45:47 UTC
I would like to invite all visitors of this bug to comment on my proposal in
http://bugs.kde.org/show_bug.cgi?id=93192 
Comment 3 FiNeX 2009-09-13 19:34:30 UTC

*** This bug has been marked as a duplicate of bug 93192 ***