Bug 56832 - adding closetab in toolbar crashes when no tabs exist when editing toolbars
Summary: adding closetab in toolbar crashes when no tabs exist when editing toolbars
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 53984 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-04-04 13:48 UTC by Konstantinos Arvanitis
Modified: 2003-05-29 16:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantinos Arvanitis 2003-04-04 13:48:48 UTC
Version:           3.1.0 (using KDE KDE 3.1)
Installed from:    SuSE RPMs
OS:          Linux

When Konqueror is open, but nothing is viewed in the main window, and the "Close Tab" button is in the main toolbar then if the "Edit Toolbars" dialog is opened, any change in the toolbars will crash Konqueror when the dialog closes. Any change in the toolbars is saved and is active the next time Konqueror is started though, so the error is probably somewhere after the dialog finishes.

I do not have the KDE debugging symbols compiled in, so the stack trace is not usefull.

When having a file displayed in the main window, no problems exist.
Comment 1 Waldo Bastian 2003-05-29 16:37:37 UTC
Subject: kdebase/konqueror

CVS commit by waba: 

CCMAIL: 56832-done@bugs.kde.org
* Don't crash when updating toolbars without a part loaded. (BR56832)
* Don't crash on stale file items (BR53717)


  M +2 -1      konq_mainwindow.cc   1.1172


--- kdebase/konqueror/konq_mainwindow.cc  #1.1171:1.1172
@@ -3815,4 +3815,5 @@ void KonqMainWindow::slotPopupMenu( KXML
   delete konqyMenuClient;
   m_popupEmbeddingServices.clear();
+  popupItems.clear();
 
   //kdDebug(1202) << "-------- KonqMainWindow::slotPopupMenu() - m_oldView = " << m_oldView << ", currentView = " << currentView
@@ -4143,5 +4144,5 @@ void KonqMainWindow::plugViewModeActions
   plugActionList( "viewmode", lst );
   // display the toolbar viewmode icons only for inode/directory, as here we have dedicated icons
-  if ( m_currentView->serviceType() == "inode/directory" )
+  if ( m_currentView && m_currentView->serviceType() == "inode/directory" )
     plugActionList( "viewmode_toolbar", m_toolBarViewModeActions );
 }


Comment 2 Waldo Bastian 2003-05-29 16:52:29 UTC
*** Bug 53984 has been marked as a duplicate of this bug. ***