Bug 56759 - Klipper and gvim both crash when text selected in gvim
Summary: Klipper and gvim both crash when text selected in gvim
Status: RESOLVED DUPLICATE of bug 61412
Alias: None
Product: klipper
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash
Target Milestone: ---
Assignee: Carsten Pfeiffer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-02 20:31 UTC by John Milton
Modified: 2004-05-15 13:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Milton 2003-04-02 20:31:04 UTC
Version:           0.9.5 (using KDE KDE 3.1)
Installed from:    Debian testing/unstable Packages
OS:          Linux

This only happens when I'm using gvim running remotely on OSF1 V4.0 1229 alpha.
Whenever I highlight text in gvim, both and klipper stop.
This is very repeatable.
It's been this way as long as I've been using KDE (since 2.?)

gvim does this:
BadValue (integer parameter out of range for operation)
Vim: Got X error
Vim: preserving files...
Xlib: unexpected async reply (sequence 0x1ee7)!
Vim: Finished.


and klipper does this:
...
(no debugging symbols found)...
#0  0x40f83b89 in wait4 () from /lib/libc.so.6
#1  0x40ff7000 in sys_sigabbrev () from /lib/libc.so.6
#2  0x40db5061 in waitpid () from /lib/libpthread.so.0
#3  0x405b23d3 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  0x40f109d8 in sigaction () from /lib/libc.so.6
#5  0x40861a7e in QClipboardWatcher::getDataInFormat(unsigned long) const ()
   from /usr/lib/libqt-mt.so.3
#6  0x408610a8 in QClipboardWatcher::format(int) const ()
   from /usr/lib/libqt-mt.so.3
#7  0x408b655f in QTextDrag::decode(QMimeSource const*, QString&, QCString&) ()
   from /usr/lib/libqt-mt.so.3
#8  0x408b0f7c in QClipboard::text(QCString&, QClipboard::Mode) const ()
   from /usr/lib/libqt-mt.so.3
#9  0x408b100c in QClipboard::text(QClipboard::Mode) const ()
   from /usr/lib/libqt-mt.so.3
#10 0x408b1058 in QClipboard::text() const () from /usr/lib/libqt-mt.so.3
#11 0x411fe544 in KlipperWidget::clipboardSignalArrived(bool) ()
   from /usr/lib/klipper.so
#12 0x411fedf8 in KlipperWidget::qt_invoke(int, QUObject*) ()
   from /usr/lib/klipper.so
#13 0x411ff029 in Klipper::qt_invoke(int, QUObject*) ()
   from /usr/lib/klipper.so
#14 0x408ff252 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/libqt-mt.so.3
#15 0x408ff10f in QObject::activate_signal(int) () from /usr/lib/libqt-mt.so.3
#16 0x40b62060 in QClipboard::selectionChanged() () from /usr/lib/libqt-mt.so.3
#17 0x4086010e in QClipboard::event(QEvent*) () from /usr/lib/libqt-mt.so.3
#18 0x408ab206 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#19 0x408aae47 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#20 0x40551ec8 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#21 0x40857f2c in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/libqt-mt.so.3
#22 0x4086a6cd in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/libqt-mt.so.3
#23 0x408bc7c7 in QEventLoop::enterLoop() () from /usr/lib/libqt-mt.so.3
#24 0x408bc684 in QEventLoop::exec() () from /usr/lib/libqt-mt.so.3
#25 0x408ab400 in QApplication::exec() () from /usr/lib/libqt-mt.so.3
#26 0x411fa2ac in main () from /usr/lib/klipper.so
#27 0x0804c940 in strcpy ()
#28 0x0804d49b in strcpy ()
#29 0x0804d92e in strcpy ()
#30 0x0804e4f1 in strcpy ()
#31 0x40effa51 in __libc_start_main () from /lib/libc.so.6
Comment 1 Matt Rogers 2004-04-14 15:35:45 UTC

    
Comment 2 Matt Rogers 2004-04-14 15:37:45 UTC
this is a duplicate of bug 61412, which has better info, and even a patch for 
QT which is reported to fix the problem.

Comment 3 Stephan Kulow 2004-05-15 13:01:53 UTC
reopen to fix database - somewhat out of sync
Comment 4 Stephan Kulow 2004-05-15 13:02:07 UTC

*** This bug has been marked as a duplicate of 61412 ***