Bug 56157 - option to tile the windows on the destop like in kvirc
Summary: option to tile the windows on the destop like in kvirc
Status: RESOLVED DUPLICATE of bug 59338
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 2 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 61113 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-03-19 20:56 UTC by Andreas
Modified: 2006-09-11 20:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas 2003-03-19 20:56:44 UTC
Version:            (using KDE KDE 3.1)
Installed from:    Gentoo Packages
OS:          Linux

It would be nice to tile alle the open windows on the desktop. At the moment I just can cascade or unclutter all the windows.
Sometimes I need to surf the web in one window and take a look into 2 konsoles at the same time. Well, I can place the windows by hand, but it would be easier to tile the windows with just a "click".
Beside this, it would be nice that the windows auto-resize if I close or open a window if I am in this tile mode.
This all reminds me of the Ion window manager. ;)
Comment 1 Lubos Lunak 2003-09-17 14:00:39 UTC
*** Bug 61113 has been marked as a duplicate of this bug. ***
Comment 2 Alexandre Bonneau 2004-08-25 03:01:58 UTC
That tiling feature would be really interresting for sure, but unlike kvirc, it would be far better to use specific window borders for the channel window. Those  window borders must be thin (or 'height-selectable') because it's not really handy when you have more than 6 channels titled.
Comment 3 Lubos Lunak 2005-11-01 16:36:20 UTC

*** This bug has been marked as a duplicate of 42023 ***
Comment 4 Lubos Lunak 2005-11-01 16:38:38 UTC
Wrong bug.
Comment 5 Lubos Lunak 2005-11-01 16:38:58 UTC

*** This bug has been marked as a duplicate of 59338 ***
Comment 6 Jon 2006-09-11 20:18:21 UTC
When two windows are tiled (or just have their borders snapped to each other), you could put a "split bar" between them; allowing you to resize both at once (one bigger and one smaller).  I filed this as Bug 133927